Ir ao conteúdo
  • Cadastre-se

Excel Célula data vazia retorna 00-01-1900


Ir à solução Resolvido por Patropi,

Posts recomendados

Boa noite

 

Gostaria que me ajudassem a resolver um problema.

 

Tenho uma planilha com duas abas.

 

Aba data

Aba livre

 

Na Aba livre, tenho uma formula que vai buscar as datas à Aba data, só que quando as células estão vazias, apresenta a data 00-01-1900

 

Eu gostaria que isso não acontecesse, gostaria que a célula ficasse em branco.

 

Em virtude disso, e como tenho uma formula para fazer a diferença entre a data Hoje e a data que possa estar nessa célula, vai fazer as contas à data 00-01-1900.

 

O que eu pretendo também é, se a celula está em branco ( zero ), o resultado deverá ser também a celula ficar em branco e não aparecer: 117 anos, 11 meses e 22 dias

 

A formula para ir buscar a data é esta: 

=SE(É.ERRO(CORRESP(LIN(A3);data!$K$7:$K$211;0));"";ÍNDICE(data!$F$7:$F$211;CORRESP(LIN(A3);data!$K$7:$K$211;0)))

 

A formula para fazer a DADTADIF é esta:

 

=SE(C9="";"";SE(E(DATADIF(C9;AGORA();"Y")=0;DATADIF(C9;AGORA();"ym")=0);DATADIF(C9;AGORA();"md")&" dias";SE(E(DATADIF(C9;AGORA();"md")=0;DATADIF(C9;AGORA();"ym")=0);DATADIF(C9;AGORA();"Y")&" anos";SE(DATADIF(C9;AGORA();"Y")=0;DATADIF(C9;AGORA();"ym")&" meses, "&DATADIF(C9;AGORA();"md")&" dias";SE(DATADIF(C9;AGORA();"md")=0;DATADIF(C9;AGORA();"Y")&" anos, "&DATADIF(C9;AGORA();"ym")&" meses";DATADIF(C9;AGORA();"Y")&" anos, "&DATADIF(C9;AGORA();"ym")&" meses, "&DATADIF(C9;AGORA();"md")&" dias")))))

 Podem me ajudar, sff??

 

Obrigado

 

Cumps

Link para o post
Compartilhar em outros sites
  • 11 meses depois...
  • Membro VIP

Boa tarde @ByaODP

 

Temos várias formas de resolver isso, uma delas -->  Menu arquivo --> Opções --> Avançado --> Opções de Exibição desta planilha --> desmarcar a opção ---> mostrar zero nas células cujo valor é zero.

 

Não se esqueça de clicar em Curtir.

 

Se a dúvida persistir, anexe uma planilha de exemplo que eu resolvo e posto novamente.

 

[]s

 

 

  • Curtir 1
  • Obrigado 1
  • Amei 1
Link para o post
Compartilhar em outros sites
  • 5 semanas depois...
  • 1 ano depois...
Em 22/11/2018 às 16:12, Patropi disse:

Boa tarde @ByaODP

 

Temos várias formas de resolver isso, uma delas -->  Menu arquivo --> Opções --> Avançado --> Opções de Exibição desta lanilha --> desmarcar a opção ---> mostrar zero nas células cujo valor é zero.

 

Não se esqueça de clicar em Curtir.

 

Se a dúvida persistir, anexe uma planilha de exemplo que eu resolvo e posto novamente.

 

[]s

 

 



Não consegui compreender.... consegue resolver o mesmo problema para o meu caso!

 

Pedidos.xls

Link para o post
Compartilhar em outros sites
  • Membro VIP

Boa noite Lenadro

 

Seja bem-vindo ao fórum!

 

Confira na planilha e dê retorno.

 

Veja no print abaixo a opção que desmarquei conforme eu havia descrito na postagem anterior.

A instrução que postei anteriormente é para versão do Excel 2007 e superior, se o teu Excel for 2003 ou anterior é diferente.

 

Se foi útil, clique em Curtir.

 

[]s

 

Desmarcar zero.jpg

19_08_20_Pedidos_Patropi.xls

Link para o post
Compartilhar em outros sites
  • 3 meses depois...

@Patropi Olá, sou nova aqui, mas preciso muito de uma ajuda, eu tentei desmarcar a opção que você disse por aqui, em opções, retornar zero para sumir a data 1900 e nao deu certo.. Estou anexando uma planilha caso vocês possam me ajudar.. obrigada.

 

A previsão de entrega, coluna AE deve ser de acordo com o ETA, se for SEA na coluna U soma 10 dias, se na coluna U for AIR somaria 5 dias, mas se o ETA está vazio, trás1900 :(

20201116_SHIPPING.SCHEDULE - teste.xlsx

Link para o post
Compartilhar em outros sites
  • mês depois...
  • 2 semanas depois...
  • Membro VIP

Bom dia, @Dgalvesc

 

Seja bem-vindo ao fórum!

 

Anexe um arquivo Excel, identificando as colunas onde teremos que atuar.

 

Normalmente até evitamos responder dúvidas sem arquivo anexado.

 

[]s

Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisa ser um usuário para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas comunidades sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

Aprenda a ler resistores e capacitores

EBOOK GRÁTIS!

CLIQUE AQUI E BAIXE AGORA MESMO!