Ir ao conteúdo
  • Cadastre-se

VisualG algoritmo para calculo de IRPF e INSS


Posts recomendados

Prezados, tenho um trabalho pra entregar e resolvi 98% do mesmo, só uma questão que não estou conseguindo, dai pediria ajudar de vcs...
O trabalho é este:
 

Faça um algoritmo em VisualG que, dado o salário bruto de uma pessoa, calcule o salário líquido sabendo que há o desconto de dois impostos, de acordo com a tabela abaixo:

Tabela IRPF

Tabela INSS

Salário até R$1500,00 será 0% de imposto;

Salário até R$3000,00 será 15% de imposto;

Salário acima de R$3000,00 será 27,5% de imposto.

Importo fixo de 11% do salário, sendo que o total do imposto não pode ser superior a R$400,00. (aqui onde o bicho pega, não sei como limitar a esse valor)

 

Atenção para calcular o IRPF você poderá utilizar uma estrutura de decisão encadeada, já para o INSS você poderá utilizar uma estrutura de decisão composta. Depois de avaliar as duas estruturas (IRPF e INSS) você então calculará o salário líquido.

Para que você possa conferir se seu algoritmo está correto execute com os valores do salário bruto dado abaixo e confira se o salário líquido será o apresentado abaixo:

Salário Bruto

Salário Líquido

R$ 5000,00

R$ 3225,00

R$ 3500,00

R$ 2152,50

 

Retorno de resultado

R$ 1800,00

R$ 1332,00

R$ 1400,00

R$ 1246,00

Meu algoritmo ficou assim (funcionando porém com valores que dão mais de R$ 400,00 de INSS ele não limita, porque não sei como fazer, me ajudem por favor):


 

var
   salarioB, irpf, inss: real
inicio
   //IRRF:
   //Até 1.500 | -
   //De 1.500 até 3.000 | 15,0
   //Acima de 3.000 | 27,5
   //INSS:
   //Fixo | 11,0 | Limite de desconto 400
   escreva("Digite o salário:")
   leia (salarioB)
   se (salarioB<1500.00)ou(salarioB=1500.00) entao
      inss<- salarioB*11/100
      escreval("Seu SalarioB Liquido é", salarioB - inss)
   senao
      se (salarioB>1500.01)e(salarioB<=3000.00) entao
         irpf<- salarioB*15/100
         inss<- salarioB*11/100
         escreval ("IRPF a ser descontado é", irpf)
         escreval ("INSS a ser descontado é", inss)
         escreval("O salário Líquido é", salarioB - irpf - inss)
      senao
         se (salarioB>3000.00)ou(salarioB= 3000.00) entao
            irpf<- salarioB*27.5/100
            inss<- salarioB*11/100
            escreval ("IRPJ a ser descontado é", irpf)
            escreval ("INSS a ser descontado é", inss)
            escreval("O salário Líquido é", salarioB - irpf - inss)

         fimse
      fimse
   fimse
fimalgoritmo

 

Link para o comentário
Compartilhar em outros sites

4 minutos atrás, Simon Viegas disse:

O texto está um pouco confuso. Por favor, posta uma foto do enunciado ou anexe o documento .pdf ou .doc, por exemplo.

 

No aguardo.

Muito obrigado pela ajuda. Eu consegui com um amigo resolver a questão... Obrigado mesmo pela atenção.

  • Curtir 1
Link para o comentário
Compartilhar em outros sites

  • Moderador
13 minutos atrás, Giovanni C Batista disse:

Muito obrigado pela ajuda. Eu consegui com um amigo resolver a questão... Obrigado mesmo pela atenção.

Já foi entregue?

 

De qualquer sorte, posta o enunciado e código para revisarmos... servi tanto para revisar o conteúdo em si, tanto para reapresentar ao professor (mesmo que não valha ponto).

 

No aguardo.

Link para o comentário
Compartilhar em outros sites

  • 3 anos depois...

Crie uma conta ou entre para comentar

Você precisa ser um usuário para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas comunidades sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

Redes-Wi-Fi-capa-3d-newsletter.png

EBOOK GRÁTIS!

CLIQUE AQUI E BAIXE AGORA MESMO!