Ir ao conteúdo
  • Cadastre-se
Pelucks

VisualG Erro nas variáveis no VisualG

Posts recomendados

Olá, estou aprendendo a programar e ainda sou iniciante, preciso fazer um trabalho que pede pra calcular o custo em reais de uma viagem de carro em pseudocódigo. Estou construindo o código mas quando coloco pra rodar ele da erro na linha das variáveis, não faço ideia do porquê desse erro.

 

Abaixo está o print do código com o erro, obrigado.

 

Screenshot_51.png

  • Amei 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Pelucks    nessa linha mostrada há duas variáveis que entre elas não foi colocada uma vírgula !

var
  //horas,velocidade,distancia,consumo,cidade destino : real
  horas,velocidade,distancia,consumo,cidade,destino   : real

 

e também lá embaixo nas linhas 18 e 19 existem erros , pois você colocou o sinal de igualdade junto a outras duas variáveis , mas o operador de atribuição no visualG é o dois pontos

   :=

junto com igual , ou o menor que junto com o menos ,

      <-

e o sinal de igualdade sozinho

     =

é usado para fazer comparações junto com o comando  se  .

Compartilhar este post


Link para o post
Compartilhar em outros sites

@devair1010 Muito obrigado pela resposta! Eu não sabia que não podiam haver espaços nas variáveis, achava que se colocasse a vírgula depois ele entenderia como uma coisa só.

 

Agora encontrei outro problema, poderia me ajudar? O trabalho me passou a fórmula que distância = horas * velmedia, ok as horas e a velocidade média é o usuário que insere, assim posso descobrir a distância, mas para descobrir o consumo tem essa fórmula: consumo = distância / quilometro. Pego a distância que descobri com a outra e aplico aqui, mas pro quilômetro ele me da essa tabela do print abaixo e eu tento fazer o programa reconhecer a cidade destino e aplicar o valor de quilômetros mas ele da erro.

 

Não sei se estou no caminho certo, mas foi o que pude pensar, obrigado.

Screenshot_52.png

Screenshot_53.png

  • Obrigado 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Pelucks      para postar seu código é melhor colocar como texto editável ,  pois imagens não vão muito bem , não,  pois é trabalhoso pra gente escrever tudo no editor do compilador , e ao postar use o botão  <> 

barap.jpg.a44f6fa81341cd703b68c9bf4abf5691.jpg

que está desenhado lá na barra de ferramentas da janela de postar , para que seu código não fique faltando nenhum caractere  ,  @Pelucks

apenas ajeitei seu código para que ele compile e rode sem erros , mas creio que não seja bem esse o resultado que você queira , então seu código ficou assim , 

Algoritmo " distancia "
var
  horas,velocidademedia,distancia   : real     //vai receber nùmeros decimais com vírgula
  minasgerais,cuiaba,cidade_destino : caractere// vai receber letras
  quilometro,consumo                : real
  cont                              : inteiro  //vai receber apenas números inteiros e sem ponto flutuante
  resposta                          : logico   // só recebe dois valores verdadeiro ou falso
inicio
  escreva("Digite Quantas Horas ")   // sem o L não pula para linha de baixo
  leia( horas )                      // não precisa colocar maiúscula
  escreva("Digite A Velocidade Média ")
  leia( velocidademedia )            // esse comando pula para a linha de baixo
  escreva("Digite A Cidade Destino ")// sem o L não pula para linha de baixo
  leia( cidade_destino )             // não precisa colocar maiúscula
  se cidade_destino = "minasgerais" entao//compara o conteúdo das variáveis
    escreval(" Quilômetro = 6")      // com o L pula para linha de baixo
  fimse                              // finaliza a comparação
  se cidade_destino = "cuiaba" entao //compara o conteúdo das variáveis
    escreval(" Quilômetro = 8")      // o L pula para linha de baixo
  fimse                              // finaliza a comparação
  distancia := horas*velocidademedia
  se (quilometro <> 0)  entao        // validar operação
    consumo := distancia / quilometro// pois é Impossível dividir por zero
  fimse                              // finaliza a comparação
  escreval                           // pular uma linha sem nada escrevar nela
  escreval(" Consumo ",consumo)      // o L pula para linha de baixo
Fimalgoritmo

descobrir o consumo tem essa fórmula: consumo = distância / quilometro

creio que o consumo seja distancia / qtd_de_litros_gastos .  

 

  • Amei 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Meu deus muito obrigado pela paciência! Nossa eu queria que me ensinassem tudo certinho assim na minha faculdade. Desculpa o incômodo eu não esperava que alguém fosse reescrever todo o código e ainda mais!!

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas comunidades sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

Aprenda_a_Ler_Resistores_e_Capacitores-capa-3d-newsletter.jpg

EBOOK GRÁTIS!

CLIQUE AQUI E BAIXE AGORA MESMO!