Ir ao conteúdo
  • Cadastre-se
KloZee

VisualG Desenvolvendo uma loja em VisualG

Posts recomendados

Poderiam me ajudar nesse problema de vetores? Estou meio perdido.

Como eu faria para ele acessar o primeiro repita para mostrar as opções (1), (2) e (3) na tela para escolha dos produtos que eu coloquei no outro repita abaixo?

Algoritmo "atividade"
Var
pass: inteiro
produtos: vetor[1..5] de caractere
preco: vetor[1..5] de real

Inicio
escreval("Digite a senha de acesso:")
leia (pass)
se pass = "1234" entao
escreval ("Acesso permitido, bem-vindo")
senao
escreval("Acesso Negado!")
fimse

repita
escreval("[1] - Lista de produtos")
escreval("[2] - Valor do pedido  ")
escreval("[3] - Finalizar pedido ")

repita
   limpaTela
   escreval("------------- INFO EXPRESS -------------")
   escreval(" 1- Monitor LED UHD 24' - $46,00        ")
   escreval(" 2- Mouse Steel Razer Series - $15,00   ")
   escreval(" 3- Teclado Razer RGB - $25,00          ")
   escreval(" 4- Ryzen 9 3900X - $100,00             ")
   escreval(" 5- GTX 3080 Super OC - $75,00          ")
   escreval("----------------------------------------")
fimalgoritmo

 

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá, alguns pontos:

 

1# Validação da senha

Duas formas:

   se pass = "1234" entao
      escreval ("Acesso permitido, bem-vindo")
   senao
      escreval("Acesso Negado!")
      fimAlgoritmo
   fimSe

ou

   se pass != "1234" entao
      escreval("Acesso Negado!")
   senao
      escreval ("Acesso permitido, bem-vindo")

      //aqui continua o programa




   fimSe

 

Uma outra forma apresentado no código abaixo...

 

 

 

2# Conceito de menu

Isso é meio que padrão... dê uma pesquisada no Google. Para dar um exemplo mais específico, segue um código:

algoritmo "atividade"
var
   //pass: inteiro
   pass: caractere
   produtos: vetor[1..5] de caractere
   preco: vetor[1..5] de real

   opcao: caractere
   pause: caractere

inicio
   escreval("Digite a senha de acesso:")
   leia(pass)

   se pass <> "1234" entao
      escreval("Acesso Negado!")
      //fimAlgoritmo
   fimse

   escreval("Acesso permitido, bem-vindo")
   leia(pause) //apenas para aguardar um ENTER ser pressionado
   repita
      limpaTela
      escreval("[1] - Lista de produtos")
      escreval("[2] - Valor do pedido  ")
      escreval("[3] - Finalizar pedido ")
      escreval("[0] - Sair             ")
      leia(opcao)

      escolha opcao
      caso "1"
         escreval("------------- INFO EXPRESS -------------")
         escreval(" 1- Monitor LED UHD 24' - $46,00        ")
         escreval(" 2- Mouse Steel Razer Series - $15,00   ")
         escreval(" 3- Teclado Razer RGB - $25,00          ")
         escreval(" 4- Ryzen 9 3900X - $100,00             ")
         escreval(" 5- GTX 3080 Super OC - $75,00          ")
         escreval("----------------------------------------")
         leia(pause)
      caso "2"
         escreval("Em construção")
      caso "3"
         escreval("Em construção")
      caso "0"
         escreval("")
      outrocaso
         escreval("Opcao inválida")
      fimEscolha

      leia(pause) //apenas para aguardar um ENTER ser pressionado
   ate opcao = "0"


fimAlgoritmo

 

Daí só ir implementando...

 

Qualquer dúvida é só perguntar.

 

  • Amei 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Simon Viegas muito obrigado pela explicação! ajudou de mais

Compartilhar este post


Link para o post
Compartilhar em outros sites

@KloZee, utilize esse código como base. Qualquer coisa vai redefinindo os items do menu e vai implementando uma coisa de cada vez.

 

Qualquer dúvida é só perguntar.

 

Obs.: NÃO implemente mais de uma coisa ao mesmo tempo. Escolha um detalhe simples e implemente... faça testes e veja se está funcionando... caso tenha erros, vá ajustando até fica mais ou menos bom... só não tente fazer muito coisa de vez... o segredo é sempre deixar o código rodável... (não confundir com pronto ou funcionando, mas apenas que não tenha erros de sintaxe)

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas comunidades sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

Aprenda a ler resistores e capacitores

EBOOK GRÁTIS!

CLIQUE AQUI E BAIXE AGORA MESMO!