Ir ao conteúdo
  • Cadastre-se
KloZee

VisualG RESOLVIDO Soma de 3 números

Posts recomendados

Algoritmo "atividade"

Var
n1 , n2 , n3: inteiro


Inicio
escreval("Digite o primeiro numero:")
leia(n1)
escreval("Digite o segundo numero:")
leia(n2)
escreval("Digite o terceiro numero:")
leia(n3)
se(n1 = 0 ou n2 = 0 ou n3 = 0)entao
escreval("Zero é numero invalido!")
fimse
escreval("A soma do numeros são", n1 + n2 + n3)

Fimalgoritmo

Problema apresentado: 1-      Escreve um programa que receba 3 números, e realize a soma dos três ate que um deles seja 0

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Simon Viegas  a linha 

se(n1 = 0 ou n2 = 0 ou n3 = 0)entao
escreval("Zero é numero invalido!")
fimse

está acusando de estar errada no VisualG

  • Curtir 2

Compartilhar este post


Link para o post
Compartilhar em outros sites

@KloZee Tente isolar as condições intercaladas por OU com parênteses:

Se ((n1 = 0) OU (n2 = 0) OU (n3 = 0)) Entao
  • Obrigado 2

Compartilhar este post


Link para o post
Compartilhar em outros sites

Só complementado...

Uma forma simples de entender seria que "precisa deixar cada sub-sentença isolada", ou seja: entre "()". Exemplo:

 

   se (n1 = 0) ou (n2 = 0) ou (n3 = 0) entao
      escreval("Zero é numero invalido!")
   senao
      escreval("A soma do numeros são", n1 + n2 + n3)
   fimSe

 

Outra forma comum é deixar a sentença principal também entre parênteses...

   se ((n1 = 0) ou (n2 = 0) ou (n3 = 0)) entao

Fica mais elegante. Obs.: em outras linguagem é comum ser obrigatório ter esses "()" mais externo.

 

 

Funciona assim: cada sub-sentença sempre retorna VERDADEIRO ou FALSO. Sempre um se tem uma sentença principal, que no caso é o resultado final das operações entres as sub-sentenças. No teu exemplo, existem essas 3 sub-sentenças... cada uma também resultam sempre em VERDADEIRO ou FALSO. Algo assim:

   se ((FALSO) ou (VERDADEIRO) ou (FALSO)) entao

Daí, a sentença final vai ser o resultado dessa sentença maior... Como tem um monte de "ou", significa na prática que "basta um ser VERDADEIRO para a sentença ser VERDADEIRO... por aí vai.

 

Um pouco sobre os operadores: https://www.apoioinformatica.inf.br/produtos/item/09-operadores

 

  • Curtir 1
  • Amei 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Simon Viegas e se eu quiser colocar um repita para realizar a soma dos três ate que um deles seja 0?

como eu poderia fazer

adicionado 9 minutos depois
8 minutos atrás, KloZee disse:

@Simon Viegas e se eu quiser colocar um repita para realizar a soma dos três ate que um deles seja 0?

como eu poderia fazer

por exemplo, eu colocar 3 + 5 + 19, nenhum desses numeros são 0!

aí ele repete o programa dnv, ai eu coloco por exemplo 0 + 3 + 5, ai ele faz o procedimento normal de falar que 0 é invalido

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites
12 minutos atrás, KloZee disse:

@Simon Viegas e se eu quiser colocar um repita para realizar a soma dos três ate que um deles seja 0?

como eu poderia fazer

 

Nesse caso, vai lá e faz isso... :)

 

 

Então, o segredo para resolver um problema é basicamente entender o problema!!! Pare para entender o que está sendo solicitado... daí vai precisar de um misto de experiências anteriores com criatividade. Exemplo:

 

 

32 minutos atrás, KloZee disse:

1 - Escreva um programa que receba 3 números e realize a soma dos três até que um deles seja 0

 

Então, entendo que vai "ir somando os 3 valores" e, quando um deles for 0, sai". 

algoritmo "atividade"
var
   n1 , n2 , n3: inteiro
inicio
   repita
      escreval("")
      escreval("Digite o primeiro numero:")
      leia(n1)
      escreval("Digite o segundo numero:")
      leia(n2)
      escreval("Digite o terceiro numero:")
      leia(n3)

      escreval("A soma do numeros são", n1 + n2 + n3)
   ate ((n1 = 0) ou (n2 = 0) ou (n3 = 0))
fimAlgoritmo

 

adicionado 2 minutos depois

É comum utilizar outra variável para armazenar a soma.. exemplo:

algoritmo "atividade"
var
   n1 , n2 , n3: inteiro
   soma: inteiro
inicio
   repita
      escreval("")
      escreval("Digite o primeiro numero:")
      leia(n1)
      escreval("Digite o segundo numero:")
      leia(n2)
      escreval("Digite o terceiro numero:")
      leia(n3)

      soma <- n1 + n2 + n3
      escreval("A soma do numeros são", soma)
   ate ((n1 = 0) ou (n2 = 0) ou (n3 = 0))
fimAlgoritmo

 

  • Curtir 1
  • Amei 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas comunidades sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

Aprenda a ler resistores e capacitores

EBOOK GRÁTIS!

CLIQUE AQUI E BAIXE AGORA MESMO!