Ir ao conteúdo
  • Cadastre-se

VisualG Numa fábrica trabalham homens e mulheres divididos em três classes: A Os que faz


Posts recomendados

Numa fábrica trabalham homens e mulheres divididos em três classes:
A Os que fazem até 30 peças por mês;
B Os que fazem de 31 a 35 peças por mês;
C Os que fazem mais de 35 peças por mês.
Os trabalhadores da classe A recebem salário mínimo. Os trabalhadores da classe B recebem
salário mínimo e mais 3% do salário mínimo por peça, acima das 30 iniciais. Os

trabalhadores da classe C recebem salário mínimo e mais 5% do salário mínimo por peça,
acima das 30 iniciais. Escreva um algoritmo que leia o valor do salário mínimo e uma
sequência com o seguinte “trio” de dados: o número do operário (um inteiro positivo e único
para cada operário), o número de peças fabricadas por mês (um inteiro não-negativo) e o
sexo do operário (a letra "F"ou "M"). A sequência de entrada é seguida pelo número 0.
Em seguida, o algoritmo deve calcular e escrever o salário total de cada operário, o total
da folha mensal de pagamento da fábrica, o número total de peças fabricadas por mês, a
média de peças fabricadas pelos homens de cada classe, a média de peças fabricadas pelas
mulheres de cada classe e o número do operário (ou operária) de maior salário (se houver
empate, deve ser escrito o menor número).

 

 

algoritmo "semnome"
// Função :
// Autor :
// Data : 19/08/2020
// Seção de Declarações
var
soma,soma1,soma2,soma3,m:real
n,nt,a,totalm1,totalm2,totalm3,totalf1,totalf2,totalf3,n1,n2,n3,n4,n5,n6:real
totalma,totalmb,totalmc,totalfa,totalfb,totalfc:real
s,b:caracter
inicio
// Seção de Comandos
nt:=0
soma:=0
escreval("Digite o salário minimo: ")
leia(m)
repita
   escreval("Digite o seu numero: ")
   leia(a)
   escreval("Digite o numero de peças fabricadas no mês: ")
   leia(n)
   escreval("Digite o sexo (M/F): ")
   leia(s)
   escreval("Deseja encerrar programa (S/N): ")
   leia(b)
   nt:=nt+n
   a:=1
   a:=a+1
   se (n>0)e(n<=30) entao
      soma1:=m
      escreval("salàrio total: R$",soma1)
   fimse
   se (n>30)e (n<=35) entao
      soma2:=((n-30)*(0.03*m)+m)
      escreval("salàrio total: R$",soma2)
   fimse
   se (n>35) entao
      soma3:=((n-30)*(0.05*m)+m)
      escreval("salàrio total: R$",soma3)
   fimse
   totalma:=0
   totalmb:=0
   totalmc:=0
   totalfa:=0
   totalfb:=0
   totalfc:=0
   totalfb:=totalfb+1
   se (s="M")e (n>0) e (n<=30) entao
      totalma:=1
      n1:=n
      totalm1:=n1+totalm1
   senao
      se (s="M") e (n>30) e (n<=35) entao
         totalmb:=1
         n2:=n
         totalm2:=totalm2+n2
      senao
         se (s="M") e (n>35) entao
            totalmc:=1
            n3:=n
            totalm3:=totalm3+n3
         senao
            se (s="F")e (n<=30) entao
               totalfa:=1
               n4:=n
               totalf1:=totalf1+n4
            senao
               se (s="F")e (n>30)e (n<=35) entao
                  totalfb:=1
                  n5:=n
                  totalf2:=n5+totalf2
               senao
                  se (s="F")e (n>35) entao
                     totalfc:=1
                     n6:=n
                     totalf3:=totalf3+n6
                  fimse
               fimse
            fimse
         fimse
      fimse
   fimse
ate (b="S")
soma:=soma1+soma2+soma3
totalma:=totalma+1
totalmb:=totalmb+1
totalmc:=totalmc+1
totalfa:=totalfa+1
totalfb:=totalfb
totalfc:=totalfc+1
totalm1:=totalm1
totalm2:=totalm2
totalm3:=totalm3
totalf1:=totalf1
totalf2:=totalf2
totalf3:=totalf3
escreval("a=",a)
escreval("totalfb=",totalfb)
escreval("totalf2=",totalf2)
escreval("folha mensal de pagamento da fabrica: R$",soma)
escreval("peças fabricadas no mês: ",nt)
escreval("media de pecas fabricadas pelos homens da classe A: ",(totalm1/totalma))
escreval("media de pecas fabricadas pelos homens da classe B: ",(totalm2/totalmb))
escreval("media de pecas fabricadas pelos homens da classe C: ",(totalm3/totalmc))
escreval("media de pecas fabricadas pelas mulheres da classe A: ",(totalf1/totalfa))
escreval("media de pecas fabricadas pelas mulheres da classe B: ",(totalf2/totalfb))
escreval("media de pecas fabricadas pelas mulheres da classe C: ",(totalf3/totalfc))
fimalgoritmo

 

Link para o comentário
Compartilhar em outros sites

  • Moderador

Caro usuário,

 

Seja bem-vindo ao Clube do Hardware.

 

No intuito de servir como fonte de pesquisa no caso de instituições de ensino, informamos que incorrer no resolvimento por completo de questões relacionadas a disciplinas escolares de cursos técnicos e faculdades podem ser revistas e removidas pela Equipe de Moderação do Clube do Hardware.

 

Para sanar dúvidas sobre esse tipo de problema, por gentileza, publique o passo a passo do desenvolvimento da questão, projeto, monografia ou conteúdo em dúvida para que possamos analisar se a resposta está correta ou não, ou para que possa ser auxiliado com a dúvida no desenvolvimento do exercício.

 

Infelizmente, não há como resolver os trabalhos pelos usuários. O objetivo do Clube do Hardware é auxiliar seus usuários a encontrar soluções para que possam sanar suas dúvidas, e não de trazer soluções prontas para seus usuários. Além disso, copiar e colar respostas que não são de autoria própria do qualquer usuário é considerado plágio, o que é ilegal.

 

Esperamos que compreenda.

 

Atenciosamente,

Equipe Clube do Hardware

  • Curtir 1
Link para o comentário
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisa ser um usuário para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas comunidades sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

Como se tornar um desenvolvedor full-stack

EBOOK GRÁTIS!

CLIQUE AQUI E BAIXE AGORA MESMO!