Ir ao conteúdo
  • Cadastre-se

VisualG Estrutura de Repetição - Marcar os divisíveis por 4


Ir à solução Resolvido por T.A.L,

Posts recomendados

Boa noite. Estou com um exercício pra resolver que eu estou dificuldade. Eis o exercício:

 

43) Desenvolva um algoritmo que mostre uma contagem regressiva de 30 até 1, marcando os números que forem divisíveis por 4, exatamente como mostrado abaixo:
30 29 [28] 27 26 25 [24] 23 22 21 [20] 19 18 17 [16]...

 

Infelizmente, os divisíveis por 4 estão se repetindo, mas também estão marcados. Não sei mais o que fazer. Até tentei usar outra variável, mas acabei me enrolando mais ainda. 

 

algoritmo "divisíveis"
var
   cont : inteiro 
inicio
   cont <- 30
   enquanto (cont >= 1) faca
      escreva (cont)
      cont <- cont - 1
      se (cont mod 4 = 0) entao
         escreval ("[", cont, "]")
      fimse
   fimenquanto
fimalgoritmo

image.png.6e2405b13a181aa455ae1476c3603a15.png

 

 

Link para o comentário
Compartilhar em outros sites

  • 4 semanas depois...
  • Moderador

Em relação ao espaçamento dos números entre os colchetes:

 

      se (c mod 4 = 0) entao
         escreva (" [", c:1, "]")
      senao
         escreva (c)
      fimse

 

Observe que se faz também necessário um espaço antes do "[".

 

ou

 

      se (c mod 4 = 0) entao
         escreva (" [", c:1, "]")
      senao
         escreva (" ", c:1)
      fimse

 

 

O VisualG insere um espaço automaticamente nas variáveis do tipo inteiro. Para removê-lo, definiria que quer reservar apenas um dígito. Como os números tem 2, não vai ter espaço extra.

 

image.png

 

Link para o comentário
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisa ser um usuário para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas comunidades sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

Redes-Wi-Fi-capa-3d-newsletter.png

EBOOK GRÁTIS!

CLIQUE AQUI E BAIXE AGORA MESMO!