Ir ao conteúdo
  • Cadastre-se

Não inicia após uso de software de redimensionamento de partições


Alan de Oliveira

Posts recomendados

Prezad@s,

 

Venho aqui tentar buscar uma luz com vocês. 

 

Eu tenho uma dual boot assim: C com win7 SP1, uma D com dados e outra E: com win10.

Como já feito outra vez, precisei de espaço na C e usei aquele método mover/redimensionar partições e fiz a redução na D restando um espaço não alocado entre a C e a D

 

Depois estiquei a C para catar este espaço não alocado e apliquei.

 

Como realizado outra vez, os arquivos na D: ficaram temporariamente sumidos e fui reiniciar o PC pra que acontecesse como no último redimensionamento que fiz pra voltar tudo ao normal dando visada aos arquivos. Só que dessa vez, ao invés de reiniciar com tudo redimensionado, o windows travou na tela da logo dando uma tela azul. Somente a E: com win10 reinicia agora. Os dados da D estão lá ainda intactos, consigo acessar os dados pelo win10. E estão lá no win7 os arquivos e a raiz de windows e tal...

 

Tentei passar o DVD de recuperação, nada. Tentei reinstalar o win7 por cima na C com a opção de preservar o sistema antigo e não aceita. Começa a instalar e diz: Relatório de compatibilidade - O computador iniciou usando o disco de instalação do windows. Remova o disco de instalação e reinicie o computador de modo que o windows inicie normalmente. Em seguida, insira o disco de instalação e reinicie a atualização. Não selecione "personalizada (avançada) para realizar uma atualização. Personalizada (avançada) instala uma nova cópia do windows e exclui seus programas e configurações. 

 

OBS: Meu DVD do win7 não tem o SP1 dentro. Já o win7 que tô tentando levantar me lembro que estava com o SP1. Eu teria que ter um instalador win7 já com SP1 pra não dar essa incompatibilidade aqui ou estou falando algo irrelevante?  

 

Fiquei pensando também se havia aquela partiçãozinha de 100 MB antes "reservado pelo sistema" e se o software apagou no redimensionamento das partições...🤔 Porque não tem nada lá assim. Se bem que tenho um outro notebook aqui que lá nem tem isso de partição reservada pelo sistema e dá boot de boa, então não sei se essa partição havia antes mesmo...

 

Tentei alguns procedimentos de boot rec pelo prompt de recuperação e nada. Tentei o Rebuild bcd e me retorna dizendo que tem 0 windows installed. Tentei aqueles comandos do diskpart pra selecionar, tornar ativa e tal e nada... 

 

Tentei recuperar partições mas o que acha aqui não encaixa no layout de partições, nem deixa selecionar.

 

Vejo que para evitar isso eu teria que ter uma imagem do sistema mas realmente não tive tempo de fazê-lo...

 

Algum anjo de Deus aí tem alguma luz de como recuperar este boot na C e levantar esse sistema de novo?

 

Grato desde já.

 

 

Link para o comentário
Compartilhar em outros sites

Se houve erro de particionamento eu recomendo MUITO que faça backup de tudo, remova o conteúdo que precisa, limpe o HD completamente de partições e reinstale o windows do zero.

Se sua MBR estiver danificada, o HD vira uma bomba relógio e você pode perder tudo a qualquer momento. Aproveite para rodar o HDtune e ver a aba Health do HD para descobrir se o problema é só lógico (particionamento) ou físico (desgaste do componente).

Link para o comentário
Compartilhar em outros sites

15 minutos atrás, WOZ Dods disse:

Se houve erro de particionamento eu recomendo MUITO que faça backup de tudo, remova o conteúdo que precisa, limpe o HD completamente de partições e reinstale o windows do zero.

Se sua MBR estiver danificada, o HD vira uma bomba relógio e você pode perder tudo a qualquer momento. Aproveite para rodar o HDtune e ver a aba Health do HD para descobrir se o problema é só lógico (particionamento) ou físico (desgaste do componente).

@WOZ Dods Grato pela atenção. Então, passei ele no Crystal Disk e lá tá dando tudo como saudável. Ainda não corri atrás de badblocks, posso dar uma olhada também. Será que houve erro de particionamento? Até porque as 3 ainda estão lá, foram feitas com aquele sistema de proteção de arquivos... Quanto a MBR tem uns programas pra reconstruir a MBR correto?

adicionado 3 minutos depois

 

9 minutos atrás, f_neto disse:

Instale no W10 o EasyBCD e com ele crie uma entrada para o W7

https://neosmart.net/EasyBCD/

Procure tutoriais no Youtube de como usar ele

@f_neto Grato, você diz que seria possível lá na E: onde está o win10 que passará a ser C : uando eu estiver nele, que daria pra eu por lá criar um tipo de boot que acharia o WIN7?

Link para o comentário
Compartilhar em outros sites

1 hora atrás, f_neto disse:

Exato

@f_neto  Eu tentei aqui com este easy bcd. Na hora eu fiquei até esperançoso sim porque mesmo com os dois sistemas aparecendo na tela de dualboot para escolher, eu pensei que talvez este simples fato de criar a entrada de novo, mesmo que sobrepondo uma reescrita, que algo em nível mais profundo que eu desconheça pudesse linkar de forma definitiva para chamar o win7 de novo. Mas, realmente não surtiu efeito. De qualquer forma, gostei da facilidade do programinha e já guardei ele aqui. Inclusive, se entendi direito, parece ter ele bootável, o que é bem legal caso a pessoa não tenha uma dual boot ou a pessoa tenha só 1 sistema e ele não inicie. 

 

Eu acabei de conseguir um outro método aqui. E Graças a Deus meu sistema subiu de novo. É um método todo manual. Vou dormir um pouco agora porque tô nessa maratona aqui após um monte de tentativas com a cabeça super ativa. Sentarei aqui de novo pra deixar a dica do que deu certo pra mim pra ajudar alguma pessoa que assim como eu venha aqui neste site pra conseguir uma luz.

 

Valeu!

adicionado 4 minutos depois

Opa! Para as pessoas que futuramente visitarem este tópico, eu já estava quase assumindo formatar e começar do zero o win7. Eu acabei de conseguir um outro método aqui. E Graças a Deus meu sistema subiu de novo. É um método todo manual. Vou dormir um pouco agora porque tô nessa maratona aqui após um monte de tentativas com a cabeça super ativa. Sentarei aqui de novo pra deixar a dica do que deu certo pra mim pra ajudar alguma pessoa que assim como eu venha aqui neste site pra conseguir uma luz.

 

Vou ali e já volto. Valeu!

Link para o comentário
Compartilhar em outros sites

Bom pessoal,

 

Após descansar a mente um pouco dessa loucura toda, eis que volto aqui como prometido pra passar o que me resolveu a questão.

 

OBSERVAÇÃO: Lembrando que este procedimento deu certo pra mim mas problemas de inicialização de sistemas podem ser causados por vários outros motivos e caso decida fazer o procedimento abaixo o faça por sua própria conta e risco.

 

Vamos lá, tentei tudo o que esta acima nas outras postagens como podem ver mas o que deu certo pra mim foi algo muito simples:

 

1- Criei um CD de reparação de sistema pelo outro PC que tinha win7 com SP1 (não sei se a presença deste sp1 é relevante no disco de reparação mas fiz assim mesmo);

2- Dei o Boot por este CD, coloquei no idioma Portuguese (Brazilian ABNT 2 por conta do meu teclado) e aguardei a procura pelos Windows instalados;

3- Aqui é onde tem o pulo do gato. Fui em "Load Drivers" e na janela "Add Drivers" que se abriu cliquei em OK;

4- Na janela "Open" indiquei o caminho: Computer\Selecionei a partição C:\Windows\System32\Config e dentro desta pasta apaguei o arquivo "SYSTEM" e imediatamente, dentro desta mesma pasta "Config" abri outra pasta chamada "RegBack" que é onde havia um backup mais antigo deste arquivo "SYSTEM". Copiei este arquivo "SYSTEM" e o colei na mesma  pasta que estava o "SYSTEM" corrompido  (C:\Windows\System32\Config, ou seja, no mesmo lugar onde eu havia apagado o "SYSTEM" com problema). Fui fechando e cancelando as janelas que estavam abertas até perguntar se eu queria reiniciar o PC e a mágica aconteceu. Meu PC reiniciou atravessando as telas sem travamento, perfeito como antes e já estou usando aqui com o dualboot perfeito.

 

Um grande abraço e paz aí para vocês.

 

 

adicionado 31 minutos depois

OBS:

Ah!!! E já passei um verificador de bad blocks. O HD está sem bad blocks e o programa indica boa saúde de disco. 

Link para o comentário
Compartilhar em outros sites

É similar ao procedimento para corrigir o erro do srtrail que causa o Repara Automático recorrente
Em resumo, copiar alguns arquivos da pasta regback para a pasta config, ou seja, a pasta um nível acima, por issto é importante os dois pontos após copy *.* ..
Nesta tela do erro clique em Opções Avançadas, abra o Prompt de Comando e digite:
cd \windows\system32\config\regback
      copy *.* .. ENTER
Irá pedir confirmação digite A ou Sim ou Yes 
Assista um vídeo, assista a partir dos 04:38

 

Link para o comentário
Compartilhar em outros sites

@f_neto

Eu só sei que fiquei feliz demais e tirei um peso enorme dos ombros quando executei aquela solução que postei aí. Foi muito simples de fazer e quando subiu o sistema quase chorei de felicidade porque eu só pensava no vacilo de não ter criado uma imagem ou clone de HD exatamente pra esta máquina. Quando iniciou de novo veio aquele pensamento: "Nossa!!! Acabei de ganhar horas e horas sem ter que reconfigurar todo o sistema do zero" kkkkkkk.

 

Quanto a este tipo de problema e solução que você manda aí por último, vendo isso a gente pensa: "Caramba, tem muitos tipos de problemas possíveis numa máquina né? A gente tem mais é que acordar e agradecer todos os dias por estar tudo funcionando a contento" 😆 

 

Um grande abraço e tudo de bom aí! 

Link para o comentário
Compartilhar em outros sites

19 horas atrás, f_neto disse:

É similar ao procedimento para corrigir o erro do srtrail que causa o Repara Automático recorrente
Em resumo, copiar alguns arquivos da pasta regback para a pasta config, ou seja, a pasta um nível acima, por issto é importante os dois pontos após copy *.* ..
Nesta tela do erro clique em Opções Avançadas, abra o Prompt de Comando e digite:
cd \windows\system32\config\regback
      copy *.* .. ENTER
 

 

A partir do Windows 10 1803 esse backup não é mais feito por padrão:

 

https://support.microsoft.com/en-us/help/4509719/the-system-registry-is-no-longer-backed-up-to-the-regback-folder-start

 

Para voltar a fazê-lo, tem no link a chave que precisa ser configurada no registro.

  • Curtir 1
Link para o comentário
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisa ser um usuário para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas comunidades sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

Aprenda a ler resistores e capacitores

EBOOK GRÁTIS!

CLIQUE AQUI E BAIXE AGORA MESMO!