Ir ao conteúdo
  • Cadastre-se

VisualG Alguem pode me auxiliar na resolução dessa questão (VISUALG)


Ir à solução Resolvido por Alice Braga,

Posts recomendados

Crie um algoritmo que ajude o Detran a saber, o total de recursos que foram arrecadados com a aplicação de multas de trânsito. O algoritmo deve ler as seguintes informações para cada motorista:

  • o número da carteira de motorista (de 1 a 4327)
  • número de multas;
  • valor da cada uma das multas.

Deve ser impresso o valor da dívida de cada motorista e ao final da leitura o total de recursos arrecadados (somatório de todas as multas). O algoritmo deverá imprimir também o número da carteira do motorista que obteve o maior número de multas.

 

var
   c, cart, nmult, mcart, mnmult:inteiro
   valor, total, totalgeral: real
inicio
   mnmult <- 0
   totalgeral<-0
   escreva("digite a carteira de motorista ou 0 (zero) para terminar:”)
   leia(cart)
   enquanto (cart <> 0) faça
      total <- 0
      escreva("digite o número de multas: ”)
      leia(nmult)
      para c de 1 até nmult repita
         escreva("digite o valor da multa: ”)
         leia(valor);
         total <- total + valor
      fimpara
      se (nmult > mnmult)
         mnmult <- nmult
         mcart <- cart
      fimse
      escreva("carteira de motorista: ”, cart)
      escreva("valor a pagar: ”, total)
      escreva("digite a carteira de motorista ou 0 (zero) para terminar:”)
      leia(cart)
      totalgeral<-totalgeral+total
   fimenquanto
   escreva("numero da carteira com maior numero de multas: ”, mcart)

   escreva("valor total arrecadado: ”, totalgeral)
fimalgoritmo

 

Link para o post
Compartilhar em outros sites

@Guilherme candido o que acontece quando você executa? nada? não me recordo bem do visualG mas se não me engano não precisa colocar chaves( { } ) depois do faça? 

Link para o post
Compartilhar em outros sites
  • Solução

o que tá dando errado? eu fiz aq e tá rodando direitinho, só mudei algumas palavras q estavam acentuadas, como "até" e "faça". 


Var
   // Seção de Declarações das variáveis
   c, cart, nmult, mcart, mnmult:inteiro
   valor, total, totalgeral: real

Inicio
   // Seção de Comandos, procedimento, funções, operadores, etc...
   mnmult <- 0
   totalgeral<-0

   escreva("Digite a carteira de motorista ou 0 (zero) para terminar:")
   leia(cart)
   enquanto (cart <> 0) faca
      total <- 0
      escreva("Digite o número de multas: ")
      leia(nmult)
      c<-c+1
      para c de 1 ate nmult faca
         escreva("Digite o valor da ", c,"º multa: ")
         leia(valor)
         total <- total + valor
      fimpara
      se (nmult > mnmult) entao
         mnmult <- nmult
         mcart <- cart
      fimse
      escreval("carteira de motorista: ", cart)
      escreval("valor a pagar: ", total)
      escreval("digite a carteira de motorista ou 0 (zero) para terminar:")
      leia(cart)
      limpatela
      totalgeral<-totalgeral+total

   fimenquanto

   escreval("numero da carteira com maior numero de multas: ", mcart)

   escreval("valor total arrecadado: ", totalgeral)


Fimalgoritmo

 

  • Obrigado 1
  • Amei 1
Link para o post
Compartilhar em outros sites
20 horas atrás, Guilherme candido disse:

(segue o código)

crie um algoritmo que ajude o detran a saber, o total de recursos que foram arrecadados com a aplicação de multas de trânsito. o algoritmo deve ler as seguintes informações para cada motorista:

-o número da carteira de motorista (de 1 a 4327)

-número de multas;

-valor da cada uma das multas.

deve ser impresso o valor da dívida de cada motorista e ao final da leitura o total de recursos arrecadados (somatório de todas as multas). o algoritmo deverá imprimir também o número da carteira do motorista que obteve o maior número de multas


var
c, cart, nmult, mcart, mnmult:inteiro
 valor, total, totalgeral: real
inicio
mnmult <- 0
totalgeral<-0
escreva("digite a carteira de motorista ou 0 (zero) para terminar:”)
leia(cart)
enquanto (cart <> 0) faça
total <- 0
escreva("digite o número de multas: ”)
leia(nmult)
para c de 1 até nmult repita
escreva("digite o valor da multa: ”)
leia(valor);
total <- total + valor
fimpara
se (nmult > mnmult)
mnmult <- nmult
mcart <- cart
fimse
escreva("carteira de motorista: ”, cart)
escreva("valor a pagar: ”, total)
escreva("digite a carteira de motorista ou 0 (zero) para terminar:”)
leia(cart)
totalgeral<-totalgeral+total
fimenquanto
escreva("numero da carteira com maior numero de multas: ”, mcart)

escreva("valor total arrecadado: ”, totalgeral)
fimalgoritmo

 

 

@Alice Braga estava dando vários erros , agora vejo que devido a acentuação. Muito obrigado pela sua ajuda.

  • Curtir 1
  • Amei 1
Link para o post
Compartilhar em outros sites
  • Moderador

@Guilherme candido, segue o enunciado:

 

Em 11/10/2020 às 22:35, Guilherme candido disse:

Crie um algoritmo que ajude o Detran a saber o total de recursos que foram arrecadados com a aplicação de multas de trânsito. O algoritmo deve ler as seguintes informações para cada motorista:

  • o número da carteira de motorista (de 1 a 4327)
  • número de multas;
  • valor da cada uma das multas.

 

Você precisaria ler o número da carteira para cada motorista e precisa respeitar essa faixa de valores. Nenhuma das duas coisas ainda foi implementada.

 

Adendo:

 

Sobre:

13 horas atrás, Alice Braga disse:

image.png

 

Esse trecho em destaque não tem funcionalidade no código (basta remover)... já que o c é reinicializado logo após.

 

Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas comunidades sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

livros-black-friday.jpg

SEMANA BLACK FRIDAY
Clube do Hardware

Todos os livros por apenas R$ 9,99 cada!

Eletrônica | Montagem de Micros | Redes