Ir ao conteúdo
  • Cadastre-se

VisualG Alguem pode me auxiliar na resolução dessa questão (VISUALG)


Posts recomendados

Fiz esse codigo mas não está compilando.

Escreva um algoritmo que encontre o quinto número maior que 1000, cuja divisão por 11 tenha resto 5.

Var
// Seção de Declarações das variáveis 

 I, CONTADOR: INTEIRO

Inicio
// Seção de Comandos, procedimento, funções, operadores, etc... 
 I <- 1000
CONTADOR <- 0
ENQUANTO ( CONTADOR < 5 ) FACA
SE (MOD (I,11) = 5) ENTAO
CONTADOR <- CONTADOR + 1
FIMSE
I <- I + 1
FIMENQUANTO
ESCREVA (I)

Fimalgoritmo

 

Link para o post
Compartilhar em outros sites
  • Moderador

@Guilherme candido, olá. Um "não está compilado" ficou muito genérico. Qual erro está dando? É no VisualG?

 

 

Mas vamos lá:

 

Testei teu código e deu:


image.png

 

Algo mais notável seria essa função mod. Como ela funciona? Vamos ver...

 

image.png

 

Opa! Parece que nem sequer é uma função, mas sim um "Operador Aritmético".

 

Logo, poderia ser algo como:

 

algoritmo "Nome do meu programa"
var
   i, contador: inteiro

inicio
   i <- 1000
   contador <- 0
   enquanto (contador < 5) faca
      se (i mod 11 = 5) entao
         contador <- contador + 1
      fimSe
      i <- i + 1
   fimEnquanto
   escreva (i)
fimAlgoritmo

 

 

Se no teu compilador* deu algum outro erro, poste aqui para analisarmos. É interessante analisar a partir do que ocorreu.

 

* O VisualG não compila códigos... ele apenas vai interpretando e executando linha a linha.

Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas comunidades sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

livros-black-friday.jpg

SEMANA BLACK FRIDAY
Clube do Hardware

Todos os livros por apenas R$ 9,99 cada!

Eletrônica | Montagem de Micros | Redes