Ir ao conteúdo
  • Cadastre-se

Excel Trazer o numero que mais vezes saiu"


Ir à solução Resolvido por deciog,

Posts recomendados

Prezados como trazer de uma tabela o numero que mais saiu ? tentei duas formulas mais sem exito, 

image.png.040592a124e036075f5795579cfc145a.png

 

=MODO.MULT(A1:O5) ela me traz o numero que mais vezes que aparece na tabela 

=CONT.SE(A1:O5;B7) me traz a quantidade de vezes que aparece na tabela 

gostaria que ficar assim 

image.png.6f2753b57e6fb086913664daaf81b34a.png

 

 

 

 

clube hardware.xlsx

Link para o post
Compartilhar em outros sites
  • Solução

@Srt2 < Bom Dia.

 

Usa esta formula

 

=SOMA(SE(CONT.SE(DESLOC($A$1:$O$5;LIN($A$1:$O$5)-LIN($A$1);0;1);E7)>0;1))

 

Confere se é destas forma que desejas
 
Se foi útil clica no curtir, na mãozinha, é uma forma de agradecimento pela ajuda
 
Decio

 

 

  • Curtir 2
Link para o post
Compartilhar em outros sites

Bom dia, @Srt2

 

Já existe uma resposta com o uso de fórmula do nosso amigo
@deciog (que é ótimo), mas gostaria de colocar uma outra forma
de ser executado e chegando na mesma solução só que feito em VBA 😉...

 

Abaixo o código que criei que pode ser executado por um
botão que você pode criar na Sheet "Planilha2":

Sub repetidoselecao()

 Dim xrepete As Integer
 Dim xreg As Range
 Dim ult As Long
 Dim a As Long
 Dim ws As Worksheet

   Application.ScreenUpdating = False
   Application.EnableEvents = False
 
 ult = Worksheets(2).Cells(Worksheets(2).Rows.Count, "E").End(xlDown).Row
 Set ws = Worksheets(2)

 Set xreg = Range("A1:O5")

 With ws
 
 For a = 7 To ult
  If Cells(a, 5).Value <> Empty Then
   .Cells(a, 5).Select
   xrepete = Application.WorksheetFunction.CountIf(xreg, ActiveCell)

   ActiveCell.Offset(0, 1).Select
   Selection = xrepete
   
      Range("A1").Select
  
  ElseIf Cells(a, 5).Value = Empty Then
    Exit Sub
    
  End If

Next

 End With
 
 Set ws = Nothing
 Set xreg = Nothing

   Application.ScreenUpdating = True
   Application.EnableEvents = True

End Sub


Este código pode ser inserido em um módulo; também estou disponibilizando
o arquivo "Ex_Contagem numero que mais saiu Solucao1 LB - 17-10-2020.zip",
já com o código e o botão, para melhor análise...

 

Espero que este código lhe sirva na sua questão...

 

Qualquer coisa estamos aqui para ajudá-lo...

 

Aguardando sua resposta e seu Feed Back ... não esqueça de clicar na "mãozinha" 😄

LaerteB 🙂

Ex_Contagem numero que mais saiu Solucao1 LB - 17-10-2020.zip

  • Curtir 1
Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas comunidades sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

907618_67f7_4.jpg

PROMOÇÃO RELÂMPAGO!

Curso "Arquitetura de Redes", de Gabriel Torres, por apenas R$ 22,90. Só até as 23h59min desta sexta-feira 23/10/2020!

CLIQUE AQUI E INSCREVA-SE AGORA MESMO!