Ir ao conteúdo
  • Cadastre-se

Excel Fórmula PROCV, mais valor mais próximo


Ir à solução Resolvido por deciog,

Posts recomendados

Boas, tenho o seguinte ficheiro, que contem 2 tabelas.

Quero identificar o valor na primeira tabela, baseado na segunda tabela.

Para isso criei um código único para cada linha.

Problema: Nesse código único ele pega a quantidade da tabela 1, mas na tabela 2 essa quantidade(em alguns casos pode variar, ser maior ou menor), fazendo com que o código único seja diferente e não associando assim o identificador.

 

Ficheiro em anexo, mais explicado e com exemplo.

 

Obrigado!

associar identificador.xlsx

Link para o post
Compartilhar em outros sites
  • Solução

@AfonsoMira , Bom Dia.

 

Usa desta forma


=SEERRO(ÍNDICE(TbIdentificadores!$A$2:$A$11;CORRESP(PROCV(D2;TbIdentificadores!$D$2:$D$11;1;0);TbIdentificadores!$D$2:$D$11;0));(ÍNDICE(TbIdentificadores!$A$2:$A$11;CORRESP((PROCV(D2;TbIdentificadores!$D$2:$D$11;1;1));TbIdentificadores!$D$2:$D$11;0))))

 

Confere se é destas forma que desejas
 
Se foi útil clica no curtir, na mãozinha, é uma forma de agradecimento pela ajuda
 
Decio
 

 

  • Curtir 1
Link para o post
Compartilhar em outros sites

@deciog É exatamente isso, muito obrigado. :)

Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisa ser um usuário para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas comunidades sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

Aprenda a ler resistores e capacitores

EBOOK GRÁTIS!

CLIQUE AQUI E BAIXE AGORA MESMO!