Ir ao conteúdo
  • Cadastre-se

VisualG O programa não lê o ENTAO


Posts recomendados

Visitante
algoritmo "lalala"
var
v:vetor [1..1] de real
inicio
escreval ("Digite")
leia (v[1])
se 1<v[1]<2 entao
   escreval ("Isso é maior que 1 e menor que 2")
fimse
se v[1]<1 entao
   escreval ("Isso é menor que 1")
fimse
se v[1]=>2 entao
   escreval ("Isso é igual ou maior que 2")
fimse
fimalgoritmo

  Criei esse código acima para demonstrar o problema que estou tendo em outro código, o problema é que quando o algoritmo chega na parte do "se" ocorre um erro, nesse código de exemplo acontece o mesmo erro que é "Esperava encontrar entao na linha 7".

Link para o post
Compartilhar em outros sites

@Dudu Kronbauer    são erros de syntaxe ,   aqui :

se v[1] < 2 entao    //  se 1<v[1]<2 entao  o q você quiz dizer com esse 1< antes do v[1] ?
   escreval("Isso é maior que 1 e menor que 2")
fimse
se v[1] >= 2 entao    //  se v[1]=>2 entao   o sinaL seria (  >=  )  maior que ou iguaL
   escreval("Isso é igual ou maior que 2")
fimse

 

Link para o post
Compartilhar em outros sites
  • Moderador

@Dudu Kronbauer,

 

13 horas atrás, Dudu Kronbauer disse:

Criei esse código acima para demonstrar o problema que estou tendo em outro código, o problema é que quando o algoritmo chega na parte do "se" ocorre um erro, nesse código de exemplo acontece o mesmo erro que é "Esperava encontrar entao na linha 7".

 

Veja a linha 7:

 

image.png

 

A "essência matemática" estaria meio que certa, mas não para a sintaxe do VisualG. Seria preciso separar em duas sentenças e utilizar um operador relacional para estruturar a expressão lógica. Exemplo:

 

   se  (1 < v[1]) E (v[1] < 2) entao
      escreval ("Isso é maior que 1 e menor que 2")

 


Observe que a sintaxe do VisualG exige o uso dos "()" quanto tem mais de uma sentença na expressão. (Se não colocá-los dará erro.)

 

 

Veja um teste:

 

image.png

 

 

Lembrando que a ordem dos membros não faria diferença. Poderia ficar assim:

 

   se (v[1] > 1) E (v[1] < 2) entao
      escreval ("Isso é maior que 1 e menor que 2")

 

Particularmente preferia dessa forma acima. Fica mais próximo de como "lemos"..."Se valor maior que 1 e valor menor que 2"

 

 

Sobe:

14 horas atrás, Dudu Kronbauer disse:

se v[1] => 2 entao
   escreval ("Isso é igual ou maior que 2")

 

 

 

Como sugerido por @devair1010, você inverteu a ordem. O comando correto seria >=. (em vez de =>).

 

 

Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisa ser um usuário para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas comunidades sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

Redes-Wi-Fi-capa-3d-newsletter.png

EBOOK GRÁTIS!

CLIQUE AQUI E BAIXE AGORA MESMO!