Ir ao conteúdo
  • Cadastre-se

VisualG Algoritmo de 4 opções (multiplicação, soma, diferença, sair)


Posts recomendados

Boa tarde pessoal, preciso de ajuda com esse algoritmo. Eu não consigo finalizar ele

 

algoritmo ""
var
   op: caractere
   n1, n2: inteiro
   op1, op2, op3: inteiro
   op4: caractere
inicio
   escreval("menu")
   escreval("1-multiplicacao")
   escreval("2-soma")
   escreval("3-diferenca")
   escreval("4-sair")
   escreval("digite a opcao desejada: ")
   leia(op)
   escolha(op)
      caso"1"
      leia(op1)
      escreva("digite um numero para calcular: ")
      leia(n1)
      escreva("digite outro numero: ")
      leia(n2)
      se (op1 <- n1 * n2) entao
         escreval("o resultado da multiplicacao sera: ", op1)
      fimse
      caso"2"
      leia(op2)
      escreva("digite um numero para calcular: ")
      leia(n1)
      escreval("digite outro numero: ")
      leia(n2)
      se(op2 <- n1 + n2) entao
         escreval("o total da soma sera de: ", op2)
      fimse
      caso"3"
      leia(op3)
      escreva("digite um numero para calcular: ")
      leia(n1)
      escreval("digite outro numero: ")
      leia(n2)
      se (op3 <- n1 - n2) entao
         escreval("a diferenca sera de: ", op3)
      fimse
      caso"4"
      leia(op4)
      escreval("voce escolheu nao calcular", op4)
   fimescolha
fimalgoritmo

 

Link para o post
Compartilhar em outros sites

@Victor Leo    seu código tem erros de syntaxe ,  você não observou o modo de escrever os comandos que precisam estar separados dos operadores ,  como ali nos casos , e para fazer outros cálculos você poderia colocar em um Loop , e seu código poderia ser assim  :

Algoritmo "finalizar"
Var
   // Seção de Declarações das variáveis
   op            : caractere
   n1, n2        : inteiro
   op1, op2, op3 : inteiro
   op4           : caractere
Inicio
   // Seção de Comandos, procedimento, funções, operadores, etc...
  repita
    limpatela
    escreval("menu")
    escreval("1-multiplicacao")
    escreval("2-soma")
    escreval("3-diferenca")
    escreval("4-sair")
    escreval("digite a opcao desejada: ")
    leia(op)
    escolha(op)
    caso "1"
      //leia(op1)
      escreva("digite um numero para calcular: ")
      leia(n1)
      escreva("digite outro numero: ")
      leia(n2)
      op1 <- n1 * n2
      //se (op1 < n1 * n2) entao    o Que você estaria tentando fazer nessa linha aqui  ? ? ! ! !
         escreval("o resultado da multiplicacao sera: ", op1)
      //fimse
    caso "2"
      //leia(op2)
      escreva("digite um numero para calcular: ")
      leia(n1)
      escreval("digite outro numero: ")
      leia(n2)
      op2 <- n1 + n2
      //se(op2 <- n1 + n2) entao  esse tipo de comparação nao funciona no VisuaLG
         escreval("o total da soma sera de: ", op2)
      //fimse
    caso "3"
      //leia(op3)
      escreva("digite um numero para calcular: ")
      leia(n1)
      escreval("digite outro numero: ")
      leia(n2)
     op3 <- n1 - n2
      //se (op3 <- n1 - n2) entao
         escreval("a diferenca sera de: ", op3)
      //fimse
    caso "4"
      leia(op4)
      escreval("voce escolheu nao calcular", op4)
    fimescolha
  ate op = "4"
fimalgoritmo

 

Link para o post
Compartilhar em outros sites
  • Simon Viegas alterou o título para Algoritmo de 4 opções (multiplicação, soma, diferença, sair)

Crie uma conta ou entre para comentar

Você precisa ser um usuário para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas comunidades sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

Aprenda a ler resistores e capacitores

EBOOK GRÁTIS!

CLIQUE AQUI E BAIXE AGORA MESMO!