Ir ao conteúdo
  • Cadastre-se

Visual Basic Desenvolver um algoritmo em pseudocodigo


Posts recomendados

Desenvolver seu algoritmo em pseudocódigo e atender aos seguintes critérios:

1 – Estrutura de Registro para armazenar 100 aparelhos celulares

2 – Um menu que apresente os seguintes módulos (procedimentos / funções)

2.1 – Cadastrar Produtos

2.2 – Listar todos (Aqui liste 3 características armazenadas)

2.3 - Listar 1 produto específico (Aqui liste 3 características armazenadas)

 

Considere as seguintes regras: 

1 - Controlar o cadastro para que não haja códigos idênticos.

2 - Informar ao usuário se produto foi cadastro ou não.

3 - Informar ao usuário que o produto não foi encontrado caso ocorra.

  • Curtir 1
Link para o post
Compartilhar em outros sites

 

@devair1010

Algoritmo “cadastroCelular”

Tipo
	produto = registro
	codigo: inteiro
	nome: Vetor[1..30] de caractere
	quantidade: inteiro
	valor: real
	espcor: Vetor[1..30] de caractere
	esptela: real
	memoriarom: inteiro
	memoriaram: inteiro
Fimregistro

Var
	Lista_prod: Vetor [1..100] de produto
	I: inteiro
	acha: logico
	resp: vetor[1..3] de caractere

Inicio

	para i de 1 ate 100 passo 1 faca

		Escreva(“Digite o código do produto “ ,i, “:”)
		Leia (lista_prod[i]. codigo)
		Escreva(“Insira o valor do produto “ ,i, “:”)
		Leia(lista_prod[i].valor)
		Escreva(“Digite o nome do produto “ ,i, “:”)
		Leia(lista_prod[i].nome)
		Escreva(“Digite a quantidade de produtos “ ,i, “:”)
		Leia(lista_prod[i].quantidade)
		Escreva(“Digite a cor do aparelho” , i, “:”)
		Leia(lista_prod[i].espcor)
		Escreva(“Digite o tamanho da tela do aparelho”, i, “:”)
		Leia(lista_prod[i].esptela)
		Escreva(“Digite a quantidade de memória ROM”, i, “:”)
		Leia(lista_prod[i].memoriarom)
		Escreva(“Digite a quantidade de memória RAM”, i, “:”)
		Leia(lista_prod[i].memoriaram)
	Fimpara

resp <- “sim”
	Enquanto (resp = “sim”) faca
    	Escreva(“Informe o código a ser pesquisado:”)
      	Leia(lista_prod.codigo)
i <- 1
acha <- falso
	Enquanto (i < = 100) e (acha= falso) faça
		Se (lista_prod[i].codigo = codigo) então

	acha <- verdadeiro
	Senão
	i <- i + 1
        fim_se
     fim_enquanto
	Se (acha = verdadeiro) então
		Escreva(“O preço é:”, lista_prod[i].valor)
		Escreva(“O nome do produto é:”, lista_prod[i].nome)
		Escreva(“O estoque do produto está em:”, lista_prod[i].quantidade)
		Escreva(“A quantidade de memória RAM é:”, lista_prod[i].memoriaram)
		Escreva(“A quantidade de memória ROM é:”, lista_prod[i].memoriarom)
	Senão
		Escreva(“Não há produto com o código informado”)
	fim_se
	Escreva(“Deseja continuar a pesquisa?”)
	Leia(resp)
 fim_enquanto

Fimalgoritmo

Pode verificar se está correto ?

  • Curtir 1
Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisa ser um usuário para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas comunidades sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

minicurso-montagem-popup.jpg

MINICURSO GRÁTIS!

Como ganhar dinheiro montando computadores!

CLIQUE AQUI E INSCREVA-SE AGORA MESMO!