Ir ao conteúdo
  • Cadastre-se

VisualG Informar se deu erro se 0 ou <100 e repetir operação se "S"


Posts recomendados

Boa noite,

 

Não estou conseguindo repetir a operação caso o usuário deseje nem limitar a quantidade de códigos no VisualG. Segue...

 

procedimento cadastrarprodutos
var
   i,codigo:inteiro
   op:caracter
   s,n: logico
inicio
   s<-verdadeiro
   codigo<-1
   para i de 1 ate 100 faca
      escreval("Informe o código do produto:(Código de 1 a 100)")
      leia(celular[i].codigo)
      se((codigo=0) ou (codigo>100)) entao
         escreva("ERRO")
         escreval("Quantidade máx. de produtos cadastrados")
         escreval(" ")
      senao
         escreval("Informe o modelo do produto")
         leia(celular[i].modelo)
         escreval("Informe a marca do produto")
         leia(celular[i].marca)
         escreval("Informe o preço do produto")
         leia(celular[i].preco)
         escreval("====================================")
      fimse
      escreval("Deseja repetir a operação? Digite s para Sim ou n para Não ")
      leia( op )
      se op <> "s" entao
         s <- falso
      fimse

 

Link para o post
Compartilhar em outros sites

Se você quer permitir que o usuário repita novamente as 100 leituras precisa colocar o seu código dentro de um Enquanto, se você quer confirmar se o usuário deseja continuar a cada uma das 100 leituras então troque o Para por um Enquanto usando um contador e também a variável op como condição.

 

Você não declarou o tipo celular nem declarou o vetor do tipo celular.

leia(celular[i].codigo)

 

Armazena um valor em uma variável de um elemento do vetor celular, já

se ((codigo=0) ou (codigo>100))

está se referindo apenas a uma variável chamada codigo e não a uma variável dentro de um elemento dentro de um vetor.

  • Curtir 1
  • Obrigado 1
Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisa ser um usuário para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas comunidades sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

Aprenda a ler resistores e capacitores

EBOOK GRÁTIS!

CLIQUE AQUI E BAIXE AGORA MESMO!