Ir ao conteúdo
  • Cadastre-se

VisualG Escolha caso - seleção múltipla não está funcionando corretamente


Ir à solução Resolvido por Maria Cristina Oliveira,

Posts recomendados

Oi:

 

Não estou conseguindo fazer esse programa funcionar corretamente:

 

Algoritmo "semnome"
Var
  modelo:caracter

Inicio
 escreva("entre com o modelo do calçado: ")
   leia(modelo)
   escolha modelo
   caso "mocassim"
      escreval("o modelo do calçado é masculino.")
   caso "rasteirinha"
      escreval("o modelo do calçado é feminino.")
   outrocaso
      escreval("o calçado ",modelo," é infantil.")
   fimescolha

Fimalgoritmo

 

image.png.8aed26107c07bcabe038d931c8e43531.png

  • Obrigado 1
Link para o comentário
Compartilhar em outros sites

@Maria Cristina Oliveira    testei seu código e ele está sim funcionando bem  , está bom e tudo certo .

Algoritmo "caso"
Var
  modelo : caracter
Inicio
  repita
    limpatela
    escreva("entre com o modelo do calçado: ")
    leia(modelo)
    escolha modelo
    caso "mocassim"
      escreval("o modelo do calçado é masculino.")
    caso "rasteirinha"
      escreval("o modelo do calçado é feminino.")
    outrocaso
      escreval("o calçado ",modelo," é infantil.")
    fimescolha
    escreva("outro calçaDo   S / N")
    leia(modelo)
  ate modelo = "n"
  limpatela
  escreval
  escreval
  escreval("thcau . . . !")
  escreval
  escreval
Fimalgoritmo

 

Link para o comentário
Compartilhar em outros sites

2 horas atrás, devair1010 disse:

 testei seu código e ele está sim funcionando bem  , está bom e tudo certo .

Oi::)

Então eu não sei o que está acontecendo. O seu código também não funcionou. Talvez esteja acontecendo alguma incompatibilidade :exorcize: entre o programa VisualG e meu computador ou versão do Windows.

Mas como isso só está ocorrendo com esse programa, tudo bem, deixa quieto.

Posso continuar a estudar.

Obrigada pela resposta.:thumbsup:

 

image.thumb.png.1b9b5e1ba7a5cd992bb0d971cd4e230f.png

  • Curtir 1
Link para o comentário
Compartilhar em outros sites

  • Solução
58 minutos atrás, devair1010 disse:

e esse vosualG que você está usando é uma versão antiga ,  e aqui uso o visualG 3.0 ,  esse aqui 

desse site

http://visualg3.com.br/baixe-o-visualg-3-0-7/

 

Oi: :)

Essa versão 3-0-7 não funciona direito aqui, no meu computador.

Aí baixei a versão anterior (3.0.6.5) e funcionou!

Obrigada pela ajuda.:thumbsup:

image.thumb.png.e4acb2bddd1e8bf49b86e0cf472a149e.png

  • Obrigado 2
Link para o comentário
Compartilhar em outros sites

@Maria Cristina Oliveira   olá ,  nesse site tem todos os comandos e explicações sobre ele e exemplos de como usá-los .

Quase Todos os Comandos do VisualG 3.0.6.5

visualG comandos e exemplos

 e tem outros comandos que foram criados mais recentemente e que não estão nesses sites ,  como 

mudacor -->   colorir as letras e o fundo da tela

arquivos --->  gravar dados em arquivo txt

mudacor("amarelo","frente")
mudacor("verde","fundos")

mudacor.thumb.jpg.770349474a5b6602ebe3f3630c28e0d3.jpg

  • Curtir 1
  • Obrigado 1
Link para o comentário
Compartilhar em outros sites

1 hora atrás, devair1010 disse:

olá ,  nesse site tem todos os comandos e explicações sobre ele e exemplos de como usá-los .

Oi:

Baixei esse manual em *.pdf.

Essa linguagem de programação não tem finalidade prática mas é muito boa para treinarmos o raciocínio.

Tenho certeza que alguém que domina o VisualG tem muito mais facilidade para programar em linguagem C.

Obrigada pelas dicas.:thumbsup:

  • Curtir 1
  • Obrigado 1
Link para o comentário
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisa ser um usuário para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas comunidades sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

Como se tornar um desenvolvedor full-stack

EBOOK GRÁTIS!

CLIQUE AQUI E BAIXE AGORA MESMO!