Ir ao conteúdo
  • Cadastre-se

Driver de audio em notebook Acer antigo não inicializa (error code 10)


Ir à solução Resolvido por Sheovion,

Posts recomendados

esses tempos atrás eu dei um jeito de consertar um antigo notebook da Acer que eu tinha aqui, um Aspire 4520 3485

depois de instalar o Windows 7 em um HD novo nele, o audio funcionava certinho, até na caixa de som embutida dele, mas um certo dia (o qual eu nem lembro e provavelmente nem cheguei a perceber no dia) o driver de audio parou de funcionar, nem mesmo conectando um fone na entrada P2 dele da certo, o Windows acusa de ser problema no driver mesmo, já tentei reinstalar, desinstalar e instalar de novo, instalar os drivers do próprio site da Acer recomendado pra esse note, e instalei até o mais recente suportado por ele, mas mesmo assim, o audio só não funciona, o driver fica dando esse "error code 10"

o estranho disso tudo é que um fone USB (provavelmente por usar drivers próprios) funciona certo, é só os conectores P2 (3,5 mm) e a caixa de som do note que não ta funcionando

e como eu disse, isso aconteceu do nada, acho difícil ter dado problema na caixa de som e na entrada P2 do note ao mesmo tempo do nada

alguma ideia de como resolver isso? já tentei acessar o visualizador de eventos do Windows pra checar as logs, mas não achei nada muito interessante lá, só um erro que da sempre ao iniciar, mas não parece ter nada a ver com audio
mas por precaução vou citar o mesmo abaixo:

 

Event filter with query "SELECT * FROM __InstanceModificationEvent WITHIN 60 WHERE TargetInstance ISA "Win32_Processor" AND TargetInstance.LoadPercentage > 99" could not be reactivated in namespace "//./root/CIMV2" because of error 0x80041003. Events cannot be delivered through this filter until the problem is corrected.

Link para o comentário
Compartilhar em outros sites

  • Moderador

@JoojPlays3  Boa noite! Aperte a combinação de teclas Windows + R e digite o comando msdt.exe -id DeviceDiagnostic. Será aberta a Solução de Problemas para Hardwares e Dispositivos. Siga o assistente e veja se o problema é resolvido.

Link para o comentário
Compartilhar em outros sites

agora, Rio McCloud disse:

@JoojPlays3  Boa noite! Aperte a combinação de teclas Windows + R e digite o comando msdt.exe -id DeviceDiagnostic. Será aberta a Solução de Problemas para Hardwares e Dispositivos. Siga o assistente e veja se o problema é resolvido.

a solução automática do Windows? já tentei isso, ela tenta reinstalar os drivers de audio, e da na mesma

ele falha

Link para o comentário
Compartilhar em outros sites

  • Moderador

@JoojPlays3 Certo. Antes de realizar o processo a seguir, crie um Ponto de Restauração do Sistema.

 

Abra o Gerenciador de Dispositivos, clique com o botão direito do mouse na entrada na lista referente ao som onboard e vá em Propriedades. Na janela que abrir, vá em Detalhes. Em Propriedade selecione GUID da Classe e anote o valor que é exibido.

 

Agora abra o Editor de Registro e navegue até a chave HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class. Dentro dela, procure a chave com nome igual ao valor exibido no Gerenciador de Dispositivos e entre nela. Veja se há itens chamados UpperFilters e LowerFilters. É perfeitamente normal existir só um deles. Exclua-o(s) e reinicie o Windows. Veja se o problema é corrigido.

Link para o comentário
Compartilhar em outros sites

28 minutos atrás, Rio McCloud disse:

@JoojPlays3 Certo. Antes de realizar o processo a seguir, crie um Ponto de Restauração do Sistema.

 

Abra o Gerenciador de Dispositivos, clique com o botão direito do mouse na entrada na lista referente ao som onboard e vá em Propriedades. Na janela que abrir, vá em Detalhes. Em Propriedade selecione GUID da Classe e anote o valor que é exibido.

 

Agora abra o Editor de Registro e navegue até a chave HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class. Dentro dela, procure a chave com nome igual ao valor exibido no Gerenciador de Dispositivos e entre nela. Veja se há itens chamados UpperFilters e LowerFilters. É perfeitamente normal existir só um deles. Exclua-o(s) e reinicie o Windows. Veja se o problema é corrigido.

UpperFilter tinha, eu deletei e reiniciei
mesmo assim não fez efeito

Link para o comentário
Compartilhar em outros sites

  • Moderador

@JoojPlays3 Certo. O que eu recomendaria você fazer é voltar num Ponto de Restauração do Sistema anterior ao problema, mas como você diz que não sabe quando isso começou, execute uma Instalação de Reparação do Windows. Monte uma mídia de instalação do Windows 7 num pendrive, avance normalmente, mas ao invés de selecionar Personalizada na seção a seguir, selecione Atualização. Ela manterá os arquivos, configurações e aplicativos. Mas lembre-se: não faz mal fazer backup dos seus dados antes de realizar esta operação.
 

image.png.f93e07ceee7cdc55a729b81e7b9c1c36.png

Link para o comentário
Compartilhar em outros sites

2 minutos atrás, Rio McCloud disse:

@JoojPlays3 Certo. O que eu recomendaria você fazer é voltar num Ponto de Restauração do Sistema anterior ao problema, mas como você diz que não sabe quando isso começou, execute uma Instalação de Reparação do Windows. Monte uma mídia de instalação do Windows 7 num pendrive, avance normalmente, mas ao invés de selecionar Personalizada na seção a seguir, selecione Atualização. Ela manterá os arquivos, configurações e aplicativos. Mas lembre-se: não faz mal fazer backup dos seus dados antes de realizar esta operação.
 

image.png.f93e07ceee7cdc55a729b81e7b9c1c36.png

é uma boa ideia, vou fazer isso amanhã, não to afim de virar a noite fazendo instalação do Windows hoje

Link para o comentário
Compartilhar em outros sites

  • Solução
14 horas atrás, Rio McCloud disse:

@JoojPlays3 Certo. O que eu recomendaria você fazer é voltar num Ponto de Restauração do Sistema anterior ao problema, mas como você diz que não sabe quando isso começou, execute uma Instalação de Reparação do Windows. Monte uma mídia de instalação do Windows 7 num pendrive, avance normalmente, mas ao invés de selecionar Personalizada na seção a seguir, selecione Atualização. Ela manterá os arquivos, configurações e aplicativos. Mas lembre-se: não faz mal fazer backup dos seus dados antes de realizar esta operação.
 

image.png.f93e07ceee7cdc55a729b81e7b9c1c36.png

mesmo depois de tudo isso, o problema continua, provavelmente eu não devo ter conectado os cabos das entradas de audio/caixa de som direito na hora de remontar o note e eles acabaram escapando com o tempo

de qualquer forma, eu já ia comprar um fone USB mesmo então não tem tanto problema quanto a isso, mas obrigado pela ajuda

Link para o comentário
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisa ser um usuário para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas comunidades sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

Redes-Wi-Fi-capa-3d-newsletter.png

EBOOK GRÁTIS!

CLIQUE AQUI E BAIXE AGORA MESMO!