Ir ao conteúdo
  • Cadastre-se

Calc Relatório trimestral - índice e corresp


Ir à solução Resolvido por Schiavinatto,

Posts recomendados

Olá, pessoal

 

Estou tentando criar uma planilha de relatório trimestral onde na aba "trimestre" será do relatório e na outra aba a base de dados.

 

Na aba trimestre ao digitar o número 1 na célula A1 deveria trazer o resultado apenas do primeiro trimestre. Ao digitar o número 2, trazer resultado apenas do segundo trimestre e assim por diante...

 

Criei uma fórmula de índice, corresp e linha, porém ao digitar o número 1 na célula A1 o resultado mostrado é de toda a base de dados e não apenas a informação de um trimestre.

 

O resultado na aba trimestre deveria ser:

1 trimestre: item A ao E (mostra do item F até S incorretamente)

2 trimestre: item F ao S (mostra os itens T, U, V incorretamente )

3 trimestre: item T e U (mostra o item V incorretamente)

4 trimestre: item V (este mostrou certo, mas ficou cheio de número 0)

 

Alguém poderia dar uma ajudinha na fórmula? 😀

 

P.S: Salvei o arquivo no formato xlsx porque não é possível fazer upload em .ods. Entretanto a planilha será utilizada no Libre Office.

 

 

trimestre.xlsx

Link para o comentário
Compartilhar em outros sites

@Schiavinatto

 

Obrigada pela ajuda. Era realmente o que eu estava precisando. Se possível você poderia explicar a parte em negrito da fórmula? =SEERRO(ÍNDICE($DADOS.$C$2:$C$200;CORRESP(1;($DADOS.$D$2:$D$200=MENOR($DADOS.$D$2:$D$200;LINHA()-3));0));"")

 

Gostaria de entender para poder usar em outras situações quando for necessário. 😀

Link para o comentário
Compartilhar em outros sites

Não querendo abusar, mas já abusando novamente...

 

A fórmula funcionou certinho no LibreOffice Calc, conforme fui fazendo o preenchimento dos dados. Entretanto, quando importei a planilha para o Google Planilhas não funcionou (não mexi na fórmula). Alterei os trimestres no Google e não retornou as informações do "nº do processo". Como tem dias que trabalho em home office aí acabo utilizando as duas versões (no calc e no google). Seria necessário fazer alguma adaptação?

Link para o comentário
Compartilhar em outros sites

@SkaterGirl

10 horas atrás, SkaterGirl disse:

@Schiavinatto

 

Obrigada pela ajuda. Era realmente o que eu estava precisando. Se possível você poderia explicar a parte em negrito da fórmula? =SEERRO(ÍNDICE($DADOS.$C$2:$C$200;CORRESP(1;($DADOS.$D$2:$D$200=MENOR($DADOS.$D$2:$D$200;LINHA()-3));0));"")

 

Gostaria de entender para poder usar em outras situações quando for necessário. 😀

 

Sobre a parte negrito $DADOS.$D$2:$D$200 esta é a coluna onde é procurada a referência a parte =MENOR($DADOS.$D$2:$D$200;LINHA()-3  a funçãp menor requer um indice, o primeiro menor (1) que sera o primeiro da sequencia a ser localizado para não ser necessári alterr o 1 para 2 nas linhas seguintes uso a formula ;LINHA()-3

9 horas atrás, SkaterGirl disse:

Não querendo abusar, mas já abusando novamente...

 

A fórmula funcionou certinho no LibreOffice Calc, conforme fui fazendo o preenchimento dos dados. Entretanto, quando importei a planilha para o Google Planilhas não funcionou (não mexi na fórmula). Alterei os trimestres no Google e não retornou as informações do "nº do processo". Como tem dias que trabalho em home office aí acabo utilizando as duas versões (no calc e no google). Seria necessário fazer alguma adaptação?

 

Desconheço o funcionamento do Google Planilhas, só uso e desenvolvo para o LibreOffice, desde 1998 quando se chamava StarOffice.

 

Sugestão, mantenha uma conta em uma nuvem ( ex: Dropbox / Mega ) com a pasta, dos arquivos, compartilhado nas maquinas, assim poderá usar o LibreOffice em todas as máquinas.

  • Amei 1
Link para o comentário
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisa ser um usuário para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas comunidades sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

Redes-Wi-Fi-capa-3d-newsletter.png

EBOOK GRÁTIS!

CLIQUE AQUI E BAIXE AGORA MESMO!