×
Ir ao conteúdo
  • Cadastre-se

Excel soma de despesas por mês


Ir à solução Resolvido por Patropi,

Posts recomendados

  • Moderador
  • Solução

Boa  noite,  @R10SIQUEIRA

 

Copie e cole a formula abaixo na célula A19.

Lembre-se de selecionar um mês na célula B19 e lançar valores nos meses, senão a formula irá retornar zero.

 

=SOMARPRODUTO(--(TEXTO($Q$1:$AD$1;"mmmm")=B$19)*($A$2:$A$14<>"");($Q$2:$AD$14))

 

OBS. : Sempre poste um exemplo com dados (fictícios) lançados para facilitar os testes.

 

Dê retorno.

 

[]s

  • Curtir 1
Link para o comentário
Compartilhar em outros sites

A forma mais produtiva de armazenar dados no Excel é em linha, crie uma coluna p/ Data e insira suas informações abaixo dela. Posteriormente, se você quiser visualizar seus dados em colunas mensais o Excel tem a ferramenta de Tabela Dinâmica q é muito fácil de montar e bem ágil. Colocando seus dados da forma q você está fazendo você terá dificuldades crescentes de programação, tendo de demarcar dezenas de colunas quando você poderia se limitar as colunas principais de uma tabela ordenada por Data.

Link para o comentário
Compartilhar em outros sites

Valeu @Patropi sempre me ajudando

 

Obrigado!

 

R10SIQUEIRA

ultima questão!!!!!

 

prometo pra colocar um filtro por contrato tem três, gostaria do filtro por mês e contrato, coloquei um  exemplo na planilha

 

 

28_10_21_despesas dos contratos.xlsx

 

28_10_21_DESPESAS DOS CONTRATOS.xlsx

Link para o comentário
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisa ser um usuário para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas comunidades sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

Aprenda a ler resistores e capacitores

EBOOK GRÁTIS!

CLIQUE AQUI E BAIXE AGORA MESMO!