Ir ao conteúdo
  • Cadastre-se

Posts recomendados

Tenho dois algoritimos que deve ser escrito em portugol nao consigo resolver se algum puder me ajudar!!!!! vlwwwwwwww^_^

Escrever um algoritimo para ler dois valores. Apos a leitura deve-se calcular a soma dos valores lidos e armazenar -la em variavel.

Apos o calculo da soma escrever o resultado e escrever tambem a pergunta.

Novo calculo (s/N)? deve ser ler a resposta e se a resposta for 's', deve -se repetir todos os comandos novamente, mas se a resposta for 'n' o algoritimo deve ser finalizado escrevendo a mensagem 'Fim do programa'

Escreva um algoritimo para ler a nota de 30 alunos calcular a media da turma e escrever quantos alunos tiveram a nota acima da média!!!

Link para o post
Compartilhar em outros sites

Escreva um algoritimo para ler a nota de 30 alunos calcular a media da turma e escrever quantos alunos tiveram a nota acima da média

algoritmo "nota"

var A vetor[30], i, nota, media, count

Inicio

Escreva ("Informe as 30 notas:")

Para i de 1 ate 30 faça

Leia A

Fimpara

nota <- 0

Para i de 1 ate 30 faça

nota <- nota + A

Fimpara

media <- nota / 30

count <- 0

Para i de 1 ate 30 faça

Se A > media então

count <- count+1

Fimse

Fimpara

Escreva ("Alunos acima da media:", count)

Fim

ACHO que ta certo

Link para o post
Compartilhar em outros sites

algoritmo "soma"

var

n1,n2,result:inteiro

resp:caracter

inicio

resp <- "s"

enquanto resp = "S" faca

escreval("Digite O Primeiro Numero:")

leia(n1)

escreval("Digite O Segundo Numero:")

leia(n2)

result <- n1 + n2

escreval("Resultado:",result)

escreval("Novo Calculo")

escreval("Sim(s),Não(n)")

leia(resp)

fimenquanto

escreval("Fim Do Programa")

fimalgoritmo

Espero Ter Ajudado Esta Correto O Algoritmo... :lol:

Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisa ser um usuário para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas comunidades sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

Aprenda a ler resistores e capacitores

EBOOK GRÁTIS!

CLIQUE AQUI E BAIXE AGORA MESMO!