Ir ao conteúdo
  • Cadastre-se

Ponte H com MOSFETs?


Posts recomendados

Quanto ao resistor, pode não ser necessário, dependendo de onde e como o circuito for ligado.

Esse resistor de "pull-dowl" é usado pra garantir que o mosfet fique desligado quando o circuito não estiver ligado em nada, ou, quando há um circuito, para facilitar o desligamento do mosfet.

Link para o post
Compartilhar em outros sites

Estou com outro tópico falando sobre o acionamento de mosfets canal N em ponte H com a ajuda do CI HIP4081AIP. porém surgiram outras duvidas , e vi que este tópico tem mais a ver.

Nota-se que a mobilidade dos elétrons é quase 3 vezes maior que a das lacunas. Desta forma, fica muito mais fácil produzir um mosfet canal N com baixo Rds(on) (e barato também).

Fazia tempo que eu queria enteder isso. Obrigado!

Foi mencionado aqui o tal diodo que evita a corrente reversa, porém estava testando um mosfet (IRF1404) o motor estava rodando a 10v e 1.4A ficou ligado por um bom tempo, desliguei a fonte(repentinamente) e quando liguei novamente o circuita estava em curto. O mosfet queimou. (perdi $10)

O mosfet estava ligado direto, apenas com um resistor de 1k servindo de pull-down. Não consegui imaginar porque ele queimou sem pensar na corrente reversa. Alquem tem alguma explicação?

Link para o post
Compartilhar em outros sites

Essa corrente reversa chama se corrente de cauda, no momento e em que desativamos um mosfet ele nao chega a comutar com perfeição causando mudança abrupta do sentido da corrente, esse diodo em antiparalelo portege o mosfet contra essa corrente.

porém acho que seu caso pode ser FCEM gerada na comutação do mosfet, pois quando chavea se a bobina com o terra voce provoca um aumento absurdo de tensão recaindo sobre o mosfet que muitas vezes e superior ao paramentro VDSS (tensão maxima entre dreno e fonte).

ja tentou colocar um diodo em paralelo com o motor? do mesmo jeito que e feito com o mosfet, e com bobinas de reles?

pode ser esse o problema!

abs.

Link para o post
Compartilhar em outros sites

Boa noite Felipe_Eletronic, se puder dar uma olhada no tópico "Capacitor de bootstrap e charge..." facarei muito grata.

Quanto a tentar ligar os diodos, quando a mosfet queimou os diodos não estavam presentes, porém o IRF vem com um diodo de proteção interno, ele não deveria ter dado conta do recado?

obrigado

Link para o post
Compartilhar em outros sites

Leu meu post acima?

então, esse diodo apenas protege contra a correntede cauda, e nao contra tensão reversa gerada por FCEM, que pode chegar a centenas de volts ropendo a junçao dreno fonte!

o diodo ao qual sugiro que coloque alem do IRF deve ser colocado em antiparalelo com o motor!

creio que isso iraresolver o problema de queima de mosfet quando voce comuta lo!

abs.

Link para o post
Compartilhar em outros sites
Boa noite Felipe_Eletronic, se puder dar uma olhada no tópico "Capacitor de bootstrap e charge..." facarei muito grata.

Quanto a tentar ligar os diodos, quando a mosfet queimou os diodos não estavam presentes, porém o IRF vem com um diodo de proteção interno, ele não deveria ter dado conta do recado?

obrigado

no seu circuito nao pode colocar diodo no motor

apenas condensador

Link para o post
Compartilhar em outros sites
  • 2 semanas depois...

Galera só uma pergunta... a conta pra saber o VGS é essa mesmo - [VCC vezes ("R1" dividido por "R1" mais "R2")] menos VCC???

Se for isso mesmo a conta não esta dando certo.

(4.7dividido por 4.7 mais 6.8) = 7.8

18 vezes 7.8 = 140.4

140.4 - 18 = 122.4

Galera corrijão o erro da MINHA equação por favor.

Agradeço!!!!

Link para o post
Compartilhar em outros sites

Galera montei a ponte H:

http://img148.imageshack.us/i/pontehfets.jpg/

Galera eu esqueci de "desenhar" os capacitores de 10nf entre o gate dos P-MOSFETs e o GND. Mas eles estão no circuito também.

Galera eu fui meio que "chutando" os valores dos resistores pois não aprendi a calcula-los direito.

Quando eu aciono a "entrada",do lado esquerdo da foto, ele funciona perfeitamente, o motor roda certo e os MOSFETs nem chegama a esquentar, mas quando aciono a "entrada" , do lado direito, o motor roda como se eu estivesse "pulsando" a alimentação dele, ele fica rodando fraco e tremendo, e o MOSFET Q1 começa a esquentar, se eu deixo mais que 5 segundos ligados ele esquenta muito!

Alguem pode me dizer o que pode ser?

Já montei sem os diodos, já troquei todos os resistores, já inverti os mosfets para ver se algum estava com problemas, mas continuou a mesma coisa, só da problema na "entrada direita".

Espero que alguem possa ajudar.

Até mais!

...................................................................................................................................................................

EDIT:

Galera lendo o topico novamente, vi a mesnsagem do maskador:

"Mas ele só funcionou bem mesmo adicionando os dois capacitores de 10nF, pois sem eles o VGS do mosfets da parte cima ficavam com uma pequena tensão VGS (quando cortados), o que fazia eles conduzirem um pouco e esquentarem." ai troquei o capacitor do Q1 e pronto funcionou.

Bam, espero que se isso acontecer com alguem essa mensagem possa ajuda-lo

Link para o post
Compartilhar em outros sites

Oceano, Obrigado mas já resolvi o problema.


Galera lendo o topico novamente, vi a mesnsagem do maskador:
"Mas ele só funcionou bem mesmo adicionando os dois capacitores de 10nF, pois sem eles o VGS do mosfets da parte cima ficavam com uma pequena tensão VGS (quando cortados), o que fazia eles conduzirem um pouco e esquentarem." ai troquei o capacitor do Q1 e pronto funcionou.
Bam, espero que se isso acontecer com alguem essa mensagem possa ajuda-lo

Link para o post
Compartilhar em outros sites
  • 2 semanas depois...

Galéra queria a ajuda de vocês para calcular o VGS dos mosfets, pois a expressão passada para esse calculo não da certo!

Bom eu e o Dani Piresk (quer dizer o Dani Piresk) conseguimos montar uma equação que pelo menos da o resultado dos VGS passados pelo maskador:

{VCC - [VCC*( 4K7/4K7+6K8)] - VCC} / 10 - 0.2

Bom da o resultado da ultima que não é exaro (maskador17.7 expressão criada 17.6)

Sera que com essa conta consigo mesmo descobriri o VGS dos Mosfets??

Bom de qualquer jeito espero que alguem me ensine um jeito de fazer isso.

Obrigado até mais!!

Link para o post
Compartilhar em outros sites

Não seria mais fácil verificar os valores de VGS no proprio datasheet do MOSFET em questão?

Pois nesse caso vocês estão apenas comutando os MOSFETs ou seja a tensão PORTA - FONTE (GATE - SOURCE) ou VGS está em um ponto em que ela não controla mais a corrente de dreno, qualquer aumento de VGS a partir desse ponto ira destruir o MOSFET.

claro a não ser que voce planeje em uma outra aplicação usa - lo na região linear.

veja esse datasheet de exemplo, uso muito esse MOSFET para ser ativado direto pelo PIC:

http://www.alldatasheet.com/view.jsp?Searchword=MTP52N06V

duvidas pergunte!

abs.

Link para o post
Compartilhar em outros sites

Entendo seu ponto de vista vale lembrar que em muitos casos o resistor de gate RG é dimensionado levando em conta a impedancia de entrada desejada.

EDIT.: amigo Gustavo vou tentar facilitar sua vida, o MOSFET é um dispositivo cuja condução é controlada por tensão e não por corrente como nos TJB, logo o valor da resistencia de gate é adotado de acordo com a impedancia de entrada do circuito que voce deseja, valores proximos a 1MOhm costuman ser usados, o que deve considerar na hora de calcular um resistor desses é a velocidade de comutação que desejas, pois o MOSFET possui uma caracteristica capacitiva em sua porta, onde resistores altos podem formar constantes de tempo consideraveis, nesse caso use o datasheet para se basear.

O resistor (se tiver ) que deve ser calculado trata - se do RD (Resistor de Dreno), ele consome a mesma corrente da sua carga, logo poderá usa - lo para limitar a correnta máxima de dreno, se precisar fazer isso use essa formula:

Rdreno = Vrdreno / Idreno

abs.

Link para o post
Compartilhar em outros sites
  • 5 meses depois...

Bom dia meus colegas, estou tentando montar um ponte H para conduzir ao menos 10A, e consegui porém, não consigo controlar a velocidade. O que fiz... montei a parte alta pa ponte com mosfet tipo P acionado por um bipolar tipo npn e na parte parte baixa usei mosfet tipo n nos quais eu coloco o sinal do PWM direto, porém o motor de maquina de vidro de carro não funciona a medida do PWM mas fica choramingando. Por favor meus colegas se puderem me ajudar ficarei grato pois meu projetinho esta parado por conta disto. Se precisar que eu poste o que ja fiz não tem problema. Abraço aguardo resposta.

Maskador eu fiz exatamente esta ponte que você fez,,, porém o motor fica choramingando e não chega a tensão de trabalho,,,por favor você pode me ajudar a resolver isso

Link para o post
Compartilhar em outros sites
  • 5 meses depois...

Boa tarde senhores. Estou tentando montar uma ponte H com mosfets para acionar um motor monofásico (127V/1A) e variar a frequencia utilizando a um microcontrolador para gerar os pulsos dos mosfets e variar essa frequencia do motor. A parte de lógica eu já fiz e está funcionando beleza. Tenho muitas dúvidas é na parte de potência. Retirei da net um projeto só que para 24VAC. Gostaria de saber se alguem pode dar uma olhada nesse projeto e me dar alguns conselhos.

post-783722-13884957508978_thumb.jpg

post-783722-13884957508978_thumb.jpg

Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisa ser um usuário para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas comunidades sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

Os Mitos do Dinheiro

APENAS R$ 9,90!

CLIQUE AQUI E COMPRE AGORA MESMO!