Ir ao conteúdo
  • Cadastre-se

Ajuda para criar um circuito para velocímetro digital (mas ponteiro analógico).


glcallegari

Posts recomendados

Olá caros amigos!

Entrei numa batalha Homérica quando decidi adaptar um painel de VW Polo Classic 2001 (aquele com 2 mostradores redondos) num Fusca. Já consegui resolver muitos mistérios depois que consegui o esquema de pinos do referido painel, tal como luzes, tacômetro e etc. Mas ainda estou com alguns problemas e um deles é o velocímetro. Segundo o esquema dos pinos, temos um pino (o 28) com 12V nele em relação ao terra e um outro (pino 3) com 0V que na verdade é um terra também. Mas isso não vem muito ao caso. O Ponto que quero chegar é que descobri que quando eu encosto (provoco um curto circuito na verdade) o pino 28 (que possui 12V) em um terra ou no pino 3, o ponteiro dá um pulso. Se eu fico encostando e desencostando com uma velocidade constante, o ponteiro mostra uma velocidade fixa! Isso indica que o velocímetro funciona conforme a freqüência de pulsos. Mas atentem que ele só faz isso se eu encosto o pino 28 no terra!!! Pois bem! Queria eu fazer com esse velocímetro funcionasse com um VSS (VSS é o sensor de velocidade, que no meu caso é um sensor Hall com um funcionamento muito parecido com os velocímetros de bicicleta, e ele produz 6 pulsos quadrados de 12V por volta). Fiz alguns testes. Primeiro tentei usar um transistor bipolar NPN como chave excitando a base do transistor com o VSS e ligando o pino 28 no coletor e o emissor no terra. Não funcionou!! Fui verificar o por que, e descobri que sensores Hall não fornecem corrente, apenas tensão! Então tentei substituir o transistor bipolar por um MOSFET (IRF630). Mas também não obtive êxito. O transistor não fexava contato entre o Dreno e o Source! E o engraçado é que quando eu ligava a saída do VSS no Gate, a tensão ficava perto de 0V em vez de ficar em 12V. Por fim tentei usar um CI Amplificador Operacional com entrada J-FET (TL071) e um transistor (BF494) na saída do CI. Também não deu certo! Talvez ele esteja estragado, ou eu não tenha feito a ligação corretamente.

Então o que eu gostaria dos nobres amigos é se alguém conhece algum componente eletrônico que coloque o pino 28 em curto com o terra eletronicamente (como se fosse acionado por um relê) e que possa ser controlado pelo sinal fornecido pelo VSS, lembrando que o VSS não dá corrente, apenas tensão e que se ligado a uma base de transistor a tensão de 12V cai a 0V!

Grato pela atenção de você todos!

Um abraço!:lol:

Link para o comentário
Compartilhar em outros sites

verifique se esse dispositivo de efeito hal esta a funcionar correctamente

o IRF630 deveria funcionar correctamente

quando a tensão de gate for a 12V deve entrar em conduçao

talvez o seu problema seja que a saida do hall esteja a 12V e va a 0V quando activado por campo magnetico ist e o seo sinal de saida seria inverso

para sermos mais claros seria melhor colocar aqui o esquema que fez com o IRF630 e o que ficou errado bem como o sinal que pretende na saida

Link para o comentário
Compartilhar em outros sites

Vamos por partes...

Mas antes de mais nada, diga-me: como foi que você ligou o transistor bipolar NPN e qual era o modelo desse transistor?

A principio, não vejo necessidade alguma de utilizar um MOSFET... O transistor bipolar é mais simples de se utilizar e funciona para aquilo que desejas...

Link para o comentário
Compartilhar em outros sites

  • 11 meses depois...

Oceano: O transistor estava realmente queimado, nem imagino o motivo! descarga eletrostática ou sobre-aquecimento! Não faço ideia! O Primeiro VSS estava defeituoso, mas depois comprei outro que funcionou bem.

cabteixeira: tá me tirando?

Eu resolvi o problema usando um IC com entrada J-Fet TL071CP.

Então montei o circuito abaixo:

circuitovss.jpg

Simulei no MultiSIM, e experimentei outros componentes e outras configurações, mas produziam sinais distorcidos! O que realmente funcionou com o sinal de pulsos quadrados foi o circuito acima. Me deparei com outro problema que era a calibração do velocímetro, sanado com o uso de outro circuito mais complexo retirado deste site: http://www.siliconchip.com.au/cms/A_108157/article.html

Funciona! Mas não perfeitamente! Ainda preciso verificar alguns detalhes!

No fim acabei respondendo a própria pergunta! Mas mesmo assim agradeço a atenção de todos.

Link para o comentário
Compartilhar em outros sites

Visitante
Este tópico está impedido de receber novos posts.

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas comunidades sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

Curso de Hacker Ético

LANÇAMENTO!

CLIQUE AQUI E CONFIRA!

* Este curso não é ministrado pela equipe do Clube do Hardware.