Ir ao conteúdo
  • Cadastre-se

Pen drive não funciona só no meu PC


Posts recomendados

Boa noite.

Tenho um pen-drive Kingston DT101 II de 8GB que está com um problema muito estranho, e coincidência ou não, o problema começou após eu usar esse pen-drive em um som automotivo de procedência duvidosa...

O problema:

Eu não consigo gravar nenhum arquivo grande (tipo maior que 1MB) neste Pen-drive sem que o Windows (XP SP3) dê erro de gravação. Quando isso acontece a luz do pen-drive fica piscando sem parar infinitamente até eu desconectar o pen-drive da porta USB (mesmo depois de eu já ter clicado em 'Removar o dispositivo com segurança' o led continua piscando).

A mensagem que dá é "Erro ao copiar arquivo ou pasta" - "Não é possível copiar teste.txt. Arquivo especificado não encontrado." .

No Visualizador de Eventos, o Windows gera vários logs de erro de "Disk" sempre com a mensagem "Erro detectado no dispositivo \Device\Harddisk2\D durante uma operação de paginação." E após isso acontecer, se eu reconectar o pendrive as vezes ele é reconhecido com o Sistema de Arquivos RAW e pede pra formatar ou ele volta como FAT32 normalmente inclusive com o arquivo copiado gravado porém corrompido.

Quando acontece de reconhecer como RAW, não consigo mais formatar de jeito nenhum, nem pelo prompt, nem pelo Windows, nem pelo HP USB Disk Storage Format Tool, sempre dá um erro diferente.

Agora o mais absurdo é que se eu pegar o pen-drive e colocar em qualquer outro computador, ele formata normalmente, grava arquivos enormes normalmente e é visivelmente muito mais rápido no acesso aos dados. E pra piorar, eu testei outros pen-drives, cartão de memória, MP3 Player, Celular e em todos consigo formatar e gravar arquivos normalmente neste mesmo computador.

Estou postando aqui minha dúvida porque não entendo o que pode estar havendo, parece que meu pen-drive pegou birra com meu computador...

Desculpem o post tão extenso, mas tentei detalhar o máximo possível o caso.

Configuração do PC:

Sist. Op.: Windows XP SP3 Original com todas as atualizações em dia

CPU: Athlon II x2 240 AM3 2.8GHz

MoBo: ECS A780GM-A 1.1 BIOS Atualizada (atualizei hoje inclusive...)

Memória: 2x 1GB Kingston DDR2-667MHz @ 800MHz - 1.95V

HD1: Western Digital WD5000AACS Green SATA II - 500GB (1472 KB em setores defeituosos :angry::angry: )

HD2: Western Digital WD3200AAJS SATA II - 320GB

Fonte: AVC 350W Reais

Drivers: Atualizados com a última versão disponível no site do fabricante.

O resto da config. acho que seria irrelevante neste caso.

Desde já, muito obrigado.

Link para o post
Compartilhar em outros sites

Meu conselho é você baixar a versão TRIAL do Kaspersky (baseado na ideia que você não o tenha) e mandar ele checar seu PC inteiro. Ou é algum vírus ou sua USB tá com problemas. Esse negocio de "erro arquivo de paginacao" seria um arquivo de memoria virtual do Windows, mas pra ter um no pendrive, somente se fosse designado por você, ou seja, isso aponta pra vírus.

Link para o post
Compartilhar em outros sites
Meu conselho é você baixar a versão TRIAL do Kaspersky (baseado na ideia que você não o tenha) e mandar ele checar seu PC inteiro. Ou é algum vírus ou sua USB tá com problemas. Esse negocio de "erro arquivo de paginacao" seria um arquivo de memoria virtual do Windows, mas pra ter um no pendrive, somente se fosse designado por você, ou seja, isso aponta pra vírus.

Fiz o que você recomendou, baixei o Kapersky Trial e fiz uma verificação completa, ele achou 2 vírus e 1 Trojan, mas não tinha nenhum em execução, eram apenas infecções em executáveis que eu baixei a muito tempo mas nunca nem havia sequer executado eles ainda.

O Kapersky removeu tudo e meu pen-drive continua bem aqui na minha frente piscando o led sem parar e com o mesmo problema...

Quanto à paginação, eu uso o Windows definido como "Sem arquivo de Paginação", então acredito que não seja isto...

Será que a controladora USB da minha placa-mãe estragou? Pode ser driver? Pois apesar de eu ter instalado o mais atualizado ele não aparece de jeito nenhum no Gerenciador de Dispositivos (vide imagem abaixo):

gerenciadordispstandard.jpg

Não deveria estar alguma coisa diferente deste monte de "Standard qualquer coisa"? Até onde eu sei, isso é driver genérico do Windows XP...

O que não entendo, é que se o problema realmente for relacionado com minhas portas USB (eu testei em todas), porque que só este bendito pen-drive que não está funcionando? tudo que eu ligo nestas USB's funcionam normalmente como eu já tinha falado, seria ele mais "sensível"!?

Obrigado.

Link para o post
Compartilhar em outros sites

te sugiro que procure pelo programa HP USB Disk Storage Format Tool , ele vai recuperar a estrutura do pendrive e vai ficar legal .

Link para o post
Compartilhar em outros sites

Um teste pra resolver de fez isso, seria você conectar uma distribuição Linux (como por exemplo uma live, que roda direito do CD) espetar seu pendrive e vê se consegue trabalhar com ele. Se conseguir, é alguma coisa com o Windows, se não conseguir, é alguma coisa com o Hardware. Uma alternativa rapidinha de se baixar e ao mesmo tempo muita boa distribuição é o SLAX (www.slax.org).

Link para o post
Compartilhar em outros sites
te sugiro que procure pelo programa HP USB Disk Storage Format Tool , ele vai recuperar a estrutura do pendrive e vai ficar legal .

Como eu já tinha comentado, isso eu já tentei fazer e também não deu certo.

Um teste pra resolver de fez isso, seria você conectar uma distribuição Linux (como por exemplo uma live, que roda direito do CD) espetar seu pendrive e vê se consegue trabalhar com ele. Se conseguir, é alguma coisa com o Windows, se não conseguir, é alguma coisa com o Hardware. Uma alternativa rapidinha de se baixar e ao mesmo tempo muita boa distribuição é o SLAX (www.slax.org).

Fiz o que você pediu, só que eu usei um Live CD antigo do Kurumin 5.0 e apesar do pen-drive ter se comportado meio esquisito (muuuuito lento na gravação e ele ficou uma vez com o led piscando sem parar mesmo sem estar fazendo nada), eu consegui ler e gravar arquivos nele sem problemas.

Testes de hoje:

- Espetei meu Pen-drive em outro computador e funcionou normalmente...

- Espetei mais 2 pen-drives diferentes no meu PC problemático e estes também funcionaram corretamente, embora o Windows estranhamente tenha pedido para reiniciar nas duas vezes que ele reconheceu os pen-drives pela primeira vez... Nunca vi ter que reiniciar para reconhecer pen-drive no XP...

Estou convencido que existe um problema de software, mas não estou descartando a possibilidade de que haja um problema de hardware que talvez esteja causando os conflitos no Windows...

Alguém tem mais alguma luz?:(

---

EDIT:

Consegui fazer funcionar, na gambiarra, mas funcionou...

Arranjei um Hub USB 2.0 de 4 portas bem genéricão e pluguei ele em uma das minhas USBs e pluguei o Pen-drive em uma das portas do Hub e advinhe? Funcionou perfeitamente, inclusive extremamente rápido comparado com o que estava antes...

Gente, o que que é isso!? Alguém explica como é que pode no Hub o Pen-drive funcionar e direto na USB não? Problema elétrico na porta? Sei lá...

Link para o post
Compartilhar em outros sites

Bom, parece que a solução deste caso é desconhecida até o momento...

Resolvi fazer uma pesquisa mais aprofundada do caso e encontrei uma coisa interessante:

http://social.technet.microsoft.com/forums/pt-BR/winvistapt/thread/68594200-3ea1-428c-afee-3c34f0d26a79/

http://adrenaline.com.br/forum/cpu-s-placas-mae-memorias/264729-problemas-entre-chipsets-da-amd-pendrives-datatraveler-da-kingston.html

Pelo que entendi, existe um problema sério sem solução conhecida até hoje de incompatibilidade entre Pen-drives maiores que 4GB, chipsets AMD/ATI e Windows XP/Vista/Seven.

Isso faz bastante sentido para mim, já que meu PC tem chipset AMD e dá dando problema, todos os outros PCs que eu testei meu pen-drive tinham chipset Intel ou VIA e não tiveram problemas rodando tanto Windows XP quanto Vista. Quando eu testei o Linux, mesmo no meu PC com chipset AMD, funcionou embora com uma lentidão absurda.

Não queria deixar este tópico morrer, pois vejo que, apesar de pouco comentado neste fórum, este é um problema irritante que muitas pessoas estão passsando e seria interessante se pelo menos quem tiver alguma configuração com estas características (chipset AMD + pen-drive grande + windows), poste se está tendo problemas ou se conseguiu resolver o mesmo.

Muito Obrigado.

Link para o post
Compartilhar em outros sites
  • 3 meses depois...

Estou desenterrando este tópico, porque o problema ainda não foi resolvido desde Outubro do ano passado...

Na minha última postagem de 22/10/09, eu mencionei que havia conseguido contornar a situação usando um HUB USB... Isso funcionou + ou - um mês e um belo dia parou de funcionar deste modo também...

Não faço ideia do que pode estar acontecendo, não tem mais lógica... Veja só o que eu já fiz nestes 4 meses para tentar resolver (todos sem sucesso)...

1º) Instalei uma placa PCI USB 2.0 da ALi no Windows XP SP3: Resultado, o pen-drive é completamente ignorado. Nem erro não dá, simplesmente não reconhece nada. Outros dispositivos funcionam normalmente. Ás vezes o pen-drive era reconhecido mas apresentava exatamente o mesmo comportamento das USBs da própria placa-mãe.

2º) Formatei tudo e instalei o Windows 7 com todos os updates e drivers atualizados: O problema persiste. O pen-drive é reconhecido e funciona muito bem para leitura, mas trava tudo em segundos se tento gravar qualquer coisa nele, nem que seja um TXT de 1 KB...

3º) Instalei uma outra placa PCI USB 2.0 da Via no Windows 7: O pen-drive é completamente igorado nas portas desta plaquinha, não só o pen-drive, mas todo e QUALQUER outro dispositivo USB que eu conecte nelas são completamente ignorados a ponto de nem serem alimentados pela porta. Conectei um mouse por exemplo e a luz dele só dá uma piscada e logo apaga, como se a energia fosse cortada 1 segundo após o dispositivo ser conectado. Nem preciso dizer que esta mesma placa PCI USB funciona normalmente em outros computadores...

4º) Instalei outra placa PCI USB 2.0 da Via (um modelo mais antigo) no Windows 7: O pen-drive funciona normalmente para leitura mas trava ao tentar gravar qualquer coisa... Outros dispositivos funcionam normalmente.

5º) SOLUÇÃO TEMPORÁRIA MEIA-BOCA PLUS: Desabilitei o controlador USB2.0 desta última placa Via antiga citada acima no Gerenciador de Dispositivos, forçando as portas a funcionarem somente como USB 1.1 e, advinha só? O pen-drive funciona perfeitamente, só que com a fantástica velocidade ultra-lenta do padrão 1.1 da USB...

Nunca vi nada igual. Já formatei 2 vezes com 3 sistemas operacionais diferentes, testei 4 placas USB Off-board além das on-board da minha placa-mãe e nada...

A única coisa que me vem em mente agora é problema relacionado com energia... sei lá... alguma coisa errada na linha +5V da fonte... Ainda assim não entendo porque afetaria somente as portas USB...

Problema ainda sem solução definitiva...

...

Link para o post
Compartilhar em outros sites
  • 2 semanas depois...

Cara também tenho um problema parecido, comprei um pendrive 8GB PQI, e não funciona em casa de jeito nenhum, ja espetei em todas USBs, nas de trás até que demorou um pouco mais para travar tudo.

Interessante é que cada vez dá um problema diferente, as vezes trava, as vezes da erro de paginação, as vezes não reconhece o pen.

você falou q pode ser problema em chipset AMD mas o meu é Nvidia rs, enão não sei o que fazer ja usei todo tipo de programa para formatar o pen e não adianta, até um da própria fabricante e nada.

Comprei um sandisk 4gb e ta funfando normalmente. Queria resolver isso, perdi grana com o pen de 8GB

Link para o post
Compartilhar em outros sites
  • 2 anos depois...

Cara por incrivel que pareça eu tenho o mesmo problema que o seu e ja te adianto a culpa não dessa ou daquela marca nem do computador pois eu comprei dois pen drives da mesma marca ambos 4GB,um funcionou bala o outro nem com reza braba,detalhe ele funciona em qualquer pc,not ou tv menos no meu pc.Será bruxaria?

Link para o post
Compartilhar em outros sites
  • 2 semanas depois...
Cara por incrivel que pareça eu tenho o mesmo problema que o seu e ja te adianto a culpa não dessa ou daquela marca nem do computador pois eu comprei dois pen drives da mesma marca ambos 4GB,um funcionou bala o outro nem com reza braba,detalhe ele funciona em qualquer pc,not ou tv menos no meu pc.Será bruxaria?

Deve ser...

Esse tópico já tem 3 anos e 2 meses e até agora nenhuma solução foi apresentada...

Nesse enorme meio-tempo, já montei outro computador completamente novo para mim, do zero, também baseado em AMD e advinha? Apresenta o mesmo problema com todo e qualquer pen-drive de 8GB que eu tente usar nele...

E claro, neste computador lá do início do tópico, nada mudou também... Continua sem funcionar.

Eu sinceramente já desisti. O problema de incompatibilidade é real e evidente, mas eu acredito que o dia em que encontrarmos a solução, pen-drives serão tão obsoletos quanto disquetes de 5¼ hoje em dia...

Link para o post
Compartilhar em outros sites

Nunca ouvi falar de incompatibilidade com amd e pendrives de 8GB, eu tenho um micro amd e uso com 8, 16, até de 128GB e não tive problemas, o que não quer dizer que não acontece.

O que conheço são micros antigos que não funcionam, aí a pessoa instala uma placa usb pci e pode resolver, nem subindo um linux com um live cd reconhece? ou em máquina virtual?

vou mandar um email pra kingston para saber se tem algum procedimento especial pro seu tipo de caso, nesse meio tempo não recorreu a perguntar para o fabricante do pendrive?

att

Link para o post
Compartilhar em outros sites
  • 3 meses depois...

Em primeiro lugar, peço desculpas pois fiz o registro no forum para dar uma de necromante e ressuscitar esse tópico.

Vi que o assunto se arrastou por anos sem que se encotrasse solução e, pior ainda, outros tiveram o mesmo problema.

Pois é, aconteceu comigo também MAS consegui resolver, por isso fiz o registro, pra ver se a minha "solução" serve para ajudar os outros.

A situação: comprei um pendrive de 32GB da SanDisk e ele era reconhecido pelo Windows XP mas não copiava nenhum arquivo pra ele, dizendo que não era possível encontrar o caminho. Pois bem, resolvi formatar o maldito com clique do botão direito + Formatar. Não acontecia nada, não dava erro nem nada, era como se tivesse cancelado o comando.

Abri um DOS prompt e dei um "format h:" e dava erro, ao tentar usar o convert também dava erro.

A título de curiosidade, pluguei o pen no note da minha mulher e ele funcionou corretamente.

Com a pulga atrás da orelha por causa da mensagem sobre o file system resolvi formatar o pen usando o note, aí vem o que resolveu meu problema: formatei o pen TROCANDO o file system de FAT para NTFS. Pronto, meu outro PC passou a ler/gravar normalmente no pen.

Não fiz testes reformantando o pen usando outros FS, mas acho que daria certo com FAT32 também; é um erro muito esotérico e não sei se essa gambiarra resolve os erros que vi nesse tópico, mas não custa nada tentar.

Link para o post
Compartilhar em outros sites
  • 3 meses depois...

Comprei vários pendrives Sandisk 4, 8, 16 GB. Pouco usava. Agora tenho usado mais e, quase na maioria das vezes o PC (WinXP, WIN 7) reconhece mas quando clico no Explorer para abrir não aparece nada.

Para resolver o problema tenho plugado o pendrive antes de ligar o PC. Sempre "desconecto" o pendrive antes de tirar da USB.

Tenho um pendrive PQI de 8GB que é reconhecido em qualquer computador.

Abraço!

Link para o post
Compartilhar em outros sites

Eu cheguei a ligar pro atendimento da kingston, mandei email para outros fabricantes de pendrives questionando se tinha alguma incompatibilidade entre micros amd com pendrives a partir de 4GB, li alguma coisa na internet relacionado a esses casos.

A conclusão que cheguei baseado no que li e pesquisei e pode esclarecer seria essa: não sei precisar a quantidade exata, mas algumas motherboars e notebooks com processador e chipsets AMD tinham essa falha de travar a gravação de dados em unidades flash, atingindo um número pequeno de usuarios, alguns casos a unidade corrompia fisicamente inutilizando a mesma, mas foi contornado com atualização de bios, implantação de placas controladoras ou formatação do sistema operacional, pegou bem a época das críticas mais pesadas ao windows vista, vindo o começo da migração e aceitação do windows 7, 8, então o problema na teoria desapareceu.

Cheguei a ter 5 maquinas totalmente AMD´s e não consegui reproduzir o erro, subi maquina virtual, linux, só faltei usar hackintosh...rs

Por ser uma coisa bem nota de rodapé, e também por falta de informações mais recentes sobre isso, é natural e previsível que a demanda de tópicos encobrisse esse, e faltou o autor também se comprometer a correr atrás de investigar como por exemplo eu fiz, de ligar na kingston por exemplo.

chegou a qual patamar, mesma maquina, falhando com outros pendrives?

att

Link para o post
Compartilhar em outros sites

Tenho dois desktop:

1) Windows/XP, CPU AMD 1.8GHz, 3GB de memória, USB 2.0.

2) Windows/7 64bits, CPU Intel Xeon E5620 dualcore 2.4GHz, 12GB de memória, USB 2.0.

Por sugestão de um conhecido que tem loja em CDE(PY) comprei um pendrive Kingston DT101 G2 de 32GB. Alerta: O pendrive é cor de vinho. Se for de outra cor... não compre pois é falso.

Pluguei várias vezes o novo pendrive em maquinas XP e W7. Reconhece imediatamente em todas as tentativas, funcionando perfeitamente.

Já um Sandisk Z33 Fit de 4GB, nas mesmas oportunidades, reconhece a marca e modelo do pendrive (no ícone da bandeja) porém diz que o pendrive está vazio.

Fiz reboot no W7 com o pendrive plugado e, novamente apresenta o problema.

Desliguei o computador e voltei a ligar... agora sim ele reconheceu e apresentou todo o conteúdo do pendrive.

Após atualizar o conteúdo do Z33 desconectei o pendrive através do ícone da bandeja e retirei da USB. Aguardei 5 minutos e pluguei novamente, na mesma USB que estava. Voltou a apresentar o mesmo problema.

A solução é mesmo plugar o Sandisk antes de ligar o computador, tanto no XP como no W7.

É importante informar que uso FAT32 nos pendrives.

Abraço à todos e boa sorte!

Tutuca

Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisa ser um usuário para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas comunidades sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

Os Mitos do Dinheiro

APENAS R$ 9,90!

CLIQUE AQUI E COMPRE AGORA MESMO!