Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
Entre para seguir isso  
JCVM

Problemas no VisualG

Recommended Posts

Bom gente, eu tinha um exercicio que era assim: O usuario fornece um número, e se o número estiver entre 50 e 90, exibir o numero. Senão, mandar o usuario rodar o programa novamente. Não achei muito legal isso e resolvi mandar o usuario de volta para o começo do programa. Só que eu ainda não vi repita/fimrepita direito, teria como algúem apontar o erro aqui? ( O erro acontece com o número sendo válido ou não, ele diz que esperva encontrar então na linha 8. Mas o então tá lá)

var

n:real

inicio

// Seção de Comandos

repita

escreval ("Digite um número entre 50 e 90")

leia (n)

se n>50 (e) n<90 então

escreval (n)

senao

escreval (n," Não é um número válido")

fimrepita

fimse

fimalgoritmo

Ou seja, o que eu quero é que o programa repita apenas se o usuario digitar um numero inválido.

Compartilhar este post


Link para o post
Compartilhar em outros sites
Bom gente, eu tinha um exercicio que era assim: O usuario fornece um número, e se o número estiver entre 50 e 90, exibir o numero. Senão, mandar o usuario rodar o programa novamente. Não achei muito legal isso e resolvi mandar o usuario de volta para o começo do programa. Só que eu ainda não vi repita/fimrepita direito, teria como algúem apontar o erro aqui? ( O erro acontece com o número sendo válido ou não, ele diz que esperva encontrar então na linha 8. Mas o então tá lá)

var

n:real

inicio

// Seção de Comandos

repita

escreval ("Digite um número entre 50 e 90")

leia (n)

se n>50 (e) n<90 então

escreval (n)

senao

escreval (n," Não é um número válido")

fimrepita

fimse

fimalgoritmo

Ou seja, o que eu quero é que o programa repita apenas se o usuario digitar um numero inválido.

Bom, prazer, minha primeira postagem no fórum... :D

ok, aqui vai

O comando é repita...ate(DEFINE O QUE VAI REPETIR). voce deverá colocar no final da instrução a condição da parada, senao o programa sequer irá rodar. se nao fosse por isso, ele iria ser executado infinitamente :o

var

n:real

inicio

// Seção de Comandos

repita

escreval ("Digite um número entre 50 e 90")

leia (n)

se ((n>50) e (n<90)) então

escreval (n)

senao

escreval (n," Não é um número válido")

fimse

ate ((n>50) e (n<90))

fimalgoritmo

caso nao goste de declarar o que vai "amarrar" o seu comando, poderá usar o enquanto...fimenquanto, entretanto neste voce irá especificar a condiçao para ele executar no início.

A diferença entre um e outro é que o repita...ate ira funcionar ATÉ que acontece o que voce pediu, já o enquanto funcionará ENQUANTO for diferente do que voce colocou. o mesmo algoritmo usando enquanto seria.

Outra coisa que notei foi que voce colocou um fimse depois do ate, o que geraria um erro. se voce abre um bloco SE dentro de REPITA...ATE é importante que o mesmo seja fechado dentro do bloco.

Qualquer dúvida, não deixe de perguntar

var

n:real

inicio

// Seção de Comandos

ENQUANTO((n<=50) OU (n>=90))

escreval ("Digite um número entre 50 e 90")

leia (n)

se ((n>50) e (n<90)) então

escreval (n)

senao

escreval (n," Não é um número válido")

fimse

FIMENQUANTO

fimalgoritmo

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Entre para seguir isso  





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×