Ir ao conteúdo
  • Cadastre-se

FaustoJr

Membros Juniores
  • Total de itens

    9
  • Registro em

  • Última visita

  • Qualificações

    N/D
  1. Boa noite. Na verdade, nas células da coluna "G" eu tenho a seguinte fórmula "=SOMA(D5:F5)" na célula "G5", "=SOMA(D6:F6)" na célula "G6" e assim por diante até a célula "G64". Tenho um botão para "Limpar Cotas" que quando acionado apaga os valores das colunas "C" e "E" e copia os valores da coluna "G" e os cola na coluna "F". Até aí tudo bem, mas preciso que ainda neste comando do botão os valores da coluna "G" sejam apagados sem que as fórmulas destas células sejam apagas. Desta forma, assim que eu inserir um valor em ao menos uma célula da coluna "C", todos os valores da coluna "G" voltem a ser calculados conforme a fórmula contida em suas células. Será que isto é possível? Obrigado
  2. Boa noite, preciso de uma macro para apagar os valores das células do intervalo (G5:G64), mas que não apague as fórmulas destas células. Obrigado
  3. Boa tarde, Estou fazendo uma planilha e gostaria de uma macro que ocultasse os valores de todo o intervalo ("G5:G64"), mas sem ocultar a coluna. E caso fosse digitado algum valor em qualquer uma das células do intervalo "C5:C64" , os valores de todo o intervalo "G5:G64" voltem a ser mostrados na planilha. Então, se eu digitar algum valor na célula "C8" por exemplo, todos os valores da coluna "G" voltariam a ficar visíveis na planilha. Alguém sabe me dizer se é possível fazer isso? Segue planilha em anexo. Obrigado. Planilha1 - Teste.xlsx
  4. Boa noite Charley Rocha, Era realmente isso, só que ainda preciso corrigir um detalhe. Nesta planilha posso registrar jogos da Mega Sena com 6, 7 e 8 dezenas, mas quando eu insiro somente 6 dezenas (no intervalo K5:P5, por exemplo) sobram duas células vazias (Q5 e R5). E quando eu aciono a macro para colocar em ordem crescente, as células K5 e L5 ficam vazias e as dezenas vão para o intervalo M5:R5. Eu gostaria que após a ação da macro as dezenas fossem ordenas a partir da primeira célula deixando as últimas vazias quando houver. Obrigado mais uma vez
  5. Boa noite Charley Rocha. Você é o cara!!! Ficou perfeito; exatamente como eu queria. Muito Obrigado. Sem querer abusar, mas aproveitando um pouco mais do seu conhecimento; esta planilha é para um bolão da mega sena entre os amigos de trabalho e em uma outra parte dela eu colocaria as dezenas apostadas da seguinte maneira (segue tabela em anexo): Coluna "J" numerada de 1 a 60 a partir da célula "J5", onde o número 1 representa a primeira linha com até 8 dezenas (K5:R5); a célula "J6" representa a segunda linha com até 8 dezenas apostadas (K6:R6) e assim por diante até a célula "J64" onde tenho a última linha para apostas (K64:R64). Desta forma, eu preciso de uma macro que faça o seguinte: MsgBox para confirmar se realmente quer realizar este processo; Colocar os números das células (K5:R5) em ordem crescente; Depois colocar os números das célula (K6:R6) em ordem crescente e assim por diante até a última linha (K64:R64); MsgBox: Operação realizada com sucesso. Estou colocando a planilha em anexo e se puder me ajudar agradeço mais uma vez!!! Planilha1.xlsx
  6. Boa noite Charley. Desculpe por não me fazer entender muito bem, mas na verdade o que eu estou querendo é que quando eu atualizar a planilha os dados da colunas "B" e "D" sejam apagados e que caso eu resolva colocar alguma fórmula nas células destas colunas elas não sejam apagadas na próxima atualização. Então eu gostaria que quando eu pressionar um botão específico, a tabela fosse desbloqueada, os valores das colunas "B" e "D" fossem apagados, depois somente os valores das células não vazias da coluna "F" fossem copiados (sem copiar as fórmulas dessa coluna) e depois esses valores fossem colados nas células correspondentes da coluna "E" sobrepondo aos valores antigos desta coluna. E por fim, bloquear novamente a planilha. A planilha está em anexo. Obrigado Planilha1.xlsx
  7. Olá, estou elaborando uma planilha e como não tenho muito conhecimento em programação, gostaria de uma ajuda. Esta planilha tem algumas células protegidas e eu preciso de uma macro associada a um botão para fazer o seguinte processo: Desbloquear a tabela; Apagar somente os valores e não as fórmulas das colunas "B" e "D"; Copiar somente os valores e não as fórmulas das células não vazias da coluna "F" (que se refere a situação atual); Colar esses valores na coluna "E" (que se refere a situação anterior) sobrepondo-os aos valores antigos; Bloquear a tabela. Segue em anexo a planilha. Obrigado Planilha1.xlsx
  8. Boa noite Osvaldo. Fiz o que você sugeriu, mas quando seleciono uma dessas células e deleto seu conteúdo deixando-a vazia, o excel aceita a célula ficar vazia e não aparece a mensagem de erro. Qual seria a macro para inserir "?" caso a célula fique vazia?
  9. Boa noite. Estou precisando de uma ajuda em uma planilha onde as células do intervalo M2:R2 somente fosse permitido digitar o ponto de interrogação ("?") e os números de 01 a 60. No entanto, eu não queria que estas células ficassem vazias e caso isso ocorra, apareça a mensagem de erro para que elas não fiquem vazias. Fiz a validação de dados nestas células com uma lista (?, 01, 02, ... , 60) e tentei com a caixa de seleção Ignorar em branco marcada e também desmarcada. Consegui restringir a digitação a estes dados, porém não consigo impedir que as células fiquem vazias. Alguém pode me ajudar? Obrigado

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×