Ir ao conteúdo
  • Cadastre-se

claudiocj

Membros Juniores
  • Total de itens

    17
  • Registro em

  • Última visita

  • Qualificações

    N/D
  1. Algoritmo "troca" Var palavra,troca: caractere t:inteiro v :inteiro funcao trocaPares (v:inteiro):caractere var c:inteiro palavra, aux:caractere inicio v <- compr(palavra) enquanto v > 0 faca //letra ç aux <- aux + copia(palavra;v;1) v <- v-1 fimenquanto palavra := aux retorne palavra fimfuncao Inicio escreva("Digite uma palavra: ") leia (palavra) escreval("Palavra Trocada é: ", troca) Fimalgoritmo fiz assim só não funciona. eu fiquei ate perdido já, queria testar no visualg ou no portugol esse algaritimo de troca de letras não inverte.
  2. pessoal agradeço a ajuda, mas não tenho ideia de como fazer isso eu queria que fosse assim a pessoal digitasse um palavra "exemplo" e ela fosse trocando de par em par e se for impar a quantidade de letras manteria o no final. o EXEMPLO FICANDO ASSIM "XEMELPO" ENTENDI.
  3. como faço para usar esse mesmo conceito só que usando par de letras, segue o código: algoritmo "ordenação" var vet: vetor [1..4] de inteiro i, j,aux : inteiro inicio Para i <- 1 ate 4 faca escreva("Digite um Valor: ") Leia (vet [i]) FimPara para i <- 1 ate 3 faca para j <- i+1 ate 4 faca se(vet[i] > vet[j]) Entao aux <- vet[i] vet[i] <- vet[j] vet[j]<- aux FimSe FimPara FimPara para i <- 1 ate 4 faca escreva("{",vet[i],"}") Fimpara fimalgoritmo
  4. ixii agora fundiu meu cérebro kkkkk.. vou postar aqui o que eu quero pra ver se fica melhor a compreensão. Em PETEQS uma string pode ser tratada como um vetor de caracteres. Observe por exemplo a função inverte(entradas: frase) a seguir que recebe uma string como parâmetro e retorna uma nova string que é o inverso da string original. função inverte(entradas: frase) início resultado  frase para i  1 até tamanho(frase)/2 faça aux  frase resultado  frase[tamanho(frase)-i+1] resultado[tamanho(frase)-i+1]  aux próximo i fim Na construção desse algoritmo, foi usada a função tamanho(entradas: frase) que retorna o número de caracteres em uma string. Considere o seguinte exemplo de uso: programa exemplo início imprima inverte("exemplo") imprima inverte("reviver") fim A saída do programa seria: olpmexe reviver Sua tarefa: Escreva o algoritmo da função trocaPares(entradas: frase) que recebe uma string como parâmetro e retorna uma nova string em que os pares de letras consecutivas na string original são invertidas. Se a string de entrada tiver um número ímpar de letras, a última letra deve permanecer inalterada. A seguir, você pode ver um exemplo de teste da função: programa exemplo início imprima trocaPares("exemplo") imprima trocaPares("decantador") imprima trocaPares("entre paredes") fim A saída do programa seria: xemelpo edactndaro nert eapereds
  5. certo se a pessoa digitar uma palavra acima de 10 carácter o acontece?
  6. não consigo acompanhar o raciocino como seria?
  7. corrigi e o erro passou para baixo. adicionado 1 minuto depois como ficaria se eu usasse vetor tem como ?
  8. Então, mesmo usando esse comando compr, não passa desse ponto. Tentei usar o Portugol, mas não conheço muito bem.
  9. me referi a total de Jogos feitos e total de jogos sofridos adicionado 2 minutos depois realmente é isso mesmo eu tirei e não reparei, o algorítimo rodo perfeitamente então passo despercebido vou corrigir adicionado 5 minutos depois não sei porque mais se eu botar no singular aparece como não tivesse posto dentro da variável (var) principalmente o empate adicionado 8 minutos depois esse ponto tive que criar essa variável, pós eu não estava conseguindo o resultado esperado que era jogos sem fazer gols, só consegui dessa maneira "gambiarra"
  10. como resolvo esse problema no visual g esta dando erro quando testa. da erro "se (tamanho (palavra mod 2 = 0)) entao" aqui Var palavra: caractere aux: caractere t:inteiro c, i :inteiro Inicio t <- 0 aux <- "" leia (palavra) se (tamanho (palavra mod 2 = 0)) entao t <- palavra senao t <- tamanho(palavra) -1 fimse enquanto t > 0 faça aux <- palavra[c] palavra [c] <- (palavra [c+1]) palavra [c+1] <- aux t < t-2 c <- c+2 c <- -1 fimenquanto escreval (palavra) Fimalgoritmo
  11. Var pontos :inteiro mediaGols :real vitorias :inteiro saldoGf :inteiro empates :inteiro partida :inteiro JogosSemfg : inteiro TjgFeitos :inteiro golsFeitos :inteiro TjgSofridos :inteiro golsSofridos :inteiro Inicio golsFeitos <- 0 saldoGf <- 0 golsSofridos <- 0 vitorias <- 3 empates <- 1 TjgFeitos <- 0 golsSofridos <- 0 saldoGf <- 0 para partida <- 1 ate 12 faca escreval("Jogo ",partida:1,"?") leia (golsFeitos, golsSofridos) se golsFeitos = 0 entao JogosSemfg <- JogosSemfg + 1 fimse se golsFeitos > golsSofridos entao pontos <- pontos + vitorias fimse se golsFeitos = golsSofridos entao pontos <- pontos + empates fimse JogosSemfg <- golsFeitos - golsSofridos TjgFeitos <- TjgFeitos + golsFeitos TjgSofridos <- TjgSofridos + golsSofridos fimpara saldoGf <- TjgFeitos - TjgSofridos mediaGols <- TjgFeitos / partida escreval("Pontos: ", pontos) escreval("Saldo de Gols: ", saldoGf) escreval("Jogos sem fazer Gols: ", JogosSemfg) escreval("Média de Gols por Jogo: ", mediaGols) Fimalgoritm código completo. muito obrigado
  12. tentei usar seu 1 exemplo, fiquei enrolado, só que eu não sei como usar essas duas golsPro :inteiro //total de gols feitos golsContra :inteiro //total de gols sofridos como esquematizar, usando se e então ?
  13. Boa noite, quase resolvi essa questão só não entendo porque gols feito e gols sofrido não subtraem para da o resultado de jogos sem fazer gol. Algoritmo "PDA" // Disciplina : [Projeto de Desenvolvimento de Algaritimos] // Professor : Antonio Carlos Nicolodi // Descrição : Aqui você descreve o que o programa faz! (função) // Autor(a) : Cláudio Cotrim Jr // Data atual : 21/10/2018 Var pontos :inteiro //total de pontos ganhos mediaGols :real //média de gols por partida vitorias :inteiro //número de vitórias empates :inteiro //número de empates partida :inteiro //número da partida (controlador do para) golsFeitos :inteiro //gols feitos na partida golsSofridos:inteiro //gols sofridos na partida Inicio golsFeitos <- 0 golsSofridos <-0 vitorias <- 3 empates <-1 para partida <- 1 ate 12 faca escreval("Jogo ",partida:1,"?") leia (golsFeitos) leia (golsSofridos) se golsFeitos > golsSofridos entao pontos <- pontos + vitorias senao se golsFeitos = golsSofridos entao pontos <- pontos + empates fimse fimse fimpara golsFeitos <- golsFeitos + 1 golsSofridos <- golsSofridos + 1 mediaGols <- golsFeitos + golsSofridos + partida escreval("Pontos: ", pontos) escreval("Saldo de Gols: ", golsFeitos) escreval("Jogos sem fazer Gols: ", golsFeitos - golsSofridos) escreval("Média de Gols por Jogo: ", mediaGols / 12) Fimalgoritmo

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×