Ir ao conteúdo
  • Cadastre-se

404_NOT_FOUND

Membros Plenos
  • Total de itens

    30
  • Registro em

  • Última visita

  • Qualificações

    N/D
  1. @Biscatão da Boate Algoritmo "AVALIAÇÃO HISTÓRIA FINAL" //AUTORES: VALDECI JUNIOR RODRIGUES // LUCAS PONTES MARIANO BARBOSA // VICTOR HUGO SANCHES DE OLIVEIRA // ITALO JOSÉ MEDEIROS Var vet :vetor[1..10] de inteiro m,n :inteiro quest :vetor[1..10,1..6] de caractere resp :caractere r,q :inteiro tela :caractere certos :inteiro erros :inteiro cont :inteiro op,op2 :inteiro confirm :caractere aux :inteiro cont2 :inteiro cont3 :inteiro procedimento q() inicio limpatela cont <- cont + 1 escreval(cont,"° QUESTÃO:") fimprocedimento procedimento separa() inicio escreval("-------------") fimprocedimento procedimento limpa() inicio escreval("Pressione ENTER...") leia(confirm) limpatela fimprocedimento procedimento definequest() inicio quest[1,1] <- "Quem foi Adolf Hitler?" quest[1,2] <- "A)Um Camponês Alemão" quest[1,3] <- "B)Líder da Alemanha Nazista no período da Segunda Guerra" quest[1,4] <- "C)Líder do Brasil no período da Segunda Guerra" quest[1,5] <- "D)Empresário Alemão" quest[1,6] <- "B"//Resposta Certa quest[2,1] <- "Quem foi Benito Mussolini?" quest[2,2] <- "A)Um ditador Italiano do PNF(Partido Nacional Fascista)" quest[2,3] <- "B)Um líder de movimentos comunistas" quest[2,4] <- "C)Fundador do Satanismo no mundo" quest[2,5] <- "D)Um traficante de escravos" quest[2,6] <- "A"//Resposta Certa quest[3,1] <- "Quando Foi a Segunda Guerra Mundial?" quest[3,2] <- "A)1909 - 1910" quest[3,3] <- "B)1920 - 1930" quest[3,4] <- "C)1939 - 1945" quest[3,5] <- "D)1800 - 1850" quest[3,6] <- "C"//Resposta Certa quest[4,1] <- "Quem foi Júlio César?" quest[4,2] <- "A)Foi um político e futuramente Imperador Romano" quest[4,3] <- "B)Foi um matemático" quest[4,4] <- "C)Foi um religioso" quest[4,5] <- "D)Foi um programador" quest[4,6] <- "A"//Resposta Certa quest[5,1] <- "Quando foi a Primeira Guerra Mundial?" quest[5,2] <- "A)1964 - 1985" quest[5,3] <- "B)1914 - 1918" quest[5,4] <- "C)1956 - 1978" quest[5,5] <- "D)1900 - 1920" quest[5,6] <- "B"//Resposta Certa quest[5,1] <- "Quando foi o Regime Militar no Brasil?" quest[5,2] <- "A)1964 - 1985" quest[5,3] <- "B)1916 - 1918" quest[5,4] <- "C)1912 - 1918" quest[5,5] <- "D)1910 - 1920" quest[5,6] <- "A"//Resposta Certa quest[6,1] <- "Quando foi descoberta a América?" quest[6,2] <- "A)1492" quest[6,3] <- "B)1500" quest[6,4] <- "C)1450" quest[6,5] <- "D)1600" quest[6,6] <- "A"//Resposta Certa quest[7,1] <- "Quando foi descoberto o Brasil?" quest[7,2] <- "A)1480" quest[7,3] <- "B)1500" quest[7,4] <- "C)1450" quest[7,5] <- "D)1600" quest[7,6] <- "B"//Resposta Certa quest[8,1] <- "Quem descobriu o Brasil?" quest[8,2] <- "A)Pedro Álvares Cabral" quest[8,3] <- "B)Getúlio Vargas" quest[8,4] <- "C)Dom Pedro I" quest[8,5] <- "D)Dom Pedro II" quest[8,6] <- "A"//Resposta Certa quest[9,1] <- "Quando foi proclamado a República?" quest[9,2] <- "A)1889" quest[9,3] <- "B)1420" quest[9,4] <- "C)1450" quest[9,5] <- "D)1700" quest[9,6] <- "A"//Resposta Certa quest[10,1] <- "Quando foi o período das Cruzadas?" quest[10,2] <- "A)1095 - 1291" quest[10,3] <- "B)900 - 1000" quest[10,4] <- "C)1000 - 1100" quest[10,5] <- "D)1100 - 1200" quest[10,6] <- "A"//Resposta Certa fimprocedimento procedimento f() inicio para q de 1 ate 10 faca vet[q] <- q fimpara para q de 10 ate 2 passo -1 faca n <- randi(q)+1 m <- vet[q] vet[q] <- vet[n] vet[n] <- m fimpara fimprocedimento procedimento menu() inicio cont2 <- cont2 + 1 escreval() escreval(" #### #### #### # # #### ") escreval(" # # # # # # # # # # ") escreval(" #### ### # # # # #### ") escreval(" # # # # # # # # # ") escreval(" # # # #### # # # ") escreval() escreval() escreval(" 1 - REALIZAR PROVA") escreval(" 2 - RELATÓRIOS") leia (op) fimprocedimento Inicio definequest() menu() f() se op = 1 entao para q de 1 ate 10 faca q() separa() escreval(quest[vet[q],1]) escreval para r de 2 ate 5 faca escreval(quest[vet[q],r]) fimpara escreval() escreva("A alternativa CORRETA é:") leia(resp) se (resp = quest[vet[q],6]) entao certos <- certos + 1 senao erros <- erros + 1 fimse fimpara limpatela menu() fimse //----------------- se cont2 = 2 entao repita limpa() se op = 1 entao escreval("VOCÊ JÁ REALIZOU A PROVA! PRESSIONE 2 PARA CONFERIR OS RELATÓRIOS...") leia (op) fimse se op = 2 entao repita escreval() escreval(" #### #### #### # # #### ") escreval(" # # # # # # # # # # ") escreval(" #### ### # # # # #### ") escreval(" # # # # # # # # # ") escreval(" # # # #### # # # ") escreval() escreval(" 1 - VER ACERTOS") escreval(" 2 - VER ERROS") escreval(" 3 - VER GABARITO") escreval(" 4 - FECHAR SISTEMA") leia(op2) se op2 = 1 entao escreval("O número de ACERTOS são:",certos) escreval() limpa() fimse se op2 = 2 entao escreval("O número de ERROS são:",erros) escreval() limpa() fimse se op2 = 3 entao para q de 1 ate 10 faca para r de 6 ate 6 faca escreva(q, "°") escreval (quest[vet[q],6]) fimpara fimpara escreval() limpa() fimse se op2 = 4 entao fimse ate op2 = 4 fimse senao se cont2 = 1 entao escreval() escreval("VOCÊ AINDA NÃO REALIZOU A PROVA!") fimse fimse Fimalgoritmo A VERSÃO FINAL FICOU ASSIM, valeu...
  2. @Simon Viegas Ahhhhhh... Entendi onde tava errando, desculpe não explicar direito, mas eu não estava entendendo praticamente nada :v Eu estava informando o vetor errado, fui muito desatento. Obrigado por tudo cara... Segue o link do algoritmo: Var vet :vetor[1..10] de inteiro m,n :inteiro quest :vetor[1..10,1..6] de caractere resp :caractere r,q :inteiro tela :caractere certos :inteiro erros :inteiro cont :inteiro op,op2 :inteiro confirm :caractere aux :inteiro cont2 :inteiro cont3 :inteiro procedimento q() inicio limpatela cont <- cont + 1 escreval(cont,"° QUESTÃO:") fimprocedimento procedimento separa() inicio escreval("-------------") fimprocedimento procedimento limpa() inicio escreval("Pressione ENTER...") leia(confirm) limpatela fimprocedimento procedimento definequest() inicio quest[1,1] <- "Quem foi Adolf Hitler?" quest[1,2] <- "A)Um Camponês Alemão" quest[1,3] <- "B)Líder da Alemanha Nazista no período da Segunda Guerra" quest[1,4] <- "C)Líder do Brasil no período da Segunda Guerra" quest[1,5] <- "D)Empresário Alemão" quest[1,6] <- "B"//Resposta Certa quest[2,1] <- "Quem foi Benito Mussolini?" quest[2,2] <- "A)Um ditador Italiano do PNF(Partido Nacional Fascista)" quest[2,3] <- "B)Um líder de movimentos comunistas" quest[2,4] <- "C)Fundador do Satanismo no mundo" quest[2,5] <- "D)Um traficante de escravos" quest[2,6] <- "A"//Resposta Certa quest[3,1] <- "Quando Foi a Segunda Guerra Mundial?" quest[3,2] <- "A)1909 - 1910" quest[3,3] <- "B)1920 - 1930" quest[3,4] <- "C)1939 - 1945" quest[3,5] <- "D)1800 - 1850" quest[3,6] <- "C"//Resposta Certa quest[4,1] <- "Quem foi Júlio César?" quest[4,2] <- "A)Foi um político e futuramente Imperador Romano" quest[4,3] <- "B)Foi um matemático" quest[4,4] <- "C)Foi um religioso" quest[4,5] <- "D)Foi um programador" quest[4,6] <- "A"//Resposta Certa quest[5,1] <- "Quando foi a Primeira Guerra Mundial?" quest[5,2] <- "A)1964 - 1985" quest[5,3] <- "B)1914 - 1918" quest[5,4] <- "C)1956 - 1978" quest[5,5] <- "D)1900 - 1920" quest[5,6] <- "B"//Resposta Certa quest[5,1] <- "Quando foi o Regime Militar no Brasil?" quest[5,2] <- "A)1964 - 1985" quest[5,3] <- "B)1916 - 1918" quest[5,4] <- "C)1912 - 1918" quest[5,5] <- "D)1910 - 1920" quest[5,6] <- "A"//Resposta Certa quest[6,1] <- "Quando foi descoberta a América?" quest[6,2] <- "A)1492" quest[6,3] <- "B)1500" quest[6,4] <- "C)1450" quest[6,5] <- "D)1600" quest[6,6] <- "A"//Resposta Certa quest[7,1] <- "Quando foi descoberto o Brasil?" quest[7,2] <- "A)1480" quest[7,3] <- "B)1500" quest[7,4] <- "C)1450" quest[7,5] <- "D)1600" quest[7,6] <- "B"//Resposta Certa quest[8,1] <- "Quem descobriu o Brasil?" quest[8,2] <- "A)Pedro Álvares Cabral" quest[8,3] <- "B)Getúlio Vargas" quest[8,4] <- "C)Dom Pedro I" quest[8,5] <- "D)Dom Pedro II" quest[8,6] <- "A"//Resposta Certa quest[9,1] <- "Quando foi proclamado a República?" quest[9,2] <- "A)1889" quest[9,3] <- "B)1420" quest[9,4] <- "C)1450" quest[9,5] <- "D)1700" quest[9,6] <- "A"//Resposta Certa quest[10,1] <- "Quando foi o período das Cruzadas?" quest[10,2] <- "A)1095 - 1291" quest[10,3] <- "B)900 - 1000" quest[10,4] <- "C)1000 - 1100" quest[10,5] <- "D)1100 - 1200" quest[10,6] <- "A"//Resposta Certa fimprocedimento procedimento f() inicio para q de 1 ate 10 faca vet[q] <- q fimpara para q de 10 ate 2 passo -1 faca n <- randi(q)+1 m <- vet[q] vet[q] <- vet[n] vet[n] <- m fimpara fimprocedimento procedimento menu() inicio cont2 <- cont2 + 1 escreval("********************************************************") escreval("* *") escreval("* *") escreval("* AVALIAÇÃO DE HISTÓRIA *") escreval("* *") escreval("* 1 - REALIZAR PROVA *") escreval("* 2 - RELATÓRIOS *") escreval("* *") escreval("* *") escreval("* *") escreval("* *") escreval("* *") escrevaL("********************************************************") leia (op) fimprocedimento Inicio definequest() menu() f() se op = 1 entao para q de 1 ate 10 faca q() separa() escreval(quest[vet[q],1]) escreval para r de 2 ate 5 faca escreval(quest[vet[q],r]) fimpara escreval() escreva("A alternativa CORRETA é:") leia(resp) se (resp = quest[vet[q],6]) entao certos <- certos + 1 senao erros <- erros + 1 fimse fimpara limpatela menu() fimse //----------------- se cont2 = 2 entao repita limpa() se op = 1 entao escreval("VOCÊ JÁ REALIZOU A PROVA! PRESSIONE 2 PARA CONFERIR OS RELATÓRIOS...") leia (op) fimse se op = 2 entao repita escreval("********************************************************") escreval("* *") escreval("* *") escreval("* AVALIAÇÃO DE HISTÓRIA *") escreval("* *") escreval("* 1 - VERIFICAR ACERTOS *") escreval("* 2 - VERIFICAR ERROS *") escreval("* 3 - CONFERIR GABARITO *") escreval("* 4 - FECHAR AVALIAÇÃO *") escreval("* *") escreval("* *") escreval("* *") escrevaL("********************************************************") leia(op2) se op2 = 1 entao escreval("O número de ACERTOS são:",certos) escreval() limpa() fimse se op2 = 2 entao escreval("O número de ERROS são:",erros) escreval() limpa() fimse se op2 = 3 entao para q de 1 ate 10 faca para r de 6 ate 6 faca escreva(q, "°") escreval (quest[vet[q],6]) fimpara fimpara escreval() limpa() fimse se op2 = 4 entao fimse ate op2 = 4 fimse senao se cont2 = 1 entao escreval() escreval("VOCÊ AINDA NÃO REALIZOU A PROVA!") fimse fimse Fimalgoritmo GRACIAS...
  3. Como posso estar fazendo isso? Não entendi muito bem a explicação...@Simon Viegas
  4. @f_neto .MP4, media player mesmo cara... O do windows, eu edito no linux abre de boa, coloco pra ver no windows e n abre(fica tela preta)
  5. @Simon Viegas Quebrei a cabeça pra caramba e não entendi, eu fiz o sistema de embaralhamento, poŕem n ta funcionando por algum erro que eu n consegui encontrar, se puder por favor me ajudar. Quero aprender esse método e gravar na cabeça mesmo porque é útil p crlh (se é que tenha algo inútil em programação). Algoritmo "Avaliação História 3.0" Var vet :vetor[1..10] de inteiro i,n :inteiro quest :vetor[1..10,1..6] de caractere resp :caractere r,q :inteiro tela :caractere certos :inteiro erros :inteiro cont :inteiro op,op2 :inteiro confirm :caractere aux :inteiro cont2 :inteiro procedimento q() inicio limpatela cont <- cont + 1 escreval(cont,"° QUESTÃO:") fimprocedimento procedimento separa() inicio escreval("-------------") fimprocedimento procedimento limpa() inicio escreval("Pressione ENTER...") leia(confirm) limpatela fimprocedimento procedimento definequest() inicio quest[1,1] <- "Quem foi Adolf Hitler?" quest[1,2] <- "A)Um Camponês Alemão" quest[1,3] <- "B)Líder da Alemanha Nazista no período da Segunda Guerra" quest[1,4] <- "C)Líder do Brasil no período da Segunda Guerra" quest[1,5] <- "D)Empresário Alemão" quest[1,6] <- "B"//Resposta Certa quest[2,1] <- "Quem foi Benito Mussolini?" quest[2,2] <- "A)Um ditador Italiano do PNF(Partido Nacional Fascista)" quest[2,3] <- "B)Um líder de movimentos comunistas" quest[2,4] <- "C)Fundador do Satanismo no mundo" quest[2,5] <- "D)Um traficante de escravos" quest[2,6] <- "A"//Resposta Certa quest[3,1] <- "Quando Foi a Segunda Guerra Mundial?" quest[3,2] <- "A)1909 - 1910" quest[3,3] <- "B)1920 - 1930" quest[3,4] <- "C)1939 - 1945" quest[3,5] <- "D)1800 - 1850" quest[3,6] <- "C"//Resposta Certa quest[4,1] <- "Quem foi Júlio César?" quest[4,2] <- "A)Foi um político e futuramente Imperador Romano" quest[4,3] <- "B)Foi um matemático" quest[4,4] <- "C)Foi um religioso" quest[4,5] <- "D)Foi um programador" quest[4,6] <- "A"//Resposta Certa quest[5,1] <- "Quando foi a Primeira Guerra Mundial?" quest[5,2] <- "A)1964 - 1985" quest[5,3] <- "B)1914 - 1918" quest[5,4] <- "C)1956 - 1978" quest[5,5] <- "D)1900 - 1920" quest[5,6] <- "B"//Resposta Certa quest[5,1] <- "Quando foi o Regime Militar no Brasil?" quest[5,2] <- "A)1964 - 1985" quest[5,3] <- "B)1916 - 1918" quest[5,4] <- "C)1912 - 1918" quest[5,5] <- "D)1910 - 1920" quest[5,6] <- "A"//Resposta Certa quest[6,1] <- "Quando foi descoberta a América?" quest[6,2] <- "A)1492" quest[6,3] <- "B)1500" quest[6,4] <- "C)1450" quest[6,5] <- "D)1600" quest[6,6] <- "A"//Resposta Certa quest[7,1] <- "Quando foi descoberto o Brasil?" quest[7,2] <- "A)1480" quest[7,3] <- "B)1500" quest[7,4] <- "C)1450" quest[7,5] <- "D)1600" quest[7,6] <- "B"//Resposta Certa quest[8,1] <- "Quem descobriu o Brasil?" quest[8,2] <- "A)Pedro Álvares Cabral" quest[8,3] <- "B)Getúlio Vargas" quest[8,4] <- "C)Dom Pedro I" quest[8,5] <- "D)Dom Pedro II" quest[8,6] <- "A"//Resposta Certa quest[9,1] <- "Quando foi proclamado a República?" quest[9,2] <- "A)1889" quest[9,3] <- "B)1420" quest[9,4] <- "C)1450" quest[9,5] <- "D)1700" quest[9,6] <- "A"//Resposta Certa quest[10,1] <- "Quando foi o período das Cruzadas?" quest[10,2] <- "A)1095 - 1291" quest[10,3] <- "B)900 - 1000" quest[10,4] <- "C)1000 - 1100" quest[10,5] <- "D)1100 - 1200" quest[10,6] <- "A"//Resposta Certa fimprocedimento procedimento menu() inicio cont2 <- cont2 + 1 escreval("********************************************************") escreval("* *") escreval("* *") escreval("* AVALIAÇÃO DE HISTÓRIA *") escreval("* *") escreval("* 1 - REALIZAR PROVA *") escreval("* 2 - RELATÓRIOS *") escreval("* *") escreval("* *") escreval("* *") escreval("* *") escreval("* *") escrevaL("********************************************************") leia (op) fimprocedimento procedimento verif() inicio para q de 1 ate 10 faca vet[q] <- q fimpara para q de 10 ate 2 passo 1 faca n <- randi(q+1) m <- vet[q] (vet[q]) <- (vet[n]) (vet[n]) <- m fimpara fimprocedimento Inicio definequest() verif() menu() se op = 1 entao para q de 1 ate 10 faca q() separa() escreval(quest[vet[q],1]) escreval para r de 2 ate 5 faca escreval(quest[vet[q],r]) fimpara escreval() escreva("A alternativa CORRETA é:") leia(resp) se (resp = quest[q,6]) entao certos <- certos + 1 senao erros <- erros + 1 fimse fimpara limpatela menu() fimse //----------------- se cont2 = 2 entao repita limpa() se op = 2 entao repita escreval("********************************************************") escreval("* *") escreval("* *") escreval("* AVALIAÇÃO DE HISTÓRIA *") escreval("* *") escreval("* 1 - VERIFICAR ACERTOS *") escreval("* 2 - VERIFICAR ERROS *") escreval("* 3 - CONFERIR GABARITO *") escreval("* 4 - FECHAR AVALIAÇÃO *") escreval("* *") escreval("* *") escreval("* *") escrevaL("********************************************************") leia(op2) se op2 = 1 entao escreval("O número de ACERTOS são:",certos) escreval() limpa() fimse se op2 = 2 entao escreval("O número de ERROS são:",erros) escreval() limpa() fimse se op2 = 3 entao para q de 1 ate 10 faca para r de 6 ate 6 faca escreva(q, "°") escreval (quest[q,r]) fimpara fimpara escreval() limpa() fimse se op2 = 4 entao fimse ate op2 = 4 fimse senao se cont2 = 1 entao escreval("VOCÊ AINDA NÃO REALIZOU A PROVA!") fimse fimse Fimalgoritmo
  6. @Greengamer99992 Cara, eu te recomendaria comprar outro, parcele no cartão que você paga de boa. Tem muita coisa pra mudar nesse pc, o meu também é bem antigo já pensei em dar um up no meu também, porém pensei bem e decidi comprar um notebook. Notebook: https://www.magazineluiza.com.br/notebook-acer-aspire-es15-es1-572-3562-intel-core-i3-4gb-1tb-led-15-6-windows-10/p/135237100/in/note/ A placa de vídeo dele é onboard, não é muito recomendado pra jogos, mas até roda alguns jogos "leves" como: Minecraft; League of Legends; Counter Strike Global Offensive.
  7. Olá pessoal, eu editei um vídeo no programa "Pitivi" no linux, mas não consigo abri - lo no windows. Preciso de ajuda...
  8. @Simon Viegas Até esqueci de tirar, eu apenas coloquei ela pra ver se ia dar resultado, mas como ja era de se esperar... Bem o randi() até serviu, porém ele repete algumas questões, então eu teria que fazer um passo que o "devair1010" falou. Tenho um tempo para rever o código e mudar algumas coisas, provavelmente concertarei isso. Caso eu tiver alguma dúvida ou erro, estarei postando aqui. adicionado 0 minutos depois @Simon Viegas Por sinal, como deixo o algoritmo que colar aqui no formato certo visualg? Tipo, coloridinho e tal igual tu faz...
  9. @devair1010 OK, mas tem um problema, ele não exibe as 10 questões, ele repete algumas.
  10. @devair1010 Quando tento fazer o randi com o gabarito das questões, todas elas ficam "A". Preciso que o gabarito também apareça aleatorio. Segue o código: Algoritmo "Alg QUestionário" Var quest :vetor[1..10,1..6] de caractere resp :caractere r,q :inteiro tela :caractere certos :inteiro erros :inteiro cont :inteiro op,op2 :inteiro confirm :caractere aux :inteiro procedimento q() inicio limpatela cont <- cont + 1 escreval(cont,"° QUESTÃO:") fimprocedimento procedimento separa() inicio escreval("-------------") fimprocedimento procedimento limpa() inicio escreval("Pressione ENTER...") leia(confirm) limpatela fimprocedimento procedimento definequest() inicio aleatorio on quest[1,1] <- "Quem foi Adolf Hitler?" quest[1,2] <- "A)Um Camponês Alemão" quest[1,3] <- "B)Líder da Alemanha Nazista no período da Segunda Guerra" quest[1,4] <- "C)Líder do Brasil no período da Segunda Guerra" quest[1,5] <- "D)Empresário Alemão" quest[1,6] <- "B"//Resposta Certa quest[2,1] <- "Quem foi Benito Mussolini?" quest[2,2] <- "A)Um ditador Italiano do PNF(Partido Nacional Fascista)" quest[2,3] <- "B)Um líder de movimentos comunistas" quest[2,4] <- "C)Fundador do Satanismo no mundo" quest[2,5] <- "D)Um traficante de escravos" quest[2,6] <- "A"//Resposta Certa quest[3,1] <- "Quando Foi a Segunda Guerra Mundial?" quest[3,2] <- "A)1939 - 1945" quest[3,3] <- "B)1920 - 1930" quest[3,4] <- "C)1940 - 1980" quest[3,5] <- "D)1800 - 1850" quest[3,6] <- "A"//Resposta Certa quest[4,1] <- "Quem foi Júlio César?" quest[4,2] <- "A)Foi um político e futuramente Imperador Romano" quest[4,3] <- "B)Foi um matemático" quest[4,4] <- "C)Foi um religioso" quest[4,5] <- "D)Foi um programador" quest[4,6] <- "A"//Resposta Certa quest[5,1] <- "Quando foi a Primeira Guerra Mundial?" quest[5,2] <- "A)1964 - 1985" quest[5,3] <- "B)1914 - 1918" quest[5,4] <- "C)1956 - 1978" quest[5,5] <- "D)1900 - 1920" quest[5,6] <- "B"//Resposta Certa quest[5,1] <- "Quando foi o Regime Militar no Brasil?" quest[5,2] <- "A)1964 - 1985" quest[5,3] <- "B)1916 - 1918" quest[5,4] <- "C)1912 - 1918" quest[5,5] <- "D)1910 - 1920" quest[5,6] <- "A"//Resposta Certa quest[6,1] <- "Quando foi descoberta a América?" quest[6,2] <- "A)1492" quest[6,3] <- "B)1500" quest[6,4] <- "C)1450" quest[6,5] <- "D)1600" quest[6,6] <- "A"//Resposta Certa quest[7,1] <- "Quando foi descoberto o Brasil?" quest[7,2] <- "A)1480" quest[7,3] <- "B)1500" quest[7,4] <- "C)1450" quest[7,5] <- "D)1600" quest[7,6] <- "B"//Resposta Certa quest[8,1] <- "Quem descobriu o Brasil?" quest[8,2] <- "A)Pedro Álvares Cabral" quest[8,3] <- "B)Getúlio Vargas" quest[8,4] <- "C)Dom Pedro I" quest[8,5] <- "D)Dom Pedro II" quest[8,6] <- "A"//Resposta Certa quest[9,1] <- "Quando foi proclamado a República?" quest[9,2] <- "A)1889" quest[9,3] <- "B)1420" quest[9,4] <- "C)1450" quest[9,5] <- "D)1700" quest[9,6] <- "A"//Resposta Certa quest[10,1] <- "Quando foi o período das Cruzadas?" quest[10,2] <- "A)1095 - 1291" quest[10,3] <- "B)900 - 1000" quest[10,4] <- "C)1000 - 1100" quest[10,5] <- "D)1100 - 1200" quest[10,6] <- "A"//Resposta Certa aleatorio off fimprocedimento procedimento menu() inicio escreval("********************************************************") escreval("* *") escreval("* *") escreval("* AVALIAÇÃO HISTÓRIA *") escreval("* *") escreval("* 1 - REALIZAR PROVA *") escreval("* 2 - RELATÓRIOS *") escreval("* 3 - FECHAR PROVA *") escreval("* *") escreval("* BOA SORTE! ;3 *") escreval("* *") escreval("* *") escreval("* *") escreval("* *") escrevaL("********************************************************") leia (op) fimprocedimento Inicio definequest() menu() se op = 1 entao para q de 1 ate 10 faca q() separa() aux <- randi(10) + 1 escreval(quest[aux,1]) escreval para r de 2 ate 5 faca escreval(quest[q,r]) fimpara escreval() escreva("A alternativa CORRETA é:") leia(resp) se (resp = quest[aux,6]) entao acertos <- acertos + 1 senao erros <- erros + 1 fimse fimpara limpatela fimse menu() //----------------- repita limpa() se op = 2 entao repita escreval(" ********************") escreval(" * 1 - VER ACERTOS *") escreval(" * 2 - VER ERROS *") escreval(" * 3 - VER GABARITO *") escreval(" * 4 - FECHAR PROVA *") escreval(" ********************") leia(op2) se op2 = 1 entao escreval("O número de ACERTOS são:",certos) escreval() limpa() fimse se op2 = 2 entao escreval("O número de ERROS são:",erros) escreval() limpa() fimse se op2 = 3 entao para q de 1 ate 10 faca aux <- randi(10) + 1 para r de 6 ate 6 faca escreva(q, "°") escreval (quest[q,aux]) fimpara fimpara escreval() limpa() fimse se op2 = 4 entao fimse ate op2 = 4 fimse se op = 3 entao fimse Fimalgoritmo
  11. @devair1010 OK... Cara tem como eu mostrar as perguntas em ordem aleatória? quest[1,1] <- "Quem foi Adolf Hitler?" quest[1,2] <- "A)Um Camponês Alemão" quest[1,3] <- "B)Líder da Alemanha Nazista no período da Segunda Guerra" quest[1,4] <- "C)Líder do Brasil no período da Segunda Guerra" quest[1,5] <- "D)Empresário Alemão" quest[1,6] <- "B"//Resposta Certa quest[2,1] <- "Quem foi Benito Mussolini?" quest[2,2] <- "A)Um ditador Italiano do PNF(Partido Nacional Fascista)" quest[2,3] <- "B)Um líder de movimentos comunistas" quest[2,4] <- "C)Fundador do Satanismo no mundo" quest[2,5] <- "D)Um traficante de escravos" quest[2,6] <- "A"//Resposta Certa Exibir a pergunta 2 primeiro e tal...
  12. @devair1010 Deixei de 1 ate 2 e até agora ta dando certo... adicionado 15 minutos depois Sabe como muda a cor ?
  13. @devair1010 Ahhhhh, entendi, eu n entendo direito o indice dos vetores. Ex: porque "para q / j de 1 ate 2 "
  14. @Simon Viegas @Simon Viegas Ta dando um erro nos Para, sabem me informar onde? Algoritmo "Alg QUestionário" Var quest :vetor[1..10,1..6] de caractere resp :inteiro r,q :inteiro tela :caractere acertos :inteiro cont : inteiro procedimento q() inicio limpatela cont <- cont + 1 escreval(cont,"° QUESTÃO:") fimprocedimento procedimento separa() inicio escreval("-------------------------------") fimprocedimento procedimento definequest() inicio quest[1,1] <- "Quem foi Adolf Hitler?" quest[1,2] <- "A)Um Camponês Alemão" quest[1,3] <- "B)Líder da Alemanha Nazista no período da Segunda Guerra" quest[1,4] <- "C)Líder do Brasil no período da Segunda Guerra" quest[1,5] <- "D)Empresário Alemão" quest[1,6] <- "B"//Resposta Certa quest[2,1] <- "Quem foi Benito Mussolini?" quest[2,2] <- "A)Um ditador Italiano do PNF(Partido Nacional Fascista)" quest[2,3] <- "B)Um líder de movimentos comunistas" quest[2,4] <- "C)Fundador do Satanismo no mundo" quest[2,5] <- "D)Um traficante de escravos" quest[2,6] <- "A"//Resposta Certa quest[3,1] <- "Quando Foi a Segunda Guerra Mundial" quest[3,2] <- "A)1939 - 1945" quest[3,3] <- "B)1920 - 1930" quest[3,4] <- "C)1940 - 1980" quest[3,5] <- "D)1800 - 1850" quest[3,6] <- "A"//Resposta Certa fimprocedimento Inicio escreval("********************************************************") escreval("* *") escreval("* *") escreval("* Questionário Perguntas *") escreval("* Aleatórias *") escreval("* *") escreval("* *") escreval("* *") escreval("* PRESSIONE ENTER PARA COMEÇAR *") escreval("* *") escreval("* BOA SORTE! ;3 *") escreval("* *") escreval("* *") escreval("* *") escreval("* *") escrevaL("********************************************************") escreva("Aperte ENTER para continuar...") leia(tela) limpatela //-----------------questão1-------------------- q() separa() definequest() escreval(quest[1,1]) escreval para q de 1 ate 5 faca para r de 2 ate 5 faca escreval(quest[q,r]) fimpara fimpara Fimalgoritmo

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×