Ir ao conteúdo
  • Cadastre-se

LoroSP

Membros Juniores
  • Total de itens

    2
  • Registro em

  • Última visita

  • Qualificações

    N/D
  1. @Simon Viegas Agradeço pela atenção, Aqui segue o enunciado: Exemplo 4 - Faça um algoritmo para calcular o novo salário sabendo que este tem aumento de 10% e imposto é de 6% já sobre o salário reajustado. Os cálculos devem ser feitos em funções. E conforme fui verificar, o exemplo que me enviaram está com vários erros de sintaxe, além dos erros que você detectou; falta de declaração de variáveis, nome de função igual ao que seria a variável, entre outros. Creio que com esta correção, agora se pode utilizar o exercício como um exemplo. Mais uma vez agradeço pelo auxílio. Loro SP
  2. Boa tarde, Recebi um exercício em pseudocódigo para utilizar no VisuAlg. Porém por mais que eu tenha tentado, continua dando erro, pensei ser a Sintaxe mas logo aparece o erro de novo. Segue o algoritmo do exercício: Algoritmo "SUB-ROTINA-EX04" // // Função: calcular o novo salário // Autor: Ana Fernanda // Data: 14/01/2019 // seção de declarações de variáveis globais var s, sal, ns: real // a seguir a sub-rotina para calcular o aumento // como tem retorno será uma função funcao aumento (sal: real):real var aumento: real inicio aumento <- sal * 0.1 retorne aumento fimfuncao funcao imposto (sal: real):real inicio imposto <- sal * 0.06 retorne imposto fimfuncao // início do programa principal inicio escreval ("Digite o salário ") leia (sal) s <- sal + aumento(sal) ns <- s - imposto(s) escreval ("Novo Salário = ",ns) fimalgoritmo Alguma mente descansada poderia verificar? Agradeço antecipadamente. LoroSP

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...