Ir ao conteúdo
  • Cadastre-se

jonas steindorff gomes

Membros Juniores
  • Total de itens

    1
  • Registro em

  • Última visita

  • Qualificações

    N/D
  1. Nessa Estrutura se eu tirar a condição enquanto a minha operação segue corretamente, porém, a partir do momento que coloco a condição enquanto para a idade ele segue fazendo a leitura, mas quando ela encerra ela volta a leitura no sexo ainda da 1 pessoa. Estou ficando frustrado, pois não estou conseguindo resolver essa única situação. //Foi feita uma pesquisa entre os habitantes de uma região. Foram coletados // os dados de idade, //sexo (M/F) e salário. Faça um algoritmo que informe: //a) a média de salário do grupo; //b) a maior e a menor idade do grupo; //c) a quantidade de mulheres com salário até R$100,00. //Encerre a entrada de dados quando for digitada uma idade negativa. Var i, idade, maior_idade, menor_idade, contador, contadorFem, contadorMasc: inteiro sexo, m, f, masculino: caracter salario, soma_salario: real Inicio menor_idade<- 999 para i de 1 ate 4 faca escreval ("Idade da ", i, "a pessoa:") leia(idade) enquanto idade > 0 faca escreval ("Sexo M para masculino ou F para feminino:", i, "a pessoa") leia(sexo) escreval ("Salario: ") leia(salario) soma_salario<- soma_salario + salario se (sexo = "f") e (salario<=100) entao contador <- contador + 1 fimse se (idade > maior_idade)entao maior_idade <- idade fimse se (idade < menor_idade)entao menor_idade <- idade fimse fimenquanto fimpara soma_salario<- soma_salario/i escreval ("A média do salário do grupo:", soma_salario) escreval ("Maior idade:", maior_idade) escreval ("Menor idade:", menor_idade) escreval ("Quanditade de mulheres com salario menor que R$ 100,00:", contador) Fimalgoritmo

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...