Ir ao conteúdo
  • Cadastre-se

danielmoreira

Membros Juniores
  • Total de itens

    1
  • Registro em

  • Última visita

  • Qualificações

    N/D
  1. Bom Dia, por favor como fica esse algoritmo em java? Obrigado! <algoritmo "BuscaBinaria" var a : vetor[0..14] de inteiro lowerBound, upperBound, curIn, searchKey : inteiro fim : logico inicio a[0] <- 1 a[1] <- 2 a[2] <- 4 a[3] <- 5 a[4] <- 8 a[5] <- 10 a[6] <- 11 a[7] <- 20 a[8] <- 25 a[9] <- 32 a[10] <- 33 a[11] <- 37 a[12] <- 39 a[13] <- 46 a[14] <- 50 escreval("Busca: ") leia(searchKey) lowerBound <- 0 upperBound <- 14 fim <- falso enquanto fim = falso faca curIn <- int((lowerBound + upperBound) / 2) escreval(lowerBound, " " , upperBound, curIn) se a[curIn] = searchKey entao escreval("achou na posicao" , curIn) fim <- verdadeiro senao se lowerBound > upperBound entao escreval("não achou") fim <- verdadeiro senao se a[curIn] < searchKey entao lowerBound <- curIn + 1 senao upperBound <- curIn - 1 fimse fimse fimse fimenquanto fimalgoritmo>

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

Aprenda_a_Ler_Resistores_e_Capacitores-capa-3d-newsletter.jpg

EBOOK GRÁTIS!

CLIQUE AQUI E BAIXE AGORA MESMO!