Ir ao conteúdo
  • Cadastre-se

xisxisde

Membro Júnior
  • Total de itens

    12
  • Cadastrado em

  • Última visita

  • Qualificações

    0%
  1. Por favor, dicas, palavras, textos. Acho que é por analogia, vou colocar um exemplo aqui mas não me deem a resposta, resolverei dois exercicios e terminarei minha epopeia em algoritmos e irei passar para programação. Exemplo (eu sei que é matrizes): 1. Construa um algoritmo que, tendo como dados de entrada dois pontos quaisquer no plano, P(x1,y1) e P(x2,y2), escreva a distância entre eles. A fórmula que efetua tal cálculo é: "raiz quadradade de": (x²-x1)² + (y2-y1)² PS: Não sei mexer com raiz quadrada em algoritmo, y2 e y1 são relacionadas a variaveis? valeu PS2: É matrizes? Como vou criar um plano se não for matrizes?
  2. programa { funcao inicio() { real m = 1.30 real d = 1.00 real n real preco real valor leia(m) leia(d) leia(preco) leia(valor) se (n >= 12) { preco = d } senao{ preco = m } escreva("Numero de maças compradas: ") leia(n) valor = n*preco escreva(valor) } Então, o que esta acontecendo é que antes de aparecer "Numero de maças compradas: " para eu escrever o numero e o algoritmo me dar o resultado do preço (o que esta funcionando) me pede 4 valores e eu tenho que dar enter, antes de aparecer "Numero de maças compradas: " e eu acho que é por causa da inicialização das variaveis no começo do programa (o que o portugol studio pede), o que eu deveria fazer? colocar a inicialização no final? porque sem inicialização da erro, abraço valeu ajuda ae Então, mudou tudo, o código ta assim agora: funcao inicio() { real m = 1.30 real d = 1.00 real n real preco real valor escreva("Numero de maças compradas: ") leia(n) se (n >= 12) { preco = d } senao { preco = m } valor = n*preco escreva(valor) } } E o problema é que pra menor que doze ta me pedindo um valor real pra variavel n, doidera, pra maior que doze funciona. Edit ultimo: o erro não acontece mais, só parou, doidera.
  3. obrigado por tudo @devair1010 e @kgincom essas informações não preciso postar mais duvidas ... valeu
  4. Eu entendi o que você fez, você fez o loop do sim mas não declarou negatividade (falso) para receber fim dos calculos simplesmente deu um comando "escreva ("Fim dos calculos."). Sem ser desrespeitoso é claro eu so estou falando o que vi, parece que esses exercicios dessa professora flavia são meio estranhos kkkkkkkkkkkkkk
  5. Só passando para informar, seria melhor usar o portugol studio, ja estou passando para ele, muito melhor...
  6. Eu tenho tido problemas em resolver exercícios propostos por uma apostila com a sintaxe de repetição "enquanto", o problema é que eu não vejo erro no meu algoritmo e ainda assim o console do VisualG não me dá o que meu algoritmo está programado para fazer, irei postar dois algoritmos aqui com o problema escrito e o que está acontecendo com cada um deles, ajuda por favor, como eu acho que esta correto não sei mais por onde seguir... Primeiro: Dizer sim e não (com enquanto), problema: " Escreva um algoritmo para ler dois valores. Após a leitura deve-se calcular a soma dos valores lidos e armazená-la em uma variável. Após o cálculo da soma, escrever o resultado e escrever também a pergunta 'Novo Cálculo (S/N)?'. Deve-se ler a resposta e se a resposta for 'S' (sim), deve-se repetir todos os comandos (instruções) novamente, mas se a resposta for 'N' (não), o algoritmo deve ser finalizado escrevendo a mensagem 'Fim dos Cálculos'. " O problema na resolução desse problema é que eu não consigo receber a mensagem: "Fim dos cálculos." quando eu dou uma resposta negativa no console do VisualG, mas quando eu uso o caractere que relacionei (obrigado @devair1010) com a variável booleana com uma resposta positiva o looping da repetição dos cálculos acontece, aqui está como eu vejo totalmente correto e devendo aparecer a mensagem de fim dos cálculos: Algoritmo "naoentendinada" // // // Descrição : Aqui você descreve o que o programa faz! (função) // Autor(a) : Nome do(a) aluno(a) // Data atual : 22/06/2021 Var // Seção de Declarações das variáveis a: real b: real c: logico opcao: caractere resultado: real Inicio // Seção de Comandos, procedimento, funções, operadores, etc... enquanto (c = "verdadeiro") faca escreva ("Informe um numero:") leia (a) escreva ("Informe um numero:") leia (b) resultado <- a+b escreval ("O resultado é:",resultado) escreva ("Novo calculo (S/N)?") leia (opcao) se opcao = "s" entao c = "verdadeiro" fimse leia (opcao) se opcao = "n" entao c = "falso" escreva ("Fim dos Calculos.") fimse fimenquanto Neste algoritmo /\ fiquei pensando se o problema não esta em ter um ( c = "verdadeiro" ) no meio do codigo, sei la. O outro problema (que alias e bem simples): Escreva um algoritmo para ler um valor entre 1 (inclusive) e 10 (inclusive). Se o valor lido não estiver entre 1 (inclusive) e 10 (inclusive), deve ser lido um novo valor. Algoritmo "semnome" // // // Descrição : Aqui você descreve o que o programa faz! (função) // Autor(a) : Nome do(a) aluno(a) // Data atual : 27/06/2021 Var // Seção de Declarações das variáveis a: real b: real Inicio // Seção de Comandos, procedimento, funções, operadores, etc... enquanto (1<=10) faca escreva ("Informe um numero:") leia (a) se (a) <> (1<=10) entao leia (b) (b) = 20 fimse fimenquanto Fimalgoritmo também tentei colocar "escreva (b)" no lugar de "leia (b)" mas me da erro exatamente nessa linha ou na (b) = 20 não lembro. alguém ajuda, corrige, sei la, me fala se ta certo, se é o visual g, alguma coisa, porque sozinho não vou conseguir avançar...
  7. Então @devair1010o loop ja esta acontecendo, é que eu estava escrevendo uma tecla e apertando enter, depois de escrever S e dar enter, dar enter de novo, o loop acontece, so pra esclarecer e obrigado por tudo.
  8. Opa valeu cara agora a duvida foi esclarecida totalmente, obrigado.
  9. Então, @devair1010, deixa eu te citar de novo só pra você vim aqui, eu ainda estou tentando resolver este exercício com enquanto faça, se alguém quiser pegar da onde eu parei, está dando erro na linha c = "falso" porque o loop não está ocorrendo, acho que é preciso de mais alguns comandos só não sei quais, sinceramente, não sei porque o loop não acontece, mas não vou pedir mais ajuda vou tentar resolver sozinho, talvez na expressão logica um ou ou e ou xou sei la, vou deixar o código do enquanto faça da onde eu parei aqui pra quem precisar: algoritmo "não entendi nada" // Descrição : Aqui você descreve o que o programa faz! (função) // Autor(a) : Nome do(a) aluno(a) // Data atual : 22/06/2021 var a: real b: real c: logico opcao: caractere resultado: real inicio enquanto (c = "verdadeiro") faca escreva ("Informe um numero:") leia(a) escreva ("Informe um numero:") leia(b) resultado <- a+b escreval("O resultado é:",resultado) escreva ("Novo calculo (S/N)?") leia(opcao) se opcao = "n" entao c = "falso" fimse leia(opcao) se opcao = "s" entao c = "verdadeiro" fimse fimenquanto Eu sei que é quase tudo como você fez, mas eu criei do nada só algumas coisas que eu copiei, as básicas então, ainda não sei porque o loop não acontece mas tudo bem...
  10. @devair1010 muito obrigado, vou estudar este algoritmo que você postou
  11. Então, neste tópico há duas coisas: a resolução de um problema e algumas duvidas, finalizei meu estudo de algoritmos, mas tenho algumas duvidas, uma muito pertinente que quero encontrar a solução logo, vamos lá, primeiro as duvidas: Qual a diferença entre projeto logico e físico? Como usar uma variável boolean eficientemente (se puder dar exemplos, de (S/N) com algoritmos seria ótimo) ? Quais são os comandos de input das teclas do teclado, e do mouse para algoritmos, se existem, por exemplo eu quero apertar a tecla enter depois de escrever (S/N)? ... (sim eu sei que no dos você aperta o enter mas eu gostaria de ter esta pergunta respondida) Agora vamos ao problema que eu "resolvi", o resultado no VisualG e o DOS todo em negrito, se eu apertar enter muitas vezes ele da erro em uma das linhas ... O problema: Escreva um algoritmo para ler dois valores. Após a leitura deve-se calcular a soma dos valores lidos e armazená-la em uma variável. Após o cálculo da soma, escrever o resultado e escrever também a pergunta 'Novo Cálculo (S/N)?'. Deve-se ler a resposta e se a resposta for 'S' (sim), deve-se repetir todos os comandos (instruções) novamente, mas se a resposta for 'N' (não), o algoritmo deve ser finalizado escrevendo a mensagem 'Fim dos Cálculos'. PS: Sobre este problema, se alguém conseguir fazer um algoritmo para o VisualG que escreva "Novo calculo (S/N)?" e você aperte a tecla S ou N e de enter e tal por favor, é isso que estou tentando e procurando, além das outras duvidas... A solução no VisualG: algoritmo "sem nome" // Descrição : Aqui você descreve o que o programa faz! (função) // Autor(a) : Nome do(a) aluno(a) // Data atual : 21/06/2021 var A: inteiro B: inteiro C: inteiro S: logico N: logico inicio A <- 10 B <- 20 leia(A) leia(B) leia(A)+(B) = (C) leia(C) escreval("Novo Calculo (S/N)?") leia(S) ou (N) se (S) fimse enquanto (A+B = 30) faca (A)+(B) = 30 fimenquanto se (N) escreval ("Fim dos calculos") fimse
  12. Estou tendo um problema com meu eclipse e um problema no visualg, segue abaixo tudo isso: O problema no eclipse é que ele não reconhece a linguagem C/C++ nem a Python, ou melhor, a python ele reconhece mas não aparece no "File>New>" Python project ou C/C++ project, este é o problema que esta acontecendo no eclipse, o que eu fiz? desinstalei completamente o eclipse, do registro, o java, tudo e no meu eclipse não esta aparecendo a janela primaria onde tem a opção para desenvolvedores C/C++. (não irei postar nenhuma screen ou video porque ja esta tudo explicado). Sim, as linguagens estão (estavam porque desinstalei tudo) sendo lidas no prompt de comando mas mesmo assim o eclipse não reconhece, so reconhece a java, não estou conseguindo resolver. O proximo problema é um exercicio de uma apostila de algoritmos que estou estudando da FACCAT vou deixar o link dela neste topico, vai que ajuda alguem, então, quero criar um algoritmo com variaveis logicas (booling) para somente apertar S (sim) ou N (não), mas o visualg me da um erro na linha "Fimalgoritmo" e o erro pede que eu escreva "fimse" sendo que ja esta no corpo do algoritmo, se alguem puder somente corrigir e me dizer o que aconteceria no console, obrigado, esta abaixo: PS: Link para a apostila de algoritmos, professora Flavia: https://fit.faccat.br/~fpereira/apostilas/apostila_algoritmos_mar2007.pdf N: logico S: logico X: caractere escreva ("Sim ou não?") se X = N então leia X se X = S então leia X fimse

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas comunidades sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

Redes-Wi-Fi-capa-3d-newsletter.png

EBOOK GRÁTIS!

CLIQUE AQUI E BAIXE AGORA MESMO!