Ir ao conteúdo
  • Cadastre-se

Tuufee

Membros Plenos
  • Total de itens

    19
  • Registro em

  • Última visita

  • Qualificações

    N/D

Reputação

18

Informações gerais

  • Cidade e Estado
    Americana/SP
  • Sexo
    Masculino
  1. Boa noite, peguei esse notebook do meu cunhado para formatar, no entanto a bios estava com senha, e por conta disso não conseguia dar boot no note, tentei remover a bateria moeda para tentar resetar a bios mas sem sucesso, foi depois de algumas vezes ligando e desligando pra ver se resetava, que o note parou de ligar. O símbolo de Wifi e energia ficam ligados, mas o outro símbolo de "database" fica piscando, se puderem me ajudar, agradeço desde já.
  2. Boa tarde, eu tenho um lista gigante com vários grupos de caracteres aleatórios já separados com o comando "split", só que preciso ver se os caracteres iniciais começam por exemplo com "a" e terminam com "b", só que não sei como tratar separadamente cada grupo de caracteres, já que cada grupo não possui um índice, e como a lista é muito grande e não existe padrão dos números de caracteres em cada grupo não tem jeito de eu verificar eles com o comando "[x:x]" pelas posições. Se puderem me dar um luz de como procurar seria muito bom, obrigado.
  3. @Simon Viegas 1-) Em relação ao "fim..se" realmente vacilei, não tinha percebido isso, já arrumei. 2-) O alinhamento ficou errado pelo fato de eu ter ficado testando os espaços entre as respostas, para ficar tudo padronizado, como em uma tabela, ai acabei esquecendo assim. 3-) O interrompa já vi vários códigos em outras linguagens assim, achei que seria interessante para mim usar pelo fato de que ele a partir do momento em que eu digitasse "0" o código pararia, e no caso do "se" para o código continuar quando eu digitasse "0" ele continuaria o loop até no "até = 0" e acumularia os valores até chegar no final do código. 4-) o maior e menor era pra realmente ficar assim, exibir o maior e menor caso forem diferentes, e exibir somente um caso ele fosse igual, o problema foi que não adaptei o texto para escrever isso.
  4. @Simon Viegas Agora acredito que o código esta completo, se pudesse, gostaria que desse uma olhada. Algoritmo "semnome" // Disciplina : [Algoritmo] // Professor : // Descrição : 4 - Operários // Autor(a) : // Data atual : 04/05/2017 Var A,B,C,sex,matri,pecas,MC,FA,faixapecas,sexmaior,sexmenor: inteiro nome,nomemaior,nomemenor,classmaior,classmenor: caracter salarioBase,salariofinal,total,total2,maiorsalario,menorsalario,taxaA,taxaB,taxaC : real Inicio Menorsalario <- 9999 repita salarioBase <- 888 faixapecas <- 30 taxaA <- 0/100 taxaB <- 3/100 taxaC <- 5/100 escreval("Digite o nome do operário : ") leia(nome) escreval("Digite o número da matricula do operário : ") leia(matri) se (matri = 0) então interrompa fimse Escreval("Digite o número de peças feitas pelo operário : ") leia(pecas) Escreval("Digite o sexo do operário, 1 para masc e 2 para fem : ") leia(sex) Se (pecas <= 30) então salarioFinal <- salarioBase + ((pecas - faixapecas) * (salarioBase * taxaA)) A <- A+1 Escreval("O salário do operário é ",salariofinal:30) Senao se (pecas >= 31) e (pecas <= 35) então salarioFinal <- salarioBase + ((pecas - faixapecas) * (salarioBase * taxaB)) B <- B+1 Escreval("O salário do operário é ",salariofinal:30) senao se (pecas >= 36) então salarioFinal <- salarioBase + ((pecas - faixapecas) * (salarioBase * taxaC)) C <- C+1 Escreval("O salário do operário é ",salariofinal:30) fimse fimse fimse Se (pecas >= 36) e (Sex = 1) então MC <- MC+1 fimse Se (pecas <= 30) e (sex = 2) então FA <- FA+1 fimse Escreval("Numero da matrícula do operário é : ",matri:17) Escreval("Número de peças fabricadas é : ",pecas:22) Se (sex = 1) então Escreval("O sexo do operário é : Masculino ") senao Se (sex = 2) então escreval("O sexo do operário é Feminino ") fimse fimse Se (pecas <= 30) e (salariofinal > maiorsalario) então maiorsalario <- salariofinal nomemaior <- nome sexmaior <- sex classmaior <- "A" fimse Se (pecas <= 30) e (salariofinal < menorsalario) então menorsalario <- salariofinal nomemenor <- nome sexmenor <- sex classmenor <- "A" fimse se (pecas >= 31) e (pecas <= 35) e (salariofinal > maiorsalario) então maiorsalario <- salariofinal nomemaior <- nome sexmaior <- sex classmaior <- "B" fimse se (pecas >= 31) e (pecas <= 35) e (salariofinal < menorsalario) então menorsalario <- salariofinal nomemenor <- nome sexmenor <- sex classmenor <- "B" fimse se (pecas >= 36) e (salariofinal > maiorsalario) então maiorsalario <- salariofinal nomemaior <- nome sexmaior <- sex classmaior <- "C" fimse se (pecas >= 36) e (salariofinal < menorsalario) então menorsalario <- salariofinal nomemenor <- nome sexmenor <- sex classmenor <- "C" fimse total <- salariofinal total2 <- total2 + total ate (matri = 0) Limpatela Escreval ("O total de salários pagos pela fábrica é ",total2:20) Escreval ("O numero de operários na Classe A é ",A:23) Escreval ("O numero de operários na Classe B é ",B:23) Escreval ("O numero de operários na Classe C é ",C:23) Escreval ("O número de operários do sexo masculino na classe C é ",MC:5) Escreval ("O número de operários Do sexo feminino na classe A é ",FA:6) Escreval() Se (maiorsalario <> menorsalario) então Escreval ("O Maior salário é ",maiorsalario) Escreval ("o nome do operário com maior salário é ",nomemaior) Escreval ("A classe do operário com maior salário é ",classmaior) Se (sexmaior = 1) então Escreval ("O sexo do operário com o maior salário é Masculino") Escreval() Escreval ("o Menor salário é ",menorsalario) Escreval ("O nome do operário com menor salário é ",nomemenor) Escreval ("A classe do operário com menor saláro é ",classmenor) Se (sexmenor = 1) então Escreval ("O sexo do operário com menor salário é Masculino") senao se (sexmenor = 2) então Escreval ("O sexo do operário com menor salário é Feminino") fimse fimse fimse fimse Se (sexmaior = 2) então Escreval ("O sexo do operário com maior salário é Feminino") Escreval() Escreval ("o Menor salário é ",menorsalario) Escreval ("O nome do operário com menor salário é ",nomemenor) Escreval ("A classe do operário com menor saláro é ",classmenor) Se (sexmenor = 1) então Escreval ("O sexo do operário com menor salário é Masculino") senao se (sexmenor = 2) então Escreval ("O sexo do operário com menor salário é Feminino") fimse fimse fimse Se (maiorsalario = menorsalario) então Escreval ("O Maior salário é ",maiorsalario:43) Escreval ("o nome do operário com maior salário é ",nomemaior) Escreval ("A classe do operário com maior salário é ",classmaior) Se (sexmenor = 1) então Escreval ("O sexo do operário com menor salário é Masculino") senao se (sexmenor = 2) então Escreval ("O sexo do operário com menor salário é Feminino") fimse fimse fimse fimalgoritmo
  5. Boa noite, estou tentando fazer um algoritmo simples de vetor que seria esse: "Escreva um algoritmo que, leia um vetor de 10 posições, e determine e exiba : § A média dos valores deste vetor; § O maior elemento deste vetor; A posição de menor elemento deste vetor" consegui fazer quase tudo, só preciso conseguir colocar a posição do menor vetor, não sei se é possível no visualg adicionar a posição do vetor na variável, gostaria que me respondessem, obrigado. Algoritmo "semnome" // Disciplina : [Linguagem e Lógica de Programação] // Professor : Antonio Carlos Nicolodi // Descrição : Aqui você descreve o que o programa faz! (função) // Autor(a) : Nome do(a) aluno(a) // Data atual : 13/05/2017 Var vet : vetor [1..10] de inteiro c,maior,menor,i: inteiro media : real Inicio para c de 1 ate 10 faca escreval("digite um numero inteiro : ") leia(vet[c]) media <- media + vet[c] fimpara media <- media / 10 para c de 1 ate 10 faca Se (vet[c] > maior) então maior <- vet[c] fimse Se (c = 1) então menor <- vet[c] fimse Se (vet[c] < menor) então menor <- vet[c] fimse fimpara escreval("A media dos numeros do vetor é ",media) escreval("o maior numero no vetor é ",maior) escreval("A posição de menor valor no vetor é ",menor) Fimalgoritmo
  6. @Simon Viegas Fiz as alterações como você sugeriu, adicionei o nome, sexo e classe do maior e menor, só que estou ficando louco tentando colocar o menor valor dentro da variável, nunca da certo de todas formas que tento, o máximo que consegui foi assim, o resultado do salário vai acumulando no maior salário 1000,2000,3000 etc... só que se eu não adiciono um número menor, nunca vai atribuir um valor na variável menor, se depois desses 3 salários eu parar o código o menor valor não será gravado, ao invés de ter 1000 como menor valor, isso foi o mais próximo que consegui, faz horas que estou tentando é nada, vou postar onde estou atualmente. Algoritmo "semnome" // Disciplina : [Algoritmo] // Professor : // Descrição : 4 - Operários // Autor(a) : // Data atual : 04/05/2017 Var A,B,C,sex,matri,pecas,MC,FA,faixapecas,sexmaior,sexmenor,classmaior,classmenor: inteiro nome,nomemaior,nomemenor : caracter salarioBase,salariofinal,total,total2,maiorsalario,menorsalario,taxaA,taxaB,taxaC : real Inicio repita salarioBase <- 888 faixapecas <- 30 taxaA <- 0/100 taxaB <- 3/100 taxaC <- 5/100 escreval("Digite o nome do operário : ") leia(nome) escreval("Digite o número da matricula do operário : ") leia(matri) se (matri = 0) então interrompa fimse Escreval("Digite o número de peças feitas pelo operário : ") leia(pecas) Escreval("Digite o sexo do operário, 1 para masc e 2 para fem : ") leia(sex) Se (pecas <= 30) então salarioFinal <- salarioBase + ((pecas - faixapecas) * (salarioBase * taxaA)) A <- A+1 Escreval("O salário do operário é ",salariofinal) Senao se (pecas >= 31) e (pecas <= 35) então salarioFinal <- salarioBase + ((pecas - faixapecas) * (salarioBase * taxaB)) B <- B+1 Escreval("O salário do operário é ",salariofinal) senao se (pecas >= 36) então salarioFinal <- salarioBase + ((pecas - faixapecas) * (salarioBase * taxaC)) C <- C+1 Escreval("O salário do operário é ",salariofinal) fimse fimse fimse Se (pecas >= 36) e (Sex = 1) então MC <- MC+1 fimse Se (pecas <= 30) e (sex = 2) então FA <- FA+1 fimse Escreval("Numero da matrícula do operário é ",matri) Escreval("Número de peças fabricadas é ",pecas) Se (sex = 1) então Escreval("O sexo do operário é Masculino ") senao Se (sex = 2) então escreval("O sexo do operário é Feminino ") fimse fimse Se (pecas <= 30) e (salariofinal > maiorsalario) então maiorsalario <- salariofinal nomemaior <- nome sexmaior <- sex classmaior <- A senao Se (pecas <= 30) e (salariofinal < menorsalario) então menorsalario <- salariofinal nomemenor <- nome sexmenor <- sex classmenor <- A senao se (pecas >= 31) e (pecas <= 35) e (salariofinal > maiorsalario) então maiorsalario <- salariofinal nomemaior <- nome sexmaior <- sex classmaior <- B senao se (pecas >= 31) e (pecas <= 35) e (salariofinal < menorsalario) então menorsalario <- salariofinal nomemenor <- nome sexmenor <- sex classmenor <- B senao se (pecas >= 36) e (salariofinal > maiorsalario) então maiorsalario <- salariofinal nomemaior <- nome sexmaior <- sex classmaior <- C senao se (pecas >= 36) e (salariofinal < menorsalario) então menorsalario <- salariofinal nomemenor <- nome sexmenor <- sex classmenor <- C fimse fimse fimse fimse fimse fimse total <- salariofinal total2 <- total2 + total ate (matri = 0) Limpatela Escreval ("O total de salários pagos pela fábrica é ",total2:20) Escreval ("O numero de operários na Classe A é ",A:23) Escreval ("O numero de operários na Classe B é ",B:23) Escreval ("O numero de operários na Classe C é ",C:23) Escreval ("O número de operários do sexo masculino na classe C é ",MC:5) Escreval ("O número de operários Do sexo feminino na classe A é ",FA:6) Escreval ("O Maior salário é ",maiorsalario:43) Escreval ("o Menor salário é ",menorsalario:41) Escreval ("o nome do operário com maior salário é ",nomemaior) Escreval ("A classe do operário com maior salário é ",classmaior) Escreval ("O nome do operário com menor salário é ",nomemenor) Escreval ("A classe do operário com menor saláro é ",classmenor)
  7. @Simon Viegas reescrevi o código como você sugeriu, ficou realmente melhor, mas agora estou com problemas para saber o menor salário entre os operários, já tentei de várias formas e não consigo atribuir o menor valor dentro da variável, vou postar o código Algoritmo "semnome" // Disciplina : [Algoritmo] // Professor : // Descrição : 4 - Operários // Autor(a) : // Data atual : 04/05/2017 Var A,B,C,sex,matri,pecas,taxaA,taxaB,taxaC,MC,FA,porcentagem: inteiro nome : caracter salarioBase,salarioBruto,total,total2,maior,menor : real Inicio repita salarioBase <- 888 taxaA <- 0 taxaB <- 3 taxaC <- 5 escreval("Digite o nome do operário : ") leia(nome) escreval("Digite o número da matricula do operário : ") leia(matri) se (matri = 0) então interrompa fimse Escreval("Digite o número de peças feitas pelo operário : ") leia(pecas) Escreval("Digite o sexo do operário, 1 para masc e 2 para fem : ") leia(sex) Se (pecas <= 30) então porcentagem <- (pecas - 30) * taxaA salarioBruto <- salarioBase + (salarioBase * porcentagem/100) A <- A+1 Escreval("O salário do operário é ",salarioBruto) Senao se (pecas = 31) então porcentagem <- (pecas - 30) * taxaB salarioBruto <- salarioBase + (salarioBase * porcentagem/100) B <- B+1 Escreval("O salário do operário é ",salarioBruto) senao se (pecas = 32) então porcentagem <- (pecas - 30) * taxaB salarioBruto <- salarioBase + (salarioBase * porcentagem/100) B <- B+1 Escreval("O salário do operário é ",salarioBruto) senao se (pecas = 33) então porcentagem <- (pecas - 30) * taxaB salarioBruto <- salarioBase + (salarioBase * porcentagem/100) B <- B+1 Escreval("O salário do operário é ",salarioBruto) senao se (pecas = 34) então porcentagem <- (pecas - 30) * taxaB salarioBruto <- salarioBase + (salarioBase * porcentagem/100) B <- B+1 Escreval("O salário do operário é ",salarioBruto) senao se (pecas = 35) então porcentagem <- (pecas - 30) * taxaB salarioBruto <- salarioBase + (salarioBase * porcentagem/100) B <- B+1 Escreval("O salário do operário é ",salarioBruto) senao se (pecas >= 36) então porcentagem <- (pecas - 30) * taxaC salarioBruto <- salarioBase + (salarioBase * porcentagem/100) C <- C+1 Escreval("O salário do operário é ",salarioBruto) fimse fimse fimse fimse fimse fimse fimse Se (pecas >= 36) e (Sex = 1) então MC <- MC+1 fimse Se (pecas <= 30) e (sex = 2) então FA <- FA+1 fimse Escreval("Numero da matrícula do operário é ",matri) Escreval("Número de peças fabricadas é ",pecas) Se (sex = 1) então Escreval("O sexo do operário é Masculino ") senao Se (sex = 2) então escreval("O sexo do operário é Feminino ") fimse fimse Se (salarioBruto > maior) e (maior < menor) então maior <- salarioBruto menor <- maior Senao Se (salarioBruto > maior) então maior <- salarioBruto fimse fimse se (salarioBruto < maior) e (salarioBruto < menor)então menor <- salarioBruto fimse total <- salarioBruto total2 <- total2 + total ate (matri = 0) Limpatela Escreval ("O total de salários pagos pela fábrica é ",total2:20) Escreval ("O numero de operários na Classe A é ",A:23) Escreval ("O numero de operários na Classe B é ",B:23) Escreval ("O numero de operários na Classe C é ",C:23) Escreval ("O número de operários do sexo masculino na classe C é ",MC:5) Escreval ("O número de operários Do sexo feminino na classe A é ",FA:6) Escreval ("O Maior salário é ",maior:43) Escreval ("o Menor salário é ",menor:41) Fimalgoritmo
  8. @Simon Viegas Na estrutura de seleção realmente disse errado, é uma condição e não uma variável, em relação a formula desculpe a ignorância mas não entendi como fazer, porque se eu colocar 1 variável para cada taxa, eu teria que colocar vários tipo 3%,6%,9%,12%,15%, então acredito que o código poderia ficar mais "bonito" mais em relação a funcionalidade daria na mesma, não sei se é realmente o que você quis dizer.
  9. @Simon Viegas No caso do "se..senao" eu sabia que poderia ter colocado ele ali, só que como eu teria que colocar vários "fimse" no final achei que não iria fazer diferença, mas pelo visto faz. Na estrutura de seleção realmente entendi o que você quis dizer, só que no caso desse código acredito que pelo fato de eu ter colocado uma variável para "<=30" o resultado sairia correto, porque o valor se fosse menor seria acumulado na mesma. No salário não entendi muito bem o que você quis dizer, mas acredito que seja o fato de eu ter colocado uma variável para cada resultado de salário, se for isso, eu fiz assim porque o salário é 3% a mais para cada peça acima de 30, a partir do momento que o funcionário fez mais que 30, eu não achei nenhuma solução melhor pra isso então fiz desse jeito.
  10. @Simon Viegas Reescrevi todo o código em "se..fimse", acredito que com o "escolha caso" não iria dar certo mesmo, deu quase tudo certo, as únicas coisas que faltam seria o "menor salário" que não entra na variável, acredito que a sintaxe esta errada, más não consegui resolver, outra coisa que preciso é acumular o maior e menor salário com, nome,salário,sexo,classe, se puder me dar uma luz, vou postar o código. Algoritmo "semnome" // Disciplina : [Algoritmo] // Professor : // Descrição : 4 - Operários // Autor(a) : // Data atual : 04/05/2017 Var A,B,C,sex,matri,pecas,porc,MC,FA: inteiro nome : caracter salarioA, salarioB, salarioC,total,total2,maior,menor : real Inicio repita escreval("Digite o nome do operário : ") leia(nome) escreval("Digite o número da matricula do operário : ") leia(matri) se (matri = 0) então interrompa fimse Escreval("Digite o número de peças feitas pelo operário : ") leia(pecas) Escreval("Digite o sexo do operário, 1 para masc e 2 para fem : ") leia(sex) Se (pecas <= 30) então salarioA <- 888 A <- A+1 Escreval("O salário do operário é ",salarioA) Fimse Se (pecas = 31) então salarioB <- 888 + (888 * 3/100) B <- B+1 Escreval("O salário do operário é ",salarioB) fimse Se (pecas = 32) então salarioB <- 888 + (888 * 6/100) B <- B+1 Escreval("O salário do operário é ",salarioB) fimse Se (pecas = 33) então salarioB <- 888 + (888 * 9/100) B <- B+1 Escreval("O salário do operário é ",salarioB) fimse Se (pecas = 34) então salarioB <- 888 + (888 * 12/100) B <- B+1 Escreval("O salário do operário é ",salarioB) fimse Se (pecas = 35) então salarioB <- 888 + (888 * 15/100) B <- B+1 Escreval("O salário do operário é ",salarioB) fimse se (pecas >= 36) então porc <- (pecas - 30) * 5 salarioC <- 888 + (888 * porc/100) C <- C+1 Escreval("O salário do operário é ",salarioC) fimse Se (pecas >= 36) e (Sex = 1) então MC <- MC+1 fimse Se (pecas <= 30) e (sex = 2) então FA <- FA+1 fimse Escreval("Numero da matrícula do operário é ",matri) Escreval("Número de peças fabricadas é ",pecas) Se (sex = 1) então Escreval("O sexo do operário é Masculino ") fimse Se (sex = 2) então escreval("O sexo do operário é Feminino ") fimse Se (salarioA > salarioB) e (salarioA > salarioC) então maior <- salarioA fimse Se (salarioB > salarioA) e (salarioB > salarioC) então maior <- salarioB fimse Se (salarioC > salarioA) e (salarioC > salarioB) então maior <- salarioC fimse Se (salarioA < salarioB) e (salarioA < salarioC) então menor <- salarioA fimse Se (salarioB < salarioA) e (salarioB < salarioC) então menor <- salarioB fimse Se (salarioC < salarioA) e (salarioC < salarioB) então menor <- salarioC fimse total <- salarioA + salarioB + salarioC total2 <- total2 + total ate (matri = 0) Limpatela Escreval ("O total de salários pagos pela fábrica é ",total2:20) Escreval ("O numero de operários na Classe A é ",A:23) Escreval ("O numero de operários na Classe B é ",B:23) Escreval ("O numero de operários na Classe C é ",C:23) Escreval ("O número de operários do sexo masculino na classe C é ",MC:5) Escreval ("O número de operários Do sexo feminino na classe A é ",FA:6) Escreval ("O Maior salário é ",maior:43) Se (menor = maior) então Escreval ("O Menor salário é igual ao maior ") senao Escreval ("o Menor salário é ",menor:41) fimse Fimalgoritmo
  11. @Simon ViegasEstou com dúvida de como linko o resultado do "escolha caso" no resultado do salario do operário, segue o código. algoritmo "aa" Var A,B,C,sex,matri,pecas,porc,total,totalOP,MC,FA,maior,menor: inteiro nome : caracter salarioA, salarioB, salarioC : real Inicio repita escreval("Digite o nome do operário : ") leia(nome) escreval("Digite o número da matricula do operário : ") leia(matri) se (matri = 0) ENTÃO interrompa fimse Escreval("Digite o número de peças feitas pelo operário : ") leia(pecas) Escreval("Digite o sexo do operário, 1 para masc e 2 para fem : ") leia(sex) Escolha pecas caso <= 30 salarioA <- 888 Se (sex = "2") ENTÃO FA <- FA+1 fimse A <- A+1 caso = 31 salarioB <- 888 + (888 * 3/100) B <- B+1 caso = 32 salarioB <- 888 + (888 * 6/100) B <- B+1 caso = 33 salarioB <- 888 + (888 * 9/100) B <- B+1 caso = 34 salarioB <- 888 + (888 * 12/100) B <- B+1 caso = 35 salarioB <- 888 + (888 * 15/100) B <- B+1 caso >= 36 Se (sex = "1") ENTÃO MC <- MC+1 fimse C <- C+1 fimescolha porc <- (pecas - 30) * 5 salarioC <- 888 + (888 * porc/100) total <- salarioA + salarioB + salarioC totalOP <- A + B + C Escreval("Numero da matrícula do operário é ",matri) Escreval("Número de peças fabricadas é ",pecas) Se (sex = 1) ENTÃO Escreval("O sexo do operário é Masculino ") fimse Se (sex = 2) ENTÃO escreval("O sexo do operário é Feminino ") fimse Escreval("O Salário final do operário é ") ate (matri = 0) Escreval ("O total de salários pagos pela fábrica é ",total) Escreval ("O número de operários em cada classe é ",totalOP) Escreval ("O número de operários masculinos na classe C é ",MC) Escreval ("O número de operários feminino na classe A é ",FA) fimAlgoritmo adicionado 1 minuto depo
  12. @Simon Viegas Muito obrigado pelas dicas, to começando agora e ainda to meio perdido na indentação, vou começar a indentar conforme você explicou, realmente fica muito melhor. As variáveis realmente estavam erradas, já arrumei a soma, e também o "caso", mais ainda estou meio perdido nas questões que citei acima.
  13. Boa noite, consegui progredir no código, más agora só me faltão 3 coisas parar terminar: 1 - é que não consigo linkar o resultado do "escolha caso" no valor do salário final do operário. 2 - não consigo usar aquele comando para dar espaços iguais no resultado, para criar um resultado mais bonito, alinhado, já tentei usar ele varias vezes e não deu os espaços. 3 - quando no "escolha caso" é inserido o numero 36 o visualg buga, se alguém souber me dizer porque, vou postar uma foto. Var A,B,C,sex,matri,pecas,porc,total,totalOP,MC,FA,maior,menos: inteiro nome : caracter salarioA, salarioB, salarioC : real Inicio repita escreval("Digite o nome do operário : ") leia(nome) escreval("Digite o número da matricula do operário : ") leia(matri) se (matri = 0) então interrompa fimse Escreval("Digite o número de peças feitas pelo operário : ") leia(pecas) Escreval("Digite o sexo do operário, 1 para masc e 2 para fem : ") leia(sex) Escolha pecas caso <= 30 salarioA <- 888 Se (sex = "2") então FA <- +1 fimse A <- A+1 caso = 31 salarioB <- 888 + (888 * 3/100) B <- +1 caso = 32 salarioB <- 888 + (888 * 6/100) B <- +1 caso = 33 salarioB <- 888 + (888 * 9/100) B <- +1 caso = 34 salarioB <- 888 + (888 * 12/100) B <- +1 caso = 35 salarioB <- 888 + (888 * 15/100) B <- +1 caso >= 36 Se (sex = "1") então MC <- +1 fimse C <- +1 porc <- (pecas - 30) * 5 salarioC <- 888 + (888 * porc/100) total <- salarioA + salarioB + salarioC totalOP <- A + B + C fimescolha Escreval("Numero da matrícula do operário é ",matri) Escreval("Número de peças fabricadas é ",pecas) Se (sex = 1) então Escreval("O sexo do operário é Masculino ") fimse Se (sex = 2) então escreval("O sexo do operário é Feminino ") fimse Escreval("O Salário final do operário é ") ate (matri = 0) Escreval ("O total de salários pagos pela fábrica é ",total) Escreval ("O número de operários em cada classe é ",totalOP) Escreval ("O número de operários masculinos na classe C é ",MC) Escreval ("O número de operários feminino na classe A é ",FA)
  14. @devair1010 valeu cara, tinha esquecido de colocar o "<" no algoritmo, mais em relação ao resto, eu também não consegui achar forma nenhuma de fazer isso sem vetores, vou fazer com um numero limitado de operários e vamos ver no que da, valeu pela ajuda.
  15. @DiF desculpe, essa não era a intenção, é que o enunciado do exercício era muito grande, então resolvi postar só a parte aonde estava com duvidas, más vou postar inteiro para ter mais noção do problema. adicionado 0 minutos depois @Simon Viegasé em visualg, vou postar o enunciado e até onde fiz para poderem avaliar melhor. adicionado 17 minutos depois 4) Numa fábrica, trabalham homens e mulheres divididos em 3 classes: A - os que fizeram até 30 peças no mês B - os que fizeram de 31 a 35 peças no mês C - os que fizeram mais de 35 peças no mês Os operários de classe A devem receber um salário-base (R$ 888,00). Os operários de classe B devem receber um salário-base (R$ 888,00), mais 3% do salário-base para cada peça acima das 30 iniciais. Os operários de classe C devem receber um salário-base (R$ 888,00), mais 5% do salário-base para cada peça acima das 30 iniciais Escreva um algoritmo que leia os dados de um número desconhecido de operários, e calcule e exiba na tela o valor do salário final recebido no final do mês para cada operário. Os dados de um operário são: · número de matrícula do operário · número de peças fabricadas pelo operário no mês · sexo do operário (1 para sexo masculino, 2 para sexo feminino) O indicador de fim de dados (flag) é um “operário” com número de matrícula igual a zero. O algoritmo deve calcular e exibir também : · o total dos salários pagos pela fábrica; · o número de operários em cada uma das três classes (A, B e C); · o número de operários de sexo masculino na classe C; · o número de operários de sexo feminino na classe A ; · o maior e o menor salário pago com o nome, o sexo e a classe desses operários. (Em caso de empate, exiba a informação de apenas um destes operários. Não utilize vetores para armazenar informações) Estou totalmente perdido, faz muito tempo que estou quebrando a cabeça e não consigo resolver, o enunciado pede que o código leia um numero desconhecido de operários, então ficaria a critério do usuário o numero de operários, depois calcular e exibir o valor do salário de todos na tela, não sei como acumular vários valores sendo que toda vez que adicionar um novo operário a variável iria se atualizar e não acumularia todos os valores. Outro problema é que acima das 35 peças o operário iria ganhar 5% a mais do salário base, e não sei como linkar um numero que será variado de peças para adicionar 5% a cada peça feita. Queria a ajuda de vocês se possível, más não para fazer o exercício para mim e sim para dar um luz nessas partes citadas acima, a partir dessa luz eu vou me virando, abaixo segue até onde consegui desenvolver. A,B,C,sex,matri,peças,salarioA,salarioB,salarioC : inteiro nome : caracter Inicio repita escreval("Digite o nome do operário : ") leia(nome) escreval("Digite o número da matricula do operário : ") leia(matri) Escreval("Digite o número de peças feitas pelo operário : ") leia(peças) Escreval("Digite o sexo do operário, 1 para masc e 2 para fem : ") leia(sex) Escolha (peças) Se (peças <= 30) então A <- A+1 fimse Se (peças >= 31) ou (peças <= 35) então B <- B+1 fimse Se (peças >= 36) então C <- C+1 salarioA <- 880 se (peças = 31) então salarioB <- 880 + (880 * 3/100) fimse se (peças = 32) então salarioB <- 880 + (880 * 6/100) fimse se (peças = 33) então salarioB <- 880 + (880 * 9/100) fimse se (peças = 34) então salarioB <- 880 + (880 * 12/100) fimse se (peças = 35) então salarioB <- 880 + (880 * 15/100) fimse

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×