×
Ir ao conteúdo
  • Cadastre-se

saulogoiana

Membro Júnior
  • Posts

    19
  • Cadastrado em

  • Última visita

Tudo que saulogoiana postou

  1. Olá! Estou com a seguinte dúvida... Estou passando para a View "Create" um objeto do tipo SalesRecordFormView e nele contém uma List com todos os Sellers (Vendedores) do meu banco de dados. Para fazer esta Sale (Venda) preciso que o input do Seller seja o nome de um vendedor que está na minha List. Tem como mostrar abaixo do (ou no próprio campo) input o nome do vendedor, que está na List, enquanto eu digito? Ou seja, ele pesquisa o nome na List de acordo com o que eu digito. @model SalesWEBMvc.Models.ViewModel.SalesRecordFormView @{ ViewData["Title"] = "Create"; } <h2>Create</h2> <hr /> <div class="row"> <div class="col-md-4"> <form asp-action="Create"> <div asp-validation-summary="All" class="text-danger"></div> <div class="form-group"> <label asp-for="SalesRecord.Amount" class="control-label"></label> <input asp-for="SalesRecord.Amount" class="form-control" /> </div> <div class="form-group"> <label asp-for="SalesRecord.Date" class="control-label"></label> <input asp-for="SalesRecord.Date" class="form-control" /> </div> <div class="form-group"> <label asp-for="SalesRecord.Status" class="control-label"></label> <select asp-for="SalesRecord.Status" asp-items="Html.GetEnumSelectList<SalesWEBMvc.Models.Enums.SaleStatus>()" class="form-control"></select> </div> <div class="form-group"> <label asp-for="SalesRecord.Seller" class="control-label"></label> <input asp-for="SalesRecord.Seller" /> </div> <div class="form-group"> <input type="submit" value="Create" class="btn-default" /> </div> </form> </div> </div>
  2. Olá!! Meu código está compilando normalmente mas quando executo o programinha "apresenta problemas". Se puder me ajudar agradeço. EDIT: Vou colocar também a função de inserção na Arvore Binaria. Ao inserir deveria apontar para o nó pai mas isso parece não acontecer. void inserir_recursivo(int val,T *raiz, T pai){ if(*raiz == NULL){//Testar se o valor para onde o ponteiro está apontando é nulo printf("\n\n --> %d",val); T tmp = (T) malloc(sizeof(NODE)); inicia_no(&tmp,val); tmp->pai = pai; *raiz = tmp; printf("\nINSERIDO COM SUCESSO!\n"); printf("end: %x | pai: %x\n",&tmp,tmp->pai); }else{ if(val < (*raiz)->valor)//Testar se o conteúdo valor no endereço de raiz é maior que o a ser inserido inserir_recursivo(val, &((*raiz)->esq),*raiz);//Recursividade passando o endereço no CONTEÚDO ENDEREÇO do nó à esquerda else if(val == (*raiz)->valor){ printf("\nValor ja existente!\n"); return; }else inserir_recursivo(val, &((*raiz)->dir),*raiz);//Recursividade passando o endereço no CONTEÚDO ENDEREÇO do nó à direita } return; } struct NODE { int valor; struct NODE *dir; struct NODE *esq; struct NODE *pai; }; typedef NODE *T; void pre_ordem(T r){ if(r == NULL) return; else{ T tmp = r; while(tmp!=NULL){ printf("\n%d",tmp->valor); tmp = tmp->esq; if((tmp==NULL) && (tmp->pai !=NULL)){ T tmp2 = tmp->pai; if(tmp2){ if(tmp2->dir!=NULL){ tmp = tmp2->dir; }else return; } } } return; } }
  3. Olá companheiros! O problema do meu código é que não estou sabendo como tratar os ponteiros, na última linha parece que a variável tmp1 não está "caminhando" para o endereço à direita fazendo com que fique infinitamente no laço while. Meu resultado final deve ser uma árvore balanceada usando o algoritmo DSW. struct NODE { int valor; struct NODE *dir; struct NODE *esq; }; typedef NODE *T; void espinhadorsal(T *raiz){ T *tmp1,*tmp2; tmp2 = tmp1 = raiz; while(tmp1!=NULL){ if((*tmp1)->esq != NULL){ tmp2 = tmp1; (*tmp1) = (*tmp1)->esq; if((*tmp1)->esq!=NULL){ (*tmp1)->esq->dir = (*tmp1)->dir;//1 (*tmp2)->esq = (*tmp1)->dir;//2 } (*tmp1)->dir = *tmp2;//3 raiz = tmp1;//4 tmp1 = raiz; } else{ (*tmp1)=(*tmp1)->dir; } } return; }
  4. Obrigado pela resposta irmão mas eu acabei usando a igualdade trigonometrica onde sen^2(x) = (1-cos(2x))/2
  5. Boa tarde, pessoal! Estou com uma duvida boba, preciso calcular sen^2(x) em python mas não sei a sintaxe para sen^2. Estou usando a OCTAVE GNU. Obrigado!
  6. Olá colegas! Estou com problemas ao cadastrar um funcionário com o código seguinte. O salário não está sendo armazenado corretamente.
  7. Olá Fórum! Estou com um exercício que pede para fazer duas funções recursivas, uma para calculo de fatorial e outra para apresentar os divisores de um número inteiro. A primeira função recursiva eu consegui, a segunda não estou conseguindo desenvolver; #include<stdio.h> int fatorial(int n){ if(n==0){ return 1; }else{ return n*fatorial(n-1); } } void divisores(int n){ int i,r; divisores(n-1); r=n%n-1; if(n==0){ return 0; }else{ printf("%i",r); } } main(){ int x; x=fatorial(4); printf("%i\n",x); divisores(10); system("pause"); return 0; } Por favor me ajude!
  8. @isrnick Muito Obrigado! O problema da leitura do sexo foi resolvido. Eu adoraria saber como eu posso corrigir minha função para procurar um nome no vetor.
  9. Fiz as alterações no código e continuou o problema na hora de ler o sexo.
  10. Olá Fórum! Estou com um problema num algoritmo usando funções para armazenar, imprimir e pesquisar dados de alunos em um vetor. Parece que está havendo conflito para armazenar sexo e nome de um índice do tipo aluno, pois quando eu retiro a opção de armazenar o sexo ele executa tranquilamente. O código está no spoiler. Obrigado por visualizar, se possível me ajude!
  11. Tentei fazer um algoritmo usando funções para o problema, mas está lendo incorretamente as matrizes. #include<stdio.h> #define MAX 10 void setMatriz(int V[MAX][MAX],int maxI,int maxJ,char M){ int i,j; for(i=0;i<maxI;i++){ for(j=0;j<maxJ;j++){ printf("Digite um valor para a posicao %c(%d,%d): ",M,i+1,j+1); scanf("%i",&V[i][j]); } } } void getMatriz(int V[MAX][MAX],int Mi,int Mj,char M){ int i,j; printf("------ %c ------\n",M); for(i=0;i<Mi;i++){ for(j=0;j<Mj;j++){ printf("[%i]\t",V[i][j]); } printf("\n"); } } main(){ int A[5][4],B[5][4],C[5][4]; int i,j; setMatriz(A,5,4,'A'); printf("\n"); setMatriz(B,5,4,'B'); printf("\n"); getMatriz(A,5,4,'A'); printf("\n"); getMatriz(B,5,4,'B'); printf("\n"); for(i=0;i<5;i++){ for(j=0;j<4;j++){ C[i][j]=A[i][j]-B[i][j]; } } getMatriz(C,5,4,'C'); getch (); return 0; } Sabe por que? valeu! consegui resolver o exercício, corrigindo o algoritmo anterior com sua ajuda.
  12. Olá Colegas! Estou com um exercício simples, mas o algoritmo está dando um erro que não compreendo. Minha professora não consegue me ajudar. Exercício: Ler duas matrizes A e B com 20 elementos cada, a partir da subtração dos correspondentes índices de A com os de B criar uma matriz C contendo os resultados. Mostrar a matriz C. #include<stdio.h> #include<stdlib.h> main(){ int i,j; int A[5][4],B[5][4],C[5][4]; for(i=1;i<=5;i++){ for(j=1;j<=4;j++){ printf("Digite um valor para a posicao A(%d,%d): ",i,j); scanf("%i",&A[i][j]); } } printf("\n"); for(i=1;i<=5;i++){ for(j=1;j<=4;j++){ printf("Digite um valor para a posicao B(%d,%d): ",i,j); scanf("%i",&B[i][j]); } } printf("\n"); printf("\nMATRIZ C\n"); for(i=1;i<=5;i++){ for(j=1;j<=4;j++){ C[i][j]=A[i][j]-B[i][j]; printf("[ %i ]\t",C[i][j]); } printf("\n"); } getch (); return 0; } O problema é que quando eu executo o algoritmo ele lê os elementos da matriz A até a posição A[5][2] e já pula para a leitura da matriz B. Obrigado por visualizar, se possível me ajude!
  13. Olá! Estou com uma atividade para resolver, nela é pedido o seguinte: ---> Implementar uma multiplicação entre duas matrizes, pedir para o usuário digitar o numero de linhas e colunas das duas, no final apresentar o resultado. A entrada dos valores nas matrizes deve ser feita de forma automática ( função rand() ). A minha dúvida é a seguinte: Eu não sei como o usuário poderá escolher o número de linhas e colunas da matriz.
  14. @Simon Viegas MUITO OBRIGADO!! agora tudo fez sentido, consegui compreender como trabalhar com este tipo de função. Feliz Natal e Ano novo p você parceiro!
  15. @Simon Viegas Acho que não estou conseguindo fazer a variável percorrer o vetor, não tenho ideia de como colocar isso numa função. Porque eu imagino ter de criar um vetor genérico na função, para quando for usar a função eu use o verdadeiro vetor no lugar desse genérico.
  16. @Simon Viegas Tentei muito fazer a função mas acho que ainda não está correta. Var vogal:vetor [1..5] de caracter consoante:vetor [1..21] de caracter i,j,k:inteiro l:caracter funcao fvogal (x:inteiro): logico var t:inteiro inicio para t de 1 ate 26 faca vogal[t] consoante[t] se (x = vogal[t]) então retorne verdadeiro senao se (x = consoante[t]) então retorne falso fimse fimse fimpara fimfuncao Inicio //Armazenamento nos devidos vetores. j <- 0 k <- 97 para i de 1 ate 26 faca asc(k) se (k = 97) então vogal[1] <- carac(k) senao se (k = 101) então vogal[2] <- carac(k) senao se (k = 105) então vogal[3] <- carac(k) senao se (k = 111) então vogal[4] <- carac(k) senao se (k = 117) então vogal[5] <- carac(k) senao j <- j + 1 consoante[j] <- carac(k) fimse fimse fimse fimse fimse k <- k + 1 fimpara escreva("Digite uma letra:") leia(l) escreval("") se ((fvogal (l) = verdadeiro) então escreva("A letra é uma Vogal.") senao se ((fvogal (l) = falso) então escreva("A letra é uma Consoante.") senao escreva("Não é uma letra.") fimse fimse Fimalgoritmo
  17. @Simon Viegas Pesquisei sobre função. Fiz outros exercícios usando funções(soma, subtração, multiplicação...), mas não estou conseguindo fazer a função que retorne o valor logico analisando os elementos dos vetores.
  18. @Simon Viegas , Muito Obrigado pela atenção. Eu consegui armazenar os caracteres nos devidos vetores. Porém estão armazenados em maiúsculo, se tiver que corrigir isto eu dou um jeito. Var vogal:vetor [1..5] de caracter consoante:vetor [1..21] de caracter i,j,k:inteiro Inicio //Armazenamento nos devidos vetores. j <- 0 k <- 65 para i de 1 ate 26 faca asc(k) se (k = 65) então vogal[1] <- carac(k) senao se (k = 69) então vogal[2] <- carac(k) senao se (k = 73) então vogal[3] <- carac(k) senao se (k = 79) então vogal[4] <- carac(k) senao se (k = 85) então vogal[5] <- carac(k) senao j <- j + 1 consoante[j] <- carac(k) fimse fimse fimse fimse fimse k <- k + 1 fimpara Fimalgoritmo
  19. Olá pessoal, meu professor me passou esta tarefa e não estou conseguindo resolver, se alguém me ajudar agradeço. Escreva um algoritmo em pseudocódigo que armazene as letras vogais em um vetor chamado vogal, as consoantes em um vetor chamado consoante. Em seguida crie duas funções do tipo lógico (as quais vão percorrer os vetores e comparar com a letra digitada, retornando V ou F) para saber se a letra é vogal ou consoante. Ao final deverá ser impresso: vogal, consoante ou não é uma letra (dependendo da letra digitada pelo usuário). Eu fiz um pouco mas não estou sabendo como armazenar as vogais e as consoantes nos seu devido vetor. Estou travado no algoritmo Algoritmo "VOGAL_CONSOANTE" Var vogal:vetor [1..5] de caracter consoante:vetor [1..21] de caracter i:inteiro funcao letra(x:inteiro):logico var l:caractere inicio escolha l se fimescolha se fimse fimfuncao Inicio Fimalgoritmo

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas comunidades sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

Ebook grátis: Aprenda a ler resistores e capacitores!

EBOOK GRÁTIS!

CLIQUE AQUI E BAIXE AGORA MESMO!