Ir ao conteúdo
  • Cadastre-se

Cash999

Membros Juniores
  • Total de itens

    1
  • Registro em

  • Última visita

  • Qualificações

    N/D
  1. Dada uma matriz real A3x3, verificar e mostrar se existem elementos repetidos em A. (fiz o código mas o professor disse que o certo é mostra na tela no máximo 4 valores repetidos e disse que a melhor forma é armazena num vetor. ) ps: primeira postagem. O QUE CONSEGUIR FAZER ATÉ O MOMENTO FOI ISSO programa { //variavel global inteiro matriz[3][3] funcao logico repetiu(inteiro n, inteiro lin, inteiro col){ para(inteiro l =0; l < 3; l++){ para(inteiro c = 0;c < 3; c++){ se(nao(l == lin e c == col)){ se(matriz[l][c] == n){ retorne verdadeiro } } } } retorne falso } funcao inicio(){ //receber a matriz para(inteiro l =0; l < 3; l++){ para(inteiro c = 0;c < 3; c++){ leia(matriz[l][c]) } } para(inteiro l =0; l < 3; l++){ para(inteiro c = 0;c < 3; c++){ se(repetiu(matriz[l][c], l, c)) escreva(matriz[l][c], " - ") } } } }

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×