Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.

PeroVaz

Membros Juniores
  • Total de itens

    2
  • Registro em

  • Última visita

  • Qualificações

    N/D
  1. @Simon Viegas Agradeço, mas após de longas 3 horas tentando resolver eu consegui.
  2. Galera, alguém pode rodar esse programa no Visualg 3.0 e me ajudar a resolver esse erro do qual não estou entendendo? É um trabalho de faculdade, disciplina Algoritmos II. PS: ainda não terminei o programa. Algoritmo "APS" //resgistro do campo aluno tipo aluno = registro identificador:inteiro nome:caractere idade:caractere sexo:caractere fimregistro //variaveis globais var pessoa: vetor[1..5] de aluno i:inteiro valordigitado:inteiro opcao:inteiro aux_pes:inteiro resp:inteiro //FUNÇÃO PESQUISA SEQUENCIAL SIMPLES funcao func_pes(x:inteiro):inteiro var resposta,j:inteiro inicio para j de 1 ate 5 faca se(pessoa[j].identificador = x) então resposta <- 1 senao resposta <- 0 fimse retorne resposta fimfuncao //INICIO DO PROGRAMA inicio repita escreval("UNICARIOCA - BANCO DE DADOS") escreval escreval("[1] - ADICIONAR") escreval("[2] - PESQUISAR") escreval("[3] - ORDENAR") escreval("[4] - EXIBIR") escreval("[0] - SAIR") escreval escreva("Opção: ") leia(valordigitado) escolha valordigitado //ADICIONAR USUARIO caso 1 repita i<-i+1 Escreval("UNICARIOCA - BANCO DE DADOS") escreval("ADICIONAR USUARIO") escreval escreva("Digite seu identificador: ") leia(pessoa.identificador) escreva("Digite aqui seu nome: ") leia(pessoa.nome) escreva("Digite aqui sua idade: ") leia(pessoa.idade) escreva("Digite aqui seu sexo: ") leia(pessoa.sexo) escreval escreval("PARABÉNS,USUARIO CADASTRADO!") escreval escreval("[1] - Para continuar adicionando") escreval("[2] - Para voltar ao menu usuario") leia(opcao) limpatela ate opcao = 2 limpatela caso 2 repita escreval("Digite aqui o identificador que deseja pesquisar: ") leia(resp) aux_pes <- func_pes(resp) se aux_pes = 1 então escreva("Usuario já existe") senao escreva("Usario não existe") fimse escreval escreval("[1] - Para continuar pesquisando") escreval("[2] - Para voltar ao menu usuario") leia(opcao) limpatela ate opcao = 2 fimescolha ate valordigitado = 0 fimalgoritmo

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×