Ir ao conteúdo
  • Cadastre-se

Noob3304

Membros Juniores
  • Total de itens

    12
  • Registro em

  • Última visita

  • Qualificações

    N/D
  1. como funciona um site com livestream?Ex:youtube,Twitch. Tipo como eles programaram,que linguagem,etc
  2. Tentei fazer isso de 2 formas diferentes e está dando erro nos 2, segue os 2 modos que estou colocando: Algoritmo "Refazendo codigo com matriz" Var matriz: vetor [0..11,0..3] de real inicio para 0 de 0 ate 3 faca // Matematica: Pede a nota em todos os 4 bimestre e armazena escreval("Digite sua nota do",numBimestre,"bimestre em matematica:") leia(Notas[0,0]) fimPara fimalgoritmo Algoritmo "Refazendo codigo com matriz" Var matriz: vetor [0..11,0..3] de real inicio para matriz de 0 ate 3 faca // Matematica: Pede a nota em todos os 4 bimestre e armazena escreval("Digite sua nota do",numBimestre,"bimestre em matematica:") leia(Notas[0,0]) fimPara fimalgoritmo
  3. Ok , irei modifica-lo. adicionado 26 minutos depois Algoritmo "Codigo de notas sem verificação de intervalo" Var Matematica : vetor [0..3] de real Portugues : vetor [0..3] de real Filosofia : vetor [0..3] de real Geografia : vetor [0..3] de real Sociologia : vetor [0..3] de real Educacao_Fisica : vetor [0..3] de real Fisica : vetor [0..3] de real Biologia : vetor [0..3] de real Religiao : vetor [0..3] de real Quimica : vetor [0..3] de real inglês: vetor [0..3] de real Literatura : vetor [0..3] de real Matematica_soma: real Portugues_soma: real Filosofia_soma: real Geografia_soma: real Sociologia_soma: real Educacao_fisica_soma: real Fisica_soma: real Biologia_soma: real Religiao_soma: real Quimica_soma: real Ingles_soma: real Literatura_soma: real Inicio // Matematica: Pede a nota em todos os 4 bimestre e armazena escreval ("Digite sua nota do 1 bimestre em matematica:") leia (matematica[0]) escreval ("Digite sua nota do 2 bimestre em matematica:") leia (matematica[1]) escreval ("Digite sua nota do 3 bimestre em matematica:") leia (matematica[2]) escreval ("Digite sua nota do 4 bimestre em matematica:") leia (matematica[3]) //Portugues: Pede a nota em todos os 4 bimestre e armazena escreval ("Digite sua nota do 1 bimestre em portugues:") leia (portugues[0]) escreval ("Digite sua nota do 2 bimestre em portugues:") leia (portugues[1]) escreval ("Digite sua nota do 3 bimestre em portugues:") leia (portugues[2]) escreval ("Digite sua nota do 4 bimestre em portugues:") leia (portugues[3]) //Filosofia: Pede a nota em todos os 4 bimestre e armazena escreval ("Digite sua nota do 1 bimestre em Filosofia:") leia (Filosofia[0]) escreval ("Digite sua nota do 2 bimestre em Filosofia:") leia (Filosofia[1]) escreval ("Digite sua nota do 3 bimestre em Filosofia:") leia (Filosofia[2]) escreval ("Digite sua nota do 4 bimestre em Filosofia:") leia (Filosofia[3]) //Geografia: Pede a nota em todos os 4 bimestre e armazena escreval ("Digite sua nota do 1 bimestre em Geografia:") leia (Geografia[0]) escreval ("Digite sua nota do 2 bimestre em Geografia:") leia (Geografia[1]) escreval ("Digite sua nota do 3 bimestre em Geografia:") leia (Geografia[2]) escreval ("Digite sua nota do 4 bimestre em Geografia:") leia (Geografia[3]) //Sociologia: Pede a nota em todos os 4 bimestre e armazena escreval ("Digite sua nota do 1 bimestre em Sociologia:") leia (Sociologia[0]) escreval ("Digite sua nota do 2 bimestre em Sociologia:") leia (Sociologia[1]) escreval ("Digite sua nota do 3 bimestre em Sociologia:") leia (Sociologia[2]) escreval ("Digite sua nota do 4 bimestre em Sociologia:") leia (Sociologia[3]) //Educacao_Fisica: Pede a nota em todos os 4 bimestre e armazena escreval ("Digite sua nota do 1 bimestre em Educacao_Fisica:") leia (Educacao_Fisica[0]) escreval ("Digite sua nota do 2 bimestre em Educacao_Fisica:") leia (Educacao_Fisica[1]) escreval ("Digite sua nota do 3 bimestre em Educacao_Fisica:") leia (Educacao_Fisica[2]) escreval ("Digite sua nota do 4 bimestre em Educacao_Fisica:") leia (Educacao_Fisica[3]) //Fisica: Pede a nota em todos os 4 bimestre e armazena escreval ("Digite sua nota do 1 bimestre em Fisica:") leia (Fisica[0]) escreval ("Digite sua nota do 2 bimestre em Fisica:") leia (Fisica[1]) escreval ("Digite sua nota do 3 bimestre em Fisica:") leia (Fisica[2]) escreval ("Digite sua nota do 4 bimestre em Fisica:") leia (Fisica[3]) //Religiao: Pede a nota em todos os 4 bimestre e armazena escreval ("Digite sua nota do 1 bimestre em Biologia:") leia (Biologia[0]) escreval ("Digite sua nota do 2 bimestre em Biologia:") leia (Biologia[1]) escreval ("Digite sua nota do 3 bimestre em Biologia:") leia (Biologia[2]) escreval ("Digite sua nota do 4 bimestre em Biologia:") leia (Biologia[3]) //Religiao: Pede a nota em todos os 4 bimestre e armazena escreval ("Digite sua nota do 1 bimestre em Religiao:") leia (Religiao[0]) escreval ("Digite sua nota do 2 bimestre em Religiao:") leia (Religiao[1]) escreval ("Digite sua nota do 3 bimestre em Religiao:") leia (Religiao[2]) escreval ("Digite sua nota do 4 bimestre em Religiao:") leia (Religiao[3]) //Quimica: Pede a nota em todos os 4 bimestre e armazena escreval ("Digite sua nota do 1 bimestre em Quimica:") leia (Quimica[0]) escreval ("Digite sua nota do 2 bimestre em Quimica:") leia (Quimica[1]) escreval ("Digite sua nota do 3 bimestre em Quimica:") leia (Quimica[2]) escreval ("Digite sua nota do 4 bimestre em Quimica:") leia (Quimica[3]) //inglês: Pede a nota em todos os 4 bimestre e armazena escreval ("Digite sua nota do 1 bimestre em inglês:") leia (inglês[0]) escreval ("Digite sua nota do 2 bimestre em inglês:") leia (inglês[1]) escreval ("Digite sua nota do 3 bimestre em inglês:") leia (inglês[2]) escreval ("Digite sua nota do 4 bimestre em inglês:") leia (inglês[3]) //Literatura: Pede a nota em todos os 4 bimestre e armazena escreval ("Digite sua nota do 1 bimestre em Literatura:") leia (Literatura[0]) escreval ("Digite sua nota do 2 bimestre em Literatura:") leia (Literatura[1]) escreval ("Digite sua nota do 3 bimestre em Literatura:") leia (Literatura[2]) escreval ("Digite sua nota do 4 bimestre em Literatura:") leia (Literatura[3]) //Soma todas as notas dos bimestres de matematica Matematica_soma <- (matematica[0] + matematica[1] + matematica[2] + matematica[3]) //Soma todas as notas dos bimestres de portugues Portugues_soma <- (portugues[0] + portugues[1] + portugues[2] + portugues[3]) //Soma todas as notas dos bimestres de filosofia Filosofia_soma <- (filosofia[0] + filosofia[1] + filosofia[2] + filosofia[3]) //Soma todas as notas dos bimestres de geografia Geografia_soma <- (geografia[0] + geografia[1] + geografia[2] + geografia[3]) //Soma todas as notas dos bimestres de sociologia sociologia_soma <- (sociologia[0] + sociologia[1] + sociologia[2] + sociologia[3]) //Soma todas as notas dos bimestres de educacao fisica educacao_fisica_soma <- (educacao_fisica[0] + educacao_fisica[1] + educacao_fisica[2] + educacao_fisica[3]) //Soma todas as notas dos bimestres de fisica fisica_soma <- (fisica[0] + fisica[1] + fisica[2] + fisica[3]) //Soma todas as notas dos bimestres de biologia biologia_soma <- (biologia[0] + biologia[1] + biologia[2] + biologia[3]) //Soma todas as notas dos bimestres de religiao religiao_soma <- (religiao[0] + religiao[1] + religiao[2] + religiao[3]) //Soma todas as notas dos bimestres de quimica quimica_soma <- (quimica[0] + quimica[1] + quimica[2] + quimica[3]) //Soma todas as notas dos bimestres de inglês ingles_soma <- (inglês[0] + inglês[1] + inglês[2] + inglês[3]) //Soma todas as notas dos bimestres de literatura literatura_soma <- (literatura[0] + literatura[1] + literatura[2] + literatura[3]) se (Matematica_soma e Portugues_soma e Filosofia_soma e Geografia_soma e Sociologia_soma e Educacao_fisica_soma e Fisica_soma e Biologia_soma e Religiao_soma e Quimica_soma e Ingles_soma e Literatura_soma >= 24) então escreval ("Você foi aprovado") senao escreval ("Você foi reprovado") fimse Fimalgoritmo
  4. Pera aí , acabei de ver que me equivoquei, já mando outra mensagem.
  5. Lembro que tu tinhas falado isso, só que tipo, o código eu mandei já no txt e esse enunciado que não entendi...
  6. Ótima ideia , tu poderias dar um exemplo de variável que controla as posições, que não tenho nem ideia como usar um laço de repetição nisso
  7. Realmente não precisava estar com variáveis bidimensionais, como estou aprendendo, queria utilizar, mais não foi uma boa escolha, pois só deu mais trabalho, agora arrumei. Já falando de laço de repetição, eu fiz o código utilizando o ,repita,ate,se, como abaixo: Algoritmo "parte do codigo" Var Matematica : vetor [0..3] de real Inicio repita escreval ("Digite sua nota do primeiro bimeste em matematica:") leia (matematica[0]) se (matematica[0] >=0) e (matematica[0]<= 10) então repita escreval ("Digite sua nota do segundo bimeste em matematica:") leia (matematica[1]) se (matematica[1] >=0) e (matematica[1]<= 10) então repita escreval ("Digite sua nota do terceiro bimeste em matematica:") leia (matematica[2]) se (matematica[2] >=0) e (matematica[2]<= 10) então repita escreval ("Digite sua nota do quarto bimeste em matematica:") leia (matematica[3]) se (matematica[3] >=0) e (matematica[3]<= 10) então senao escreval ("Digite uma nota entre 0 e 10 e tente novamente") fimse ate (matematica[3] >=0) e (matematica[3]<= 10) senao escreval ("Digite uma nota entre 0 e 10 e tente novamente") fimse ate (matematica[2] >=0) e (matematica[2]<= 10) senao escreval ("Digite uma nota entre 0 e 10 e tente novamente") fimse ate (matematica[1] >=0) e (matematica[1]<= 10) senao escreval ("Digite uma nota entre 0 e 10 e tente novamente") fimse ate (matematica[0] >=0) e (matematica[0]<= 10) Fimalgoritmo Tipo, você falou para usar laços de repetição, eu usei eles, teria uma forma mais fácil usando os mesmos?
  8. Está anexado o código, como ele ficou muito grande e se colocasse normal na pagina ia ficar incompreensível , coloquei no formato txt. Código:
  9. INICIO //MATEMATICA: variaveis dos bimestes de matematica escreval ("Digite sua nota do primeiro bimeste em matematica:") leia (matematica[0,0]) escreval ("Digite sua nota do segundo bimeste em matematica:") leia (matematica[0,1]) escreval ("Digite sua nota do terceiro bimeste em matematica:") leia (matematica[0,2]) escreval ("Digite sua nota do quarto bimeste em matematica:") leia (matematica[0,3]) Gostaria que estas notas somente aceitassem entre 0 e 10 caso contrario pedir notas de novo ao usuário notificando-o. update Consegui resolver parcialmente, coloquei vários "se", deu um trabalho enorme , se alguem souber fazer de um modo diferente poste aqui por gentiliza.
  10. Galera eu to começando a programar vendo videos sobre logica da programação , só que fiquei na duvida sobre a diferença entre algoritmo e código, pois uma hora fala código, outra vez, algoritmo para a mesma coisa, ai confunde muito, se alguém puder me esclarecer agradeço.
  11. Estou fazendo um pseudocódigo no Visualg e queria saber como eu peço para ele aceitar somente valores para variavel entre 0 e 10, podendo ser valores com vírgula também, e se o usuário digitar fora deste intervalo, escrever um aviso pedindo numeros dentro do intervalo.

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×