Ir ao conteúdo
  • Cadastre-se

ppeterk

Membros Plenos
  • Total de itens

    67
  • Registro em

  • Última visita

  • Qualificações

    N/D

Reputação

26

Sobre ppeterk

  • Data de Nascimento 14/02/1997 (23 anos)

Informações gerais

  • Cidade e Estado
    Belo Horizonte/MG
  • Sexo
    Masculino
  1. @Muca Costa No caso, meu amigo, seria se o excel não encontrasse o Adobe. Ou seja, seria uma tratativa de erro: "Se não encontrar Adobe, busque o navegador!"
  2. Perfeito. Exatamente como queria. Queria acrescentar 2 situações: 1º: Caso não tenha Adobe Reader, abra pelo navegador. 2º Um campo/célula na própria planilha que a pessoa possa digitar o caminho dos PDF's (as pessoas que receberão os arquivos não sabem mexer na macro).
  3. Tenho uma planilha que contêm uma lista enorme de Números. Cada número faz referência a um arquivo PDF salvo em uma pasta (Exemplo: número 2449. Tem um arquivo em PDF que se chama 2449). Enfim, quero criar uma macro que, ao clicar no número da célula, ele busque o arquivo em PDF na pasta correspondente e ABRA o arquivo. Em anexo, o arquivo excel e a pasta contendo os PDF's. Obs: É serviço de empresa. Gostaria muito da ajuda de vocês! Desde já, agredeço muito! Arquivos.rar
  4. @douglasdasilva2901, sua fórmula é ótima e, realizando alguns ajustes, adaptei da seguinte forma: =PROCV(ESQUERDA(F2;6)&"*?";$A$1:$B$9;2;0) @deciog, sua fórmula é extremamente interessante. Utilizarei muito em outras circunstâncias. No entanto, ela considera a localização do espaço vazio (" ") e não é o que desejo. Agradeço muito. @osvaldomp Assim como utilizei a do Douglas, adaptei a sua para me atender, pois ambas seguem a ideia que eu precisava: =PROCV(ESQUERDA(F2;6)&"*";$A$2:$B$5;2;0) Agradeço a todos. No entanto, como todos contribuíram muito, não sei qual marcar como melhor resposta. rsrs
  5. @deciog, sua fórmula é muito boa, mas ainda não é isso. Na sua fórmula, você considerou que a frase "Marcos Lu" poderia ser completamente encontrada em "Marcos Luis" e, de fato, é verdade, entretanto foi coincidência. Se substituirmos a palavra "Marcos Lu" por "Marcos Lg" você não achará mais o valor. Logo, o que eu pretendo, é utilizar da seguinte forma: =ESQUERDA("Marcos Lg";6) pra procurar em =ESQUERDA("Marcos Luis";6) O resultado seria: Utilize "Marcos" para procurar "Marcos". Talvez eu esteja complicando e explicando mal. Veja o exemplo editado. PROCV-ESQUERDA.xlsx
  6. Pode me explicar a lógica do 2^15? Qual o sentido de substituir o "." por ""? PROCV-ESQUERDA.xlsx
  7. @Patropi, boa noite! Não expliquei muito bem. Peço-lhe desculpas! Note que no meu exemplo os nomes não estão completos "(Marcos Lu." e "Marcos Luis"). O que eu desejo é utilizar a a função pra buscar apenas as palavras em comum da célula (Palavra Marcos) que estão a esquerda. Seria tipo essa tentativa de gambiarra: PROCV(ESQUERDA(F2;6);ESQUERDA(A1:B5;6);2;0) PROCV-ESQUERDA.xlsx
  8. Amigos, boa tarde! Além do ÍNDICE CORRESP, há algum método que eu consiga utilizar a fórmula "ESQUERDA" no "PROCV" para buscar "ESQUERDA" do valor da Matriz Tabela? Obs: Tentei utilizar a função "ESCOLHER" junto ao "PROCV". Notei que não obtive muito sucesso. Exemplo em anexo. PROCV-ESQUERDA.xlsx
  9. Grande amigo, boa tarde! Anexe o arquivo modelo para ajudarmos.
  10. Como você sugeriu, coloquei o valor na célula J10. O código busca o valor na coluna A. Veja se é assim que deseja! LocalizarValor.rar
  11. Meu grande amigo, boa noite! Como deseja que o resultado apareça? Você precisa explicar mais detalhado. A distribuição eletrônica no excel não é simples de escrever como no dia a dia. Lembre-se que o diagrama de Linus distribui o número atômico em seus respectivos subníveis acompanhado de letras... (1s² 2s² 2p^6...). Você quer que apareça as letras? Distribuição toda junta ou separada? Deseja que cada camada seja uma linha (K, L, M...) ou posso colocar tudo numa linha apenas? Enfim, especifique onde e como quer os resultados! Abraços.
  12. Crie as seguintes funções: Function pegadata() pegadata = Date End Function Function pegahora() pegahora = Time() End Function Seguindo o seu modelo, caso um campo esteja preenchido (função SE), chame a função pegadata() ou pegahora(). Enquanto o campo da condição não for mexido/alterado, as datas e as horas permanecerão fixas. Fica mais ou menos assim: pegadata() pegahora() Modelo em anexo. função.rar
  13. Caso deseje usar em UserForm, utilize o seguinte código: UserForm.Image1.Picture = LoadPicture(Worksheets("Planilha1").Cells.Range("A1").Value) UserForm.Image1.PictureSizeMode = fmPictureSizeModeStretch ___________________________________________________________________________________ Para funcionar: - Crie uma propriedade/caixa/objeto de imagem com o nome "Image1". - Você pode colocar esse código pra iniciar junto com o UserForm ou com algum botão. - Note que que o UserForm busca a imagem através de um link que está na celula " A1" da aba "Planilha1". Adapte a seu gosto! Exemplo do link: "C:\Users\marcelo.filho\Desktop\homem.jpg" ___________________________________________________________________________________ Eu utilizo o código associado ao nome da pessoa, ou seja, pra cada nome há uma imagem:
  14. veja o arquivo em anexo! =se(b1<1;a1-(a1*b1);a1-b1) Percentual.xlsx
  15. De acordo com o que eu abri aqui (espero não estar falando bobeira), realmente seu arquivo foi criptografado. Não consigo te ajudar. Torço para que algum amigo do fórum tenha algum conhecimento para solucionar. Tente abrir no Libre, como recomendei! Obs: Você marcou minha resposta como a melhor. Todavia, o tópico ainda não foi resolvido, pois não lhe foi apresentado a solução adequada. Se preferir, desmarque a opção e aguarde alguém lhe proporcionar uma resposta mais eficiente. rsrs

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas comunidades sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

Aprenda a ler resistores e capacitores

EBOOK GRÁTIS!

CLIQUE AQUI E BAIXE AGORA MESMO!