Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
Erickke

Relogio digital no visual G

Recommended Posts

Olá boa tarde!
eu estou com um projeto de fazer um relógio digital na faculdade
só q eu to com dificuldade em colocar o dito cujo em laço:wacko:
por exemplo
quando chegar em 59 segundos
mudar pra 1 minuto
e quando chegar em 59 minutos
mudar pra um hora
e deixa isso num loop eterno
:(
fico mais ou menos assim o começo
---------------------------------------------

se(segundo > 59) entãominuto <- minuto + 1segundo <- 0fimsese(minuto > 59) entãohora <- hora + 1minuto <- 0segundo <- 0fimsese(hora > 23)hora <- 0minuto <- 0segundo <- 0fimse

-----------------------------------------------

se alguem puder dizer que jeito é melhor de fazer
usando o enquanto o repita ou o faça
e como eu posso fazer ou dar um ideia eu agradeço
eu to usando o visualg para fazer esse algortimo
como podem ver sou novo no forum e desde de já agradeço. :)

Editado por dif
usar a tag code

Compartilhar este post


Link para o post
Compartilhar em outros sites
Postado (editado) · Ocultado por DiF, 27 de setembro de 2014 - não de o código pronto e nem mande se virar. se quiser ajudar ajude-o a entender a lógica
Ocultado por DiF, 27 de setembro de 2014 - não de o código pronto e nem mande se virar. se quiser ajudar ajude-o a entender a lógica

var

i,j,k,h:inteiro

inicio

escreval("Insira a hora atual em horas, minutos e segundos")

leia(i,j,k)

enquanto h=0 faca

enquanto i<=23 faca

enquanto j<=59 faca

enquanto k<=59 faca

escreval(i,j,k)

k<-k+1

fimenquanto

se k=60 então

k<-0

fimse

j<-j+1

fimenquanto

i<-i+1

se j=60 então

j<-0

fimse

fimenquanto

se i=24

i<-0

fimse

fimenquanto

// Seção de Comandos

fimalgoritmo

Esse alg vai fazer o relogio, porém o timing você vai ter que se virar.

Editado por Daniolip

Compartilhar este post


Link para o post
Postado · Ocultado por DiF, 27 de setembro de 2014 - Não. ninguém vai ajudar você postando em outros tópicos. Por gentileza crie um para você e poste suas tentativas
Ocultado por DiF, 27 de setembro de 2014 - Não. ninguém vai ajudar você postando em outros tópicos. Por gentileza crie um para você e poste suas tentativas

Alguém me ajuda com esse execício por favor 

obrigado, espero resposta.

Compartilhar este post


Link para o post

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário






Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×