Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.

Simon Viegas

Moderadores
  • Total de itens

    3.416
  • Registro em

  • Última visita

  • Qualificações

    0%

Reputação

1.546

Sobre Simon Viegas

  • Data de Nascimento 22-06-1982 (36 anos)

Informações gerais

  • Cidade e Estado
    Salvador/BA
  • Sexo
    Masculino

Outros

  • Biografia
    Carregando...
  • Ocupação
    Técnico e Analista de Sistemas
  • Interesses
    Tecnologia
  1. @Ayron Matos, sua dúvida é referente a implementação de um algoritmo em alguma linguagem de programação (se sim, qual?), ou é apenas para efetuar o procedimento manualmente mesmo? Sobre: Perceba que apenas postou um cálculo... é interessante que insira comentários explicando do que se trata... No aguardo.
  2. Uma vez já tive problemas para compilar no Dev-C++, um código ficava dando erro de compilação, mesmo sendo um código que funcionava perfeitamente antes... ai reinstalei o programa e voltou a funcionar. A depender faz isso também.
  3. Não sei se é "a melhor", mas é uma boa solução!!! Substituir por " " não é válido, pois a frase final tem que ficar como no exemplo.
  4. Como assim? tente explicar melhor. O leia() é uma estrutura que "ler algo do teclado ou do arquivo e joga na variável". No exemplo do @devair1010, o leia() vai ler do arquivo enquanto existir dados nele, ao terminar, passa a ler do teclado. @Lucas Da Silva Aleixo, sobre: Teria que ver qual o contexto da necessidade.. Para que quer salvar em arquivos? tem como dar um exemplo mais específico? O uso de arquivo no Visualg é muito limitado... não dá para, por exemplo, usar o programa normalmente, e no final usar um arquivo para salvar os dados (pelo menos eu desconheço)... lá, só dá para usar o arquivo no início e de uma vez só. Sugeriria utilizar o Pascal, que é muito mais robusta... é bem próximo do Visualg, só muda que os comandos são em inglês. (obs.: o Visualg é meio que uma tentativa de "traduzir" o Pascal, ou seja, utilizando os comandos em Português para assim deixar "mais amigável", mas a estrutura da linguagem é bem próximo...). Ou parte para o C ou C++... que é mais popular...
  5. Só alguns adendos construtivos para tentar deixar mais claro os conceitos, especialmente para outros possíveis leitores menos experientes: 1# O "+1" não está sendo colocado no randi(), no caso, estará criando "uma expressão", ou seja, recebe um valor aleatório de 0 a N-1, e adiciona 1 a resposta, logo: na verdade seria: "vai resultar em número na faixa 1 a 60", ou seja, o randi() gerará números na faixa de 0 a 59, mas o resultado é que será de 1 a 60. Resumindo: Se fosse perguntado: "nessa linha do código, o randi() está gerando número de que faixa?". A resposta deverá ser de 0 a 59! Agora se a pergunta for: " nessa linha, está gerando números de que faixa no vetor?". Aí sim seria de 1 a 60. 2# @devair1010, não consegui encontrar boas referências sobre esse método Sound of Sorting, se puder passar um link sobre o algoritmo, agradeceria. Mas pelo pouco que achei, acho que seria "apenas" uma forma demonstrar um algoritmo de ordenação qualquer, ou seja, uma representação sonora das etapas ordenação. Tipo, algo como pegar o Insert Sort e a cada troca, ir tocando sons com frequência relacionadas... Em fim... creio que que esse código: Se trataria meio que uma variante algoritmo do Bubble Sort, ou seja, o código é muito parecido, mas é bem diferente em conceito... No Bubble, as trocas são feitas com posições adjacentes... as verificações vão flutuando em uma direção, como uma "bolha que a cada loop vai levando o maior número para o final do vetor". Vejam: Imagem do Wikipedia em inglês. Já esse código usado, apesar do código ser parecido, tem a característica de "a cada loop, deixar uma posição ordenada", ou seja, vai sempre comparando o valor da posição que quer ordenar, com as outras... Obs. 1: é comum achar lugares que chamam esse código de Bubble Sort, mas como citado, não é! Inclusive o próprio Wikipedia cometia esse erro quando tinha código para as linguagens específicas, ou seja, algo como em Java certo, mas em Pascal errado... aí, editaram e deixaram apenas o "pseudo código". Obs. 2: existem variantes do Bubbgle Sort, mas observem que a essência se mantém: a comparação com o adjacente. 3# Um pequeno detalhe: Na verdade, só age no para interno, ou seja, seria algo como "//interrompe o fluxo do para, indo para próximo linha após o respectivo fimPara.", ou seja, só "pula um". O k ficará com o valor do que estava no loop. O que acontece, é que a próxima instrução também é um fimPara... (mas isso é apenas uma coincidência, poderia ter outras instrução dentro do para externo). Que por sua vez será executada, continuando o ciclo do para externo (ou atualiza o y OU finaliza o laço de repetição, caso o y já possua o valor máximo). 4# Em relação as variáveis de controle lá nos para, sugeriria usar x, i e j... seguindo um padrão... Ficando algo como: para i de 1 ate 5 faca para j de i+1 ate 6 faca // para colocar em ordem crescente Ou, o k ficaria lá no primeiro para, e usaria x e y para os para que ficam um dentro do outro. 5# Sobre: Podem substituir por algo assim: escreva(x:2,".") 6# Sobre: para k de 1 ate 6 faca se n[k] < 10 ENTÃO escreva(" ",n[k])// escreve o restante da linha se k<6 ENTÃO escreva(" - ")// imprime um traço entre os números fimse senao escreva(n[k]) se k<6 ENTÃO escreva(" - ") fimse fimse fimpara Poderia ficar com algo assim: para k de 1 ate 6 faca se n[k] < 10 ENTÃO escreva(" ",n[k])// escreve o restante da linha senao escreva(n[k]) fimse se k<6 ENTÃO escreva(" - ") fimse fimpara ou seguindo a mesma lógica: para k de 1 ate 6 faca escreva(n[k]:2) se k<6 ENTÃO escreva(" - ") fimse fimpara *** Por ai vai.
  6. Pronto, tendo o enunciado, fica tudo mais claro. O enunciado basicamente está pedindo para receber uma frase, e exiba uma outra... ai precisa entender quais as diferenças entre um e outra.... basicamente a segunda é "a primeira frase sem algumas sequências de caracteres específicos". RESUMINDO: Você imaginou "deletar caracteres", ok! Mas no seu código, você está "substituindo por outro caractere", o que é diferente. Deletar é uma coisa. Colocar outra no lugar é outra. Daí: - ou você encontra uma forma de deletar os caracteres da frase; - ou imprimir apenas o que pode ser impresso. - ou acha outra solução. Tente imaginar como seria possível deletar os caracteres desejados OU tente imaginar como imprimir os caracteres desejados... (ou tente imaginar outra forma). obs.: a sugestão seria que você imaginasse uma forma de resolver. Você imaginou "deletar", mas implementou "substituir", como já citado, não atende ao que precisa. Tente imaginar outra forma de deletar... e ajudaríamos a implementar o que você pensou. Se dissermos como substituir (ou não imprimir), estaremos responder o desafio por você. Perceba que o desafio fio proposto para você... e você que aceitou desafiá-lo novamente... a minha forma de pensa é que o fórum vai te ajudar a "traduzir o que você imagina em C", e por sua vez, toda a criatividade deve vir de você. No aguardo.
  7. Olá. @Lucas Assunção de Sousa, sobre: As características do programa depende principalmente do enunciado, ou seja, aparentemente você postou a "tua interpretação sobre o que deve ser feito", mas seria interessante também postar "o que literalmente foi pedido". Veja, não adiantaria fazer um código dar uma resposta "correta", mas se a "forma" que foi encontrada a resposta não corresponde ao enunciado... O enunciado pode determinar O QUE quer ser feito, e também o COMO deve ser feito. RESUMINDO: Por favor, posta o enunciado para analisarmos antes. No aguardo.
  8. Sobre: Está jogando a "culpa" pro cara errado... o erro citado não está no repita, mas sim no ESCOLHA/CASO. Vide a sintaxe dessa estrutura... tem algo faltando nela. Ai reanalisa o código, e vai implementando e testando. No aguardo.
  9. Sobre: @Ayron Matos, uma coisa é uma coisa, outra coisa é outra coisa. São 2 universos (escopos) distintos. Aqui nesse tópico, precisaria corrigir e implementar o código para satisfazer o enunciado deste tópico... ou seja, retire essa "impressão da parte da matriz", e implemente o [2] e [3] citado na minha postagem anterior. No aguardo. PS: o outro tópico estou olhando, lá é lá, aqui é aqui...
  10. Vide enunciado: Dividi os requisitos em 3 partes... pelo que eu vi, das 3, você só fez a [1]. Então, executando o seu código, me pareceu que você "apenas" fez "imprimir a parte da matriz que que representa o tal TrianguloOesteLeste", mas isso nem sequer foi solicitado... além do [1], precisa fazer o [2] e [3]. No aguardo.
  11. Olá. @Ayron Matos, você só postou um código... é interessante que insira também comentários, explicando do que se trata... como se é o código final, ou se tem alguma dúvida sobre alguma parte... No aguardo.
  12. Olá @Luis Fillipe. 1# Sobre: Tem algumas formas, uma delas seria em vez de usar um vetor de inteiro, usar um vetor de caractere (literal). Ai armazenaria "--" em vez de 0. Lembrando números também podem ser representados por caracteres... só que em vez de, por exemplo, 14, seria "14".... como o i é do tipo inteiro, poderá converter de inteiro para caractere e jogar no vetor. 2# Então, qual a lógica para posição antiga? se não me engano, é a própria posição do vetor, logo, seria igual a i (ou a variável que está representando a posição). Se for seguir a sugestão 1#, obviamente teria que converter também de inteiro para caractere. **** No aguardo.
  13. Justamente. Teste e nos diga você. Tente fazer a conta no papel. Por exemplo, Maria trabalhou 40 horas, deve receber 25 por hora trabalhada e tem 3 filhos, qual seria o salário dela? após, faça o teste no programa e ver se as respostas correspondem. Veja, primeiro você tem que saber fazer a conta... o Visualg é apenas uma ferramenta para automatizar o processo, ou seja, será apenas uma tradução para linguagem de máquina daquilo que você entendeu. ADENDO: Então, como nós colaboradores já estamos mais treinados, já identificamos o que pode está errado, mas a proposta é que você que nos diga o que você precisa, entende? Comece a aprender a aprender com os erros... tente fazer antes no papel, se tiver alguma dúvida sobre o cálculo, pesquise como calcular! Caso ainda não consiga, nos indique em que parte está com dúvidas... No aguardo.
  14. Olá @Lucas Da Silva Aleixo. Sobre: Teste os códigos e veja se estão correspondendo ao esperado.. Se sim, tende a está correto, senão, certamente não estarão corretos. Caso tenha dúvidas sobre alguma parte, favor relatar onde. Veja, a proposta é que você verifique o que está errado e procure ajuda sobre a parte específica... No aguardo.
  15. Complementado: 1# Sobre: Maior e menor são excludentes entre si, logo, usam-se else. Ex.: if (valor[i] < menor) { menor = valor[i]; indice_menor = i; } else if (valor[i] > maior) { maior = valor[i]; indice_maior = i; } 2# Sobre: Outra forma seria: printf ("A fruta %s %.2f tem o maior valor\n", fruta[indice_maior], valor[indice_maior]); printf ("A fruta %s %.2f tem o menor valor\n", fruta[indice_menor], valor[indice_menor]); ***

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×