Ir ao conteúdo
  • Cadastre-se
Luan Martins

Me ajuda ( enquanto )

Recommended Posts

Gente preciso de ajuda fiz um algoritmo mais ele deu "errado"

 

se voce colocar ele no visual G ele funciona, so que ele nao faz o que pede a questão.

 

 

1.      Escrever um algoritmo que leia o nome e o sexo de 56 pessoas e informe o nome e se ela é homem ou mulher. No final informe total de homens e de mulheres.

 

eu pus para ler 3 so pra mim testar, mais deu errado ele vai fazendo ate o infinito e nunca para,

e a contagem no final da a mesma para M e para F mesmo se eu digitrar 5 M e 1 F vai dar 5 M e 5 F

 

algoritmo "Idade_Maior_Menor"// Função :// Autor :// Data : 29/05/2014// Seção de Declarações var   Nome, sexo :caracter   cont, M, F : inteiroinicio// Seção de Comandos    M <- 1   F <- 1   enquanto cont <= 3 faca   escreval ("Informe seu nome")   leia (Nome)   escreval ("Informe seu sexo (M p/ Masculino) e (F p/ Feminino)")   leia (sexo)        caso  "M"              M <- M + 1        caso  "F"              F <- F + 1        outrocaso                 escreval ("Sexo só pode ser M ou F")   fimenquanto   escreval ("Foram inseridos ",M," Homens")   escreval ("Foram inseridos ",F," Mulheres")fimalgoritmo

Compartilhar este post


Link para o post
Compartilhar em outros sites

Faltou colocar o contador, você cria a variável, mas não faz cont<- cont +1.


Fora que você esqueceu de escrever o escolha(sexo), creio q os acumuladores M e F devem começar com 0.   F<- 0 e M<- 0.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×