Ir ao conteúdo
  • Cadastre-se
roontuirvb

Correçao de algoritmo

Recommended Posts

Ooi gente!! Meu professor de Lógica me passou um algoritmo pra fz,  ta feito mas eu to com medo de q esteja errado, então se identificarem algum erro me avisem por favor. valeu galera 

 

varn1, n2, n3, n4, n5, n6, media, recpa, soma  : realaluno : caractereop, recpa1 , recpa2, recpa3 : realinicioescreval ("Digite o nome do aluno :")leia (aluno)escreval ("Digite 1 - verdeiro para obter a media das notas")escreval("Digite 2 - falso para obter a soma das nota")leia (op)se op = 1 entãoescreval ("Digite a nota 1 :")leia (n1)escreval ("Digite a nota 2 :")leia (n2)escreval ("Digite a nota 3 :")leia (n3)    media <- (n1+ n2 + n3) / 3      se media < 6.0 então          escreval ("O aluno precisa  fazer recuperaçao")          escreval ("O aluno foi para recuperaçao? 1 - sim, 99 - nao")          leia (recpa)      fimse           se recpa = 1 então            escreval ("Digite a nota da recuperaçao:")            leia (recpa1)           fimse           se recpa = 99 então            escreval ("O aluno nao compareceu a recuperaçao")            escreval("A media final do aluno é:", media)           fimse                      se recpa1 > media então            escreval ("A media final do aluno é:", recpa1)           fimse           se recpa1 < media então            escreval ("A media final do aluno é:", media)           fimsefimse           se op = 2 entãoescreval ("Digite a nota 1 :")leia (n4)escreval ("Digite a nota 2 :")leia (n5)escreval ("Digite a nota 3 :")leia (n6)    soma <- (n4+ n5+ n6)      se soma < 6.0 então       escreval ("O aluno precisa  fazer recuperaçao")       escreval ("O aluno foi pra recuperaçao? 1 - sim, 99 - nao")       leia (recpa2)      fimse           se recpa2 = 1 então            escreval ("Digite a nota da recuperaçao")            leia (recpa3)           fimse                      se recpa2 = 99 então            escreval ("O aluno nao compareceu a recuperaçao")            escreval ("A media final do aluno é", soma)           fimse                       se recpa3 > soma então            escreval ("A media final do aluno ´é", recpa3)           fimse                      se recpa3 < soma então            escreval ("A media final do aluno é", soma)           fimsefimsefimalgoritmo

Compartilhar este post


Link para o post
Compartilhar em outros sites

Achei legal o fato de você ter indentado o programa, mas gostaria de fazer outra observação, não sei se seu professor ensinou a usar o CASO(caso sim use o CASO junto com o SE, assim seu programa seria mais organizado e seria mais eficiente).   


1- No caso da recuperação: você não colocaria para a pessoa  escolher se o aluno ficou em recuperação ou não(a não ser que a questão peça dessa forma). Ficaria mais interessante se utilizasse um SE e um SENAO no outro ex: 

se(media>5.9)então   escreval("você foi aprovado e sua media e ",media)senão escreval("você foi reprovado e sua media e ",media) 

Obs: Não coloque "SENAO" com "~", porque vai dar erro. 

Caso alguém tenha verificado mais algum erro notifique(m).  

Compartilhar este post


Link para o post
Compartilhar em outros sites

Eu coloquei para o aluno escolher se fuca ou nao de recuperaçao eu so disse q se sua,media for menor q seis ele ira fazer recuperaçao. Foi uma afirmativa e nao uma pergunta. Mas mesmo obrigado por sua ideia

Ops,digitei Eu nao coloquei para o aluno escolher *

Compartilhar este post


Link para o post
Compartilhar em outros sites

O comando para dizer se ele precisa a recpa ou nao, nao é necessario, ele so pediu pra saber se aluno fez ou nao a recpa

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Você poderia postar a questão, porque podemos chegar à soluções mais simples do que a percebemos até agora! 


Mas como você mesmo disse, se não for necessário não coloque! 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Bom eu vou postar a questao quem sabe a solução nao seja mais fácil do q eu pense

Bom gente a questao pra o algoritmo acima é essa Ajude o pessoal da CORES fazendo um algoritmo que determine o resultado da Unidade II de um aluno da disciplina de Linguagem de Programaçao. Um flag (indicador de estado), VERDADEIRO ou FALSO, sera fornecido na entrada para informar se o professor nas 03 avaliaçoes previstas optou pela media ou somatorio das notas, respectivamente. Tambem é fornecido um valor numerico 99 se o aluno nao compareceu a recuperaçao. A media é 6.0.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×