Ir ao conteúdo
  • Cadastre-se

Erro E: dpkg was interrupted, you must manually run 'dpkg --configure -a'


INEM

Posts recomendados

Olá, ao tentar instalar um programa, dá-me um erro sempre que tento, na verdade com qualquer programa que seja, como posso ultrapassar o problema, o exemplo que deixo era a tentar instalar o kopete, Obrigada pelas possíveis ajudas!

carlos@carlos:~/Programas/Kopete-0.12.2.tar.bz2/kopete-0.12.2$ sudo apt-get install checkinstall

Erro:

E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.

A seguir eu escrevi carlos@carlos:~$ dpkg --configure -a

E ele disse isto:

dpkg: a operação pedida necessita de privilégios de superutilizador

Como posso activar estes privilégios?!

Link para o comentário
Compartilhar em outros sites

  • Membro VIP

Cara ,antes de mais nada atualize o sistema. O problema no seu caso é que você não está logando como "root", para realizar isso, digite "sudo su" e depois digite a senha do usuário. É bom que você também rode o comando "sudo apt-get install -f", caso esteja em alguma distribuição derivada do Debian. E , lembre-se de que antes de instalar qualquer programas, primeiro você deve descompactá-lo.

Link para o comentário
Compartilhar em outros sites

  • Membro VIP
Cara ,antes de mais nada atualize o sistema. O problema no seu caso é que você não está logando como "root", para realizar isso, digite "sudo su" e depois digite a senha do usuário. É bom que você também rode o comando "sudo apt-get install -f", caso esteja em alguma distribuição derivada do Debian. E , lembre-se de que antes de instalar qualquer programas, primeiro você deve descompactá-lo.

não igor, não é assim.

primeiro - usando o comando "sudo" antes do outro comando executa o comando seguinte como superusuário, não sendo necessário o "sudo su".

segundo - não é o caso de "sudo apt-get install -f"

terceiro - se ele estiver usando o apt-get para instalar o programa (ou o dpkg) NÃO É NECESSARIO DESCOMPACTAR NADA, descompactar seria apenas no caso de compilar o programa manualmente e este não é o caso dele.

INEM, para resolver o problema basta você fazer o que a propria mensagem de erro sugere:

sudo dpkg --configure -a

e pronto! o problema será resolvido.

Link para o comentário
Compartilhar em outros sites

OK, muito obrigada pelas explicações, consegui resolver o problema e já entro tranquilamente no gestores de pacotes para instalar e desinstalar tudo, tinha realmente um pacote "quebrado" que ficou a meio por isso tava com este problema, mas agora já entendi e consegui com o comando sudo dpkg --configure -a, mas tive de escrever sudo à frente de dpkg --configure -a, pois o linux dizia sempre que não tinha previlegios de superadministrador e eu não sabia qual era o comando para os activar, OK

Agora tenho outro problema, mas vou postar num novo tópico, podem fechar este!

Obrigada e Cumprimentos!

Link para o comentário
Compartilhar em outros sites

Arquivado

Este tópico foi arquivado e está fechado para novas respostas.

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas comunidades sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

 

GRÁTIS: ebook Redes Wi-Fi – 2ª Edição

EBOOK GRÁTIS!

CLIQUE AQUI E BAIXE AGORA MESMO!