Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
ricardokt

Ajuda - Proteus, display 7 seg

Recommended Posts

Olá pessoal,

sou novo aqui

e nao entendo muito bem do Proteus, então vim pedir ajuda

é o seguinte

eu estou montando um projeto no Proteus

mas me ocorreu uma duvida q nao estou conseguindo resolver

o projeto é o seguinte:

http://img237.imageshack.us/img237/7932/imagem2uj.png

eu so coloquei parte do projeto, so a parte q interessa

minha duvida é sobre o display de 7 segmentos

o display de 7 segmentos em si tem 10 pinos

assim como no meu projeto eu uso os 10 pinos

mas no proteus os displays so tem 8 pinos

e gostaria de saber como faço? ja q no projeto tenho q ligar 9 pinos, ja q o pino 3 não é ligado em nada

minha montagem no proteus está assim:

http://img297.imageshack.us/img297/7874/imagem1sw.png

o display é anodo comum

eu nao sei se liguei o pino 5 errado

e nao sei onde liga o pino 8, q vai para o trasistor

quem puder me ajudar eu agradeço

Compartilhar este post


Link para o post
Compartilhar em outros sites

É o seguinte: na vida real, o display tem 7 pinos dos 7 segmentos, um pino do ponto e DOIS pinos de anodo/catodo comum, que são a mesma coisa. No Proteus, falta o ponto e um anodo/catodo. Você não precisa do último, mas para o ponto, utilize um led da mesma cor.

Outra coisa que eu percebi: você colocou aquele triângulo escrito 9VCC: ele não funcionará. Você só pode escrever o valor e o sinal para o Proteus poder entender e fornecer a tensão. Neste caso, mude 9VCC para +9 e nada mais.

Editado por GuiRitter

Compartilhar este post


Link para o post
Compartilhar em outros sites
  • Autor do tópico
  • Obrigado GuiRitter por responder

    mas nao entendi muito bem

    no caso o anodo comum seria o pino 3 e 8 para o display e o pino 5 para o ponto?

    e você falou q eu nao vou precisa do anodo certo? e como q eu faço dai p ligar o transistor?

    e o ponto, dai ligo um led no pino 5 e 6 do PIC?

    grato

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    1ª: Sim.

    2ª: Precisa, mas só de um. Os dois anodos, na vida real, são internamente conectados. Tanto faz qual você use, ou se usará os dois.

    3ª: Igual como está na figura: o emissor vai em qualquer um dos anodos (ou os dois).

    4ª: Pelo que eu vi na figura, o ponto, que no Proteus pode ser um led, vai num resistor de 220, que vai no pino 7 do PIC. Os pinos 5 e 6 vão na base dos transistores.

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
  • Autor do tópico
  • acredito q consegui soluciona o caso do display

    graças a voce hehe

    e terminando de monta o circuito eu vi q o PIC nao possui os pinos 1 e 14

    na qual devem ser interligados por um capacitor de 220nF e ligados a alimentaçao e ao terra

    alguem sabe porque no Proteus nao aparece os pinos 1 e 14?

    sera q sao subentendidos?

    aqui é o circuito praticamente pronto:

    http://img140.imageshack.us/img140/5879/imagem3s.png

    (sei q ta meio bagunçado rs)

    ah e o pino 7do PIC, q era p liga no pino 5 do display, eu liguei no led, e outro pino do led aterrei, acho q ta certo né?

    grato

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    1ª:Os pinos 1 e 14 são da alimentação, que o Proteus alimenta automático. O 1 deve ser ligado no 5V e o 14 no terra.

    2ª: Sim tá certo.

    De nada! Qualquer coisa é só falar.

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Crie uma conta ou entre para comentar

    Você precisar ser um membro para fazer um comentário






    Sobre o Clube do Hardware

    No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

    Direitos autorais

    Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

    ×