Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
Entre para seguir isso  
Guest hudsonf88

[Resolvido] Erro no envio de dados para USB usando interface HID

Recommended Posts

Guest hudsonf88

Bom dia.

Eu estou precisando escrever um programa que comunique com um dispositivo USB utilizando a classe HID. O dispositivo é um PIC18F4550 e o compilador que estou utilizando para desenvolver o software embarcado é o mikroc 8.2.

O dispositivo USB já comunica normalmente pelo HID Terminal do mikroc (envia e recebe dados). No entanto, ao desenvolver um software para comunicar com o dispositivo, dá um erro "Parâmetro incorreto". Estou usando uma biblioteca chamada hidapi (versão 0.7.0 < http://www.signal11.us/oss/hidapi/ >), que é um wrap para as funções da interface HID do Windows (versão XP).

Suspeito que o problema seja no Usage ID, mas não sei qual utilizar. Já tentei usar 0x0 (para o caso de não haver), 0x01 (do exemplo da biblioteca hidapi) e 0x09 (descritor do report de saída, linha 132), mas nada funciona. Segue o arquivo de descritores da USB em anexo. Eu não sei se tem como postar o código aqui, devido à pressa (estou há dias pesquisando esse problema). Favor apenas mudar a extensão, código está indentado (ou identado).

Eu testei usando uma função de leitura no software do lado host e comuniquei com o dispositivo pelo HID Terminal do mikroc. Quando o dispositivo envia dados de volta ao host, o software host conseguiu ler os bytes. O problema mesmo é no envio de dados para o dispositivo.

Obs.: O dispositivo é reconhecido na enumeração e a variável usada no software do PIC é um char para leitura e um char para escrita.

Obrigado desde já.

Compartilhar este post


Link para o post
Compartilhar em outros sites
Guest hudsonf88

Desculpem a demora para sinalizar, mas é que há muito o problema já foi resolvido.

Não foi necessário enviar o ID do report, apenas um 0 (zero) no primeiro byte, por causa da biblioteca.

Funcionou normalmente.

Obrigado àqueles que me deram atenção.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Caso o autor do tópico necessite, o mesmo será reaberto, para isso deverá entrar em contato com a moderação solicitando o desbloqueio.

Compartilhar este post


Link para o post
Compartilhar em outros sites
Visitante
Este tópico está impedido de receber novos posts.
Entre para seguir isso  





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×