×
Ir ao conteúdo
  • Cadastre-se

bibalinda

Membro Júnior
  • Posts

    4
  • Cadastrado em

  • Última visita

Reputação

0
  1. Algoritmo "Restaurante // " Tipo cardapio = Registro codigo : inteiro nome: Caractere quantidade : inteiro valor: Real FimRegistro t_pedido = registro codItem :inteiro qtd :inteiro fimRegistro Var menu: Real lista_prod: vetor[1..10] de cardapio i, itens: inteiro op_menu:vetor [1..3] de Inteiro pedidos :vetor[1..3] de t_pedido Procedimento MenuRestaurante() Inicio Escreval("========================================") Escreval("========{ RESTAURANTE }=======") Escreval("========================================") Escreval("Opção 1 - Inclusão de itens no cardapio ") Escreval("Opção 2 - Registro de pedido ") Escreval("Opção 3 - Resumo do pedido ") Escreval("Opção 4 - Sair ") // verificar se deixa como opcao 4 ou de deixa ou OUTROCASO Escreval("----------------------------------------") FimProcedimento Procedimento MenuRestaurantee() Escreval("========================================") Escreval("========{ RESTAURANTE }=======") Escreval("========================================") Escreval("Opção 2 - Registro de pedido ") Escreval("Opção 3 - Resumo do pedido ") Escreval("Opção 4 - Sair ") // verificar se deixa como opcao 4 ou de deixa ou OUTROCASO Escreval("----------------------------------------") FimProcedimento Inicio Repita MenuRestaurante() Escreval("Qual a sua escolha no restaurante? ") Leia(menu) Se (menu = 1) então Limpatela Para i de 1 ate 1 faca // lembrar de alterar para 10 Escreva("Digite o código do produto : ") Leia(lista_prod[i].codigo) Escreva("Informe o nome do produto: ") Leia(lista_prod[i].nome) Escreva("Informe a quantidade em estoque do produto : ") Leia(lista_prod[i].quantidade) Escreva("Informe o valor [UNITÁRIO] do produto : ") Leia(lista_prod[i].valor) Escreval Escreval("========================================") Escreval FimPara FimSe LimpaTela Escreval("============================================================================================================================") Escreval(" C A R D A P I O R E S T A U R A N T E ") Escreval("============================================================================================================================") Escreval Para i de 1 ate 1 faca // lembrar de alterar para 10 Escreval("|Código do Produto:",lista_prod[i].codigo, "| Nome do Produto: ",lista_prod[i].nome,"| Quantidade em Estoque: ", lista_prod[i].quantidade,"| Valor [UNITÁRIO] do Produto: R$ ",lista_prod[i].valor) Escreval("---------------------------------------------------------------------------------------------------------------------------") FimPara Escreval Escreval Escreval Escreval Escreval MenuRestaurante() Leia(Menu) Se (Menu = 2) então Escreval("============================================") Escreval(" M O N T E S E U P E D I D O ") Escreval("============================================") Para i de 1 ate 3 faca EscrevaL("Item: ", cardapio[i].nome:30, " R$", cardapio[i].valor:1:2) FimPara FimSe
  2. Como faço uma comanda de pedidos no VisualG? Já tenho a tabela de itens no cardápio, mas não estou conseguindo encaixar um vetor para administrar um pedido.
  3. Algoritmo "Sistema de Restaurante" tipo cardapio = Registro nome: Caractere valor: Real fimregistro Var menu: Real cardapio_rest: vetor[1..10] de cardapio i, itens: inteiro op_menu:vetor [1..3] de Inteiro Inicio Repita Escreval("----------------------------------------") Escreval("-------- RESTAURANTE -------") Escreval("----------------------------------------") Escreval("Opção 1 - Inclusão de itens no cardapio ") Escreval("Opção 2 - Registro de pedido ") Escreval("Opção 3 - Resumo do pedido ") Escreval("Opção 4 - Sair ") // verificar se deixa como opcao 4 ou de deixa ou OUTROCASO Escreval("----------------------------------------") Escreval("Qual a sua escolha no restaurante? ") Leia(menu) Escolha(menu) Caso 1 Para i de 1 ate 2 faca // lembrar de alterar para 10 Escreval("informe os itens no cardapio por dia: ") Leia(cardapio_rest[i].nome) Escreva("Informe os valores dos itens do cardapio: ") Leia(cardapio_rest[i].valor) Fimpara Escreval("----------------------------------------") Para i de 1 ate 2 faca Escreval(cardapio_rest[i].nome, cardapio_rest[i].valor) Fimpara Caso 2 para i de 1 ate 3 faca Escreva("Digite até três itens do cardapio ") leia(op_menu[i]) fimpara Escolha op_menu[i] caso 1 pedido_cliente[i] <- cardapio_rest[1].nome valor_pedido[i] <- cardapio_rest[1].valor caso 2 pedido_cliente[i] <- cardapio_rest[2].nome valor_pedido[i] <- cardapio_rest[2].valor caso 3 pedido_cliente[i] <- cardapio_rest[3].nome valor_pedido[i] <- cardapio_rest[3].valor caso 4 pedido_cliente[i] <- cardapio_rest[4].nome valor_pedido[i] <- cardapio_rest[4].valor caso 5 pedido_cliente[i] <- cardapio_rest[5].nome valor_pedido[i] <- cardapio_rest[5].valor caso 6 pedido_cliente[i] <- cardapio_rest[6].nome valor_pedido[i] <- cardapio_rest[6].valor caso 7 pedido_cliente[i] <- cardapio_rest[7].nome valor_pedido[i] <- cardapio_rest[7].valor caso 8 pedido_cliente[i] <- cardapio_rest[8].nome valor_pedido[i] <- cardapio_rest[8].valor caso 9 pedido_cliente[i] <- cardapio_rest[9].nome valor_pedido[i] <- cardapio_rest[9].valor caso 10 pedido_cliente[i] <- cardapio_rest[10].nome valor_pedido[i] <- cardapio_rest[10].valor Escreval("----------------------------------------") caso 3 Escreval Escreval("===========================") EscrevaL("| COMANDA DE PEDIDO |") Escreval("===========================") Escreval("| QTD | ITENS | VALOR |") Escreval("---------------------------") Escreval("|", itens, "| | Valor |") fimescolha Ate menu=4 Fimalgoritmo Não estou conseguindo ligar os pontos... Quando coloco os nomes e valores dos itens, ele não guarda... E a parte do resumo do pedido, como faria? Tem alguma dica?

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas comunidades sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

Como se tornar um desenvolvedor full-stack

EBOOK GRÁTIS!

CLIQUE AQUI E BAIXE AGORA MESMO!