Ir ao conteúdo
  • Cadastre-se

Zithion

Membros Juniores
  • Total de itens

    13
  • Registro em

  • Última visita

  • Qualificações

    N/D
  1. @Kayky Vieira Então, eu tive uma e ela não deu conta de colocar 1080 por faltar memoria no meu pc, TALVEZ por você utilizar ddr4 ele suporte, mas é um tiro no escuro.
  2. Roda, mas não chega a ser full HD. Possivelmente vai rodar em 720p ou fique engasgando se tentar colocar 1080. Configuração do seu pc é otima, mas sua placa não é tão boa.
  3. Não fica estavel, principalmente porque seu processador e placa, não vai conseguir suportar alta qualidade por muito tempo, também o fator de que se não tiver algo para resfriar seu processador e placa, por ter um fps na tamba que você deseja, ao esquentar pode cair seu fps também.
  4. Fiz isto em asp.net <asp:TextBox ID="txtAno" runat="server" CssClass="input-control text" MaxLength="4" Width="100px"></asp:TextBox> <asp:RequiredFieldValidator ID="RequiredFieldValidator1" runat="server" ControlToValidate="txtAno" ErrorMessage="Campo obrigatório" ForeColor="Red" SetFocusOnError="True"></asp:RequiredFieldValidator>
  5. Oi galera bom dia, estou com uma dúvida sobre uma parte do meu código do TCC, poderia dar uma olhadinha? Na parte de Adicionar e Editar usuario,estou usando utilizando a mesma pagina. Porém quero que o sistema identifique quando eu for adicionar ou editar de acordo com o botão que eu clico, para isso eu fiz esse comando. OBS:Aonde esta (???) seria a condição que estou em dúvida sobre como deve ser feita, para assim ele verificar se vou adicionar ou editar um usuario. Para isso eu também criei no banco de dados como chave principal o @USUA_CODIGO da tabela usuarios, aonde ele armazena cada codigo de usuario, que seria pra verificar os já existentes depois! protected void btnSalvar_Click(object sender, EventArgs e) { if (???) { string _sql_inc = "INSERT INTO usuarios" + " (USUA_NOME,USUA_STATUS,USUA_LOGIN,GRUP_CODIGO)" + " VALUES (@USUA_NOME,@USUA_STATUS,@USUA_LOGIN,@GRUP_CODIGO)"; MySqlCommand cmd = new MySqlCommand(_sql_inc, conn); cmd.CommandType = CommandType.Text; cmd.Parameters.AddWithValue("@USUA_LOGIN", txtLogin.Text); cmd.Parameters.AddWithValue("@USUA_NOME", txtNome.Text); cmd.Parameters.AddWithValue("@USUA_STATUS", cboStatus.SelectedValue); cmd.Parameters.AddWithValue("@GRUP_CODIGO", cboGrupos.SelectedValue); } else { string _sql_inc = "UPDATE usuarios SET" + " USUA_NOME = @USUA_NOME, " + " USUA_STATUS = @USUA_STATUS, " + " USUA_LOGIN = @USUA_LOGIN, " + " GRUP_CODIGO = @GRUP_CODIGO " + " WHERE USUA_CODIGO = @USUA_CODIGO "; MySqlCommand cmd = new MySqlCommand(_sql_inc, conn); cmd.CommandType = CommandType.Text; cmd.Parameters.AddWithValue("@USUA_LOGIN", txtLogin.Text); cmd.Parameters.AddWithValue("@USUA_NOME", txtNome.Text); cmd.Parameters.AddWithValue("@USUA_STATUS", cboStatus.SelectedValue); cmd.Parameters.AddWithValue("@GRUP_CODIGO", cboGrupos.SelectedValue); cmd.Parameters.AddWithValue("@USUA_CODIGO", grid.SelectedValue); try { conn.Open(); cmd.ExecuteNonQuery(); MultiView1.ActiveViewIndex = 0; conn.Close(); conn.Dispose(); gvbind(); } catch (Exception ex) { MessageBox1.ShowMessage("ERRO: " + ex.Message); } finally { conn.Close(); conn.Dispose(); } } }
  6. Bom dia galera! Estou com uma dúvida aqui referente a utilização certa do dataReader e como fazer o proximo passo, nessa parte do meu código eu preciso clickar no botão editar que fica ao lado dos usuários cadastrados, ao clicar ele vai me redirecionar para página de cadastro para realizar a edição, porém eu preciso que quando isso ocorra, ele já puxe as informações do usuário. Entre o conn.Open e conn.Close eu preciso realizar um comando pra puxar essas informações, pois já usei select pra ler, agora só falta isso mas não to sabendo como fazer! Se alguem conseguir me ajudar ficaria super grato. Att Vinicius protected void grid_SelectedIndexChanged(object sender, EventArgs e) { string _sql = "SELECT" + " USUA_CODIGO," + " USUA_LOGIN," + " USUA_NOME," + " USUA_STATUS," + " grupos.GRUP_CODIGO" + " FROM" + " usuarios" + " INNER JOIN grupos ON grupos.GRUP_CODIGO = usuarios.GRUP_CODIGO" + " ORDER BY" + " GRUP_CODIGO DESC"; MySqlCommand cmd = new MySqlCommand(_sql, conn); try { conn.Open(); MySqlDataReader reader = cmd.ExecuteReader(); reader.close(); MultiView1.ActiveViewIndex = 1; } catch (MySqlException ex) { MessageBox1.ShowMessage(ex.Message); } finally { conn.Close(); } }
  7. Olá galera estou com uma dificuldade aqui, não consigo resolver esse exercicio por acaso alguém que menje, consegue fazer ou passar alguma dica de como fazer, aqui abaixo deixarei as instruções de como é pedido no exercicio, obrigado. Faça um algoritmo em C que dado um conteúdo de uma fita como o da figura abaixo, este execute as operações como descritas na tabela abaixo (o pseudo algoritmo executa a soma de dois números unários delimitados à direita por 1 e a esquerda por 1): Fita: 1 0 0 0 1 0 0 0 0 1 O conteúdo da fita após a execução deverá ser o seguinte: 1 0 0 0 0 0 0 0 1 1 Obs: A tabela deve ser implementada em uma matriz, sendo que os valores lá colocados são fixos, mudando apenas o conteúdo da fita, sendo esta implementada em um vetor de grande dimensão, tem que usar ponteiro e alocação de memoria. Att Felipe
  8. Oi gente, tudo bem? Queria uma ajuda em adaptar um programa que esta em portugol, para C. To quebrando a cabeça já tem dias, mas não consigo...ainda estou aprendendo a programar em C, ficaria muito feliz pois este é um exercicio para praticar e to mt curioso em saber como seria adapta-lo em C. Obrigado pela atenção. 1. Faça um algoritmo em portugol que execute os seguintes passos: 0. Procura o 1º Dígito “1” 1. Troca 1 ® 0 2. Procura posição de inserção 3. Troca 0 ® 1 4. Escreve marca fim numeral 5. Procura o 2o dígito “0” à esquerda 6. Troca 0 ® 1 7. Avança uma Posição a Direita 8. Se “0” fim 9. Se “1” continua passo 1 Considerações: · Posição de inserção é a posição do último zero mais a Direita · Marca Fim de Numeral é um zero na próxima posição após o último “Um” mais a Direita. Este pseudo-algoritmo executa a cópia de uma dada cadeia binária em uma fita infinita, utilizando um vetor de grande dimensão. O conteúdo da fita é um numeral unário delimitado à esquerda por 0 (zero) e à direita por 00 (duplo zero), como mostrado abaixo. 011111100 Observações: · A posição inicial da cabeça de leitura/gravação é a primeira posição da fita. · Os valores possíveis do conteúdo da fita são 0 e 1. · Os movimentos possíveis são: Direita, Esquerda e Nada. · O estado inicial é 0. Segue abaixo meu programa em portugol. // Função : // Autor : // Data : 07/06/2017 // Seção de Declarações var num:vetor[1..45] de inteiro cont,numero,soma,posi,limite,dobro,linha,mais:inteiro // Inicio de procedimentos Procedimento imprimir() inicio Escreva(" Esta é a ",linha, " linha: ") para cont de 1 ate (limite) faca escreva(num[cont]," " ) fimpara Escreval("") linha<-linha+1 fimprocedimento inicio // Inicio Seção de Comandos cont<-2 Escreval("|---------------------------------------------|") Escreval(" Quantos número 1 tem sua fita? ") Escreval(" Digite um número de 1 a 20: ") leia(numero) se numero>20 então Escreval(" Número maior do que o limite estipulado ") Escreval(" O programa esta sendo finalizado. ") interrompa senao // Processando quantidade número "1" o usuario digito. mais<-2 dobro<-(numero*2) limite<-(numero+2) para cont de 3 ate(limite) faca num[cont]<-1 fimpara se num[cont]=1 então num[cont]<-1 senao num[cont]<-0 fimse Escreval("") posi<-cont limite<-(limite+2) linha<-1 // Escrevendo na tela a formação de digitos e a quantidade de "1" que o usuario digito.") imprimir() // Procurando o primeiro numero 1 e trocando para 0. para cont de 1 ate(limite) faca se num[cont]=1 então soma<-soma+1 se soma=1 então num[cont]<-0 senao num[cont]<-1 fimse fimse fimpara // Imprimindo na tela a modificação imprimir() repita // Inicio da repetição // Procurando o segundo digito "0" a esquerda e substituindo por "1"!! soma<-0 para cont de 3 ate (limite) faca se num[cont]=0 então soma<-soma+1 se soma=3 então num[cont]<-1 senao num[cont]<-0 fimse fimse fimpara //Procurando o ultimo "1" e acrescentando mais o "0" no final //Imprimindo na tela a modificação posi<-cont limite<-(limite+1) imprimir() // Procurando o Segundo "0" a esquerda soma<-0 para cont de (limite) ate 3 passo-1 faca se num[cont]=0 então soma<-soma+1 se soma=3 então num[cont]<-1 senao num[cont]<-0 fimse fimse fimpara //Modificando na tela a modificação! posi<-cont imprimir() //Avança uma posição a direita e verifica //Se "0" sera o fim //Se "1" volt ao repita posi<-posi+mais se num[posi]=0 então interrompa senao num[posi]<-0 imprimir() fimse soma<-0 para cont de 1 ate (limite) faca se num[cont]=1 então soma<-soma+1 fimse fimse fimpara mais<-(mais+1) ate soma=dobro fimalgoritmo

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×