Ir ao conteúdo
  • Cadastre-se
Joao_Bilu

VisualG RESOLVIDO Problema no comando leia do VisuAlg

Posts recomendados

Problema com a Entrada de um valor

Pessoal. criei um programa de contagem com base nas aulas do Curso em Video. O algoritmo funciona normalmente, mas a interface apresenta

problemas conforme o programa vai se repetindo. Depois da primeira entrada o comando leia sobe um pouquinho na tela de execução, como 

pode ser visto na imagem. Quanto mais entradas sao digitadas mais o comando vai comendo tela até ficar totalmente desalinhado com a tela de menu.

Alguem sabe como resolver isso? como o algoritmo funciona normal acho q deve ser problema de configuração, mas como resolver?

1116327233_Semttulo.thumb.png.b6bddd06a9379736f273a005f0273a09.png

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Joao_Bilu, por favor, poste o código completo em formato de texto para melhor analisarmos.

 

Obs.:  para inserir um código no fórum, antes clique no botão <>, como mostrado na imagem abaixo:

botao_code.png

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites
Algoritmo "SuperContador"

Var
   N, C, S: Inteiro

Inicio
   Repita
      Escreval("------------------------")
      Escreval("!        M E N U       !")
      Escreval("------------------------")
      Escreval("!  [1] De 1 a 10       !")
      Escreval("!  [2] De 10 a 1       !")
      Escreval("!  [3] Sair            !")
      Escreval("------------------------")
      Leia(S)
      Escolha S
      Caso 1
         N <- 1
         Repita
            Escreva ( N,".. ")
            N <- N + 1
         Ate(N > 10)
      Caso 2
         C <- 10
         Repita
            Escreva(C,".. ")
            C <- C - 1
         Ate(C < 1)
      Caso 3
         Escreval("Saindo ...")
      FimEscolha
   Ate(S = 3)
Fimalgoritmo

Esse é o codigo

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Joao_Bilu, falta pular para próxima linha após escrever os números. Acontece que ao terminar de escrever, o cursor (onde sai as letras) ainda está no fim da linha. Daí, o próximo texto está começando a partir de lá. Bastar fazer ir para o início da próxima linha, exemplo:

 

...
      fimEscolha
      escreval("")
   ate (S = 3)
fimAlgoritmo

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Deu certo agora, valeu simon

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

ADENDO:

Só para exemplificar melhor, alterei para exibir apenas um "." após cada número, veja:

 

tela.png

 

Daí, os traços do menu estão começando após o 10... alem disso o próprio VisualG (ou se preferir VisuAlg) é meio que bugado mesmo. Repare como "comeu" o 0 na tentativa abaixo, rs.

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Aaah agora entendi, eu achei que ,quando chegava no comando repete, a execução meio que zerava, mas pelo que parece tem que ter uma preparação final pra a proxima repetição

Aqui! uma outra duvida , você sabe porque no caso abaixo tá dando erro? aqui na execução aponta erro na linha 8, 

a ideia era contar de um até 10, eu ja tinha conseguido fazer isso, mas agora tá dando erro

Algoritmo "contar"

Var
A:Inteiro

Inicio
A <- 1
Enquanto(A <= 10) faca
Escreva(A,".. ")
A <- A + 1
FimEnquanto

Fimalgoritmo

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Joao_Bilu, pelo visto o problema está no "(" colado no Enquanto.

 

Em vez de:

6 horas atrás, Joao_Bilu disse:

Enquanto(A <= 10) faca

 

Usar:

Enquanto (A <= 10) faca

 

 

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas comunidades sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

Aprenda a ler resistores e capacitores

EBOOK GRÁTIS!

CLIQUE AQUI E BAIXE AGORA MESMO!