×
Ir ao conteúdo
  • Cadastre-se

C Transformar Pseudocódigo em Linguagem C


Nexus C

Posts recomendados

@Nexus C     esse pseudocódigo tem vários erros de syntaxes ,  como comandos fora da área adequada , e etc . . .  ,  e poderia bem ser assim  :

algoritmo EntrarNoTerminal
var
  cartao : logico
  idade  : inteiro
inicio
  escreva("Aproxime o cartao")
  escreva("idade: ")
  leia( idade )
  se idade >= 65 entao
    escreval("pague R$ 4,10")
  senao
    escreval("mostra a identidade")
  fimse
  escreva("Tem cartao de transporte ? 1 - sim  2 - não ")
  leia( cartao )
  se cartao = 1 entao
    escreval("pode passar")
  senao
    escreval("não pode entrar")
  fimse
fimalgoritmo

e para converter de uma Linguagem para outra você pode substituir os comando de uma pelo da outra , e assim o logico seria bool ,  o inteiro é int , os  se's são   if , o senao é else , e o escreva é o printf da Linguagem C ,  e depois que você fizer um código sobre esse exercício , e quiser / puder , poste ele aqui para vermos como está e em que podemos ajudar ,,,  .

  • Curtir 1
Link para o comentário
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisa ser um usuário para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas comunidades sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

Aprenda a ler resistores e capacitores

EBOOK GRÁTIS!

CLIQUE AQUI E BAIXE AGORA MESMO!