Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.

devair1010

Membros Plenos
  • Total de itens

    1.782
  • Registro em

  • Última visita

  • Qualificações

    0%

Reputação

1.137

Informações gerais

  • Cidade e Estado
    rio de janeiro/rj
  • Sexo
    Prefiro não dizer
  1. @Naty Ribeirotop isso é por que você não leu o poste todo , onde tem correções para o código , e o erro não é nessa linha , se compr(nome)=0 então interrompa o erro é aqui no final , se contador <> 0 ENTÃO pfilho:=100*contadorf/contador ph:=100*homem/contador pm:=100*mulher/contador escreval("A porcentagem de homens e mulheres é respectivamente:",ph,"% e",pm,"%.") escreval("Pessoas com renda familiar acima de R$500,00:",rena_acime_500," pessoas.") escreval("Porcentagem de pessoas que tenham ao menos um filho:",pfilho,"%.") escreval("Pessoas que nasceram a partir do ano 2000:",nasc_2000,".") fimse onde se o contador for zero e ele será usado como divisor , e um numero dividido por zero é impossível , por isso dá erro , assim precisa tratar essa possibilidade , evitando que isso aconteça . então o código com as modificações seria esse : Algoritmo "Entrevistas" Var nome : caractere idade : inteiro sexo : caractere filhos,j, homem, mulher, rena_acime_500: inteiro nasc_2000 : inteiro rendaf : real contador, contadorf : real ph,pm,pfilho : real Inicio para j de 1 ate 10 faca escreval ("DIGITE OS DADOS DO ENTREVISTADO") escreval ("Tecle ENTER para sair!") escreva ("Nome :") leia(nome) se compr(nome)=0 ENTÃO interrompa fimse escreva ("Idade :") leia(idade) se idade < 19 ENTÃO nasc_2000:=nasc_2000+1 fimse escreva ("Sexo [M ou F] :") leia(sexo) se sexo="M" ENTÃO homem:=homem+1 senao se sexo="F" ENTÃO mulher:=mulher+1 fimse fimse escreva ("Filhos :") leia(filhos) se filhos > 0 ENTÃO contadorf:=contadorf+1 fimse escreva ("Renda Familiar:R$") leia(rendaf) se rendaf >= 500.00 ENTÃO rena_acime_500:=rena_acime_500+1 fimse limpatela contador:=contador+1 fimpara se contador <> 0 ENTÃO pfilho:=100*contadorf/contador ph:=100*homem/contador pm:=100*mulher/contador escreval("A porcentagem de homens e mulheres é respectivamente:",ph,"% e",pm,"%.") escreval("Pessoas com renda familiar acima de R$500,00:",rena_acime_500," pessoas.") escreval("Porcentagem de pessoas que tenham ao menos um filho:",pfilho,"%.") escreval("Pessoas que nasceram a partir do ano 2000:",nasc_2000,".") fimse Fimalgoritmo
  2. @matheus william você não está zerando o vaium , então seu código com algumas modificações ficaria assim : #include <stdio.h> #include <windows.h> #define na 16 int main(){ int n,n1,r[na],r1[na],i,j,t,somav[na],vaium=0,invert[na],np=1; printf("Digite O Primeiro Numero: "); scanf("%d", &n); /* Utiliza um número de 16 bits como base para a conversão.*/ for(i = na-1; i >= 0; i--) { r[i] = (n >> i) & 1; /*Por meio do "e" lógico ele compara se o valor na posição mais à */ /* direita é 1 ou 0 e imprime na tela até reproduzir o número binário.*/ if(r[i] & 1) printf("1"); else printf("0"); } printf("\n"); printf("Digite O Segundo Numero: "); scanf("%d", &n1); n1=abs(n1); for(i = na-1; i >= 0; i--) { r1[i] = (n1 >> i) & 1; if(r1[i] & 1) printf("1"); else printf("0"); } printf("\n"); printf("R R1 Soma vaium\n\n"); for(i=0;i<na;i++){ somav[i]=r[i]+r1[i]+vaium; if(somav[i]==3 || somav[i]==1)t=1;else t=0; printf("%d + %d => %d <---> vaium = %d\n",r[i],r1[i],t,vaium); if((somav[i]==2)){ somav[i]=0; vaium=1; } else if(somav[i]==3){ somav[i]=1; vaium=1; } else vaium=0; Sleep(500); } printf("\n\nSoma Dos Numeros Binarios : "); for (i=na-1;i>=0;i--) printf("%d",somav[i]%2); printf("\n\n"); return 0; }
  3. @DONG YOL posta o rascunho mesmo , não tem problema se estiver errado não .
  4. @DONG YOL no enunciado pede para usar três funções , a do poliglota que pega a quantidade de línguas e retorna esse valor ao cubo , e a que calcula o salario base de acordo com o nível do cargo , e a fatorial que pega o grau de estudo e faz a fatorial , então a mais fácil é a do poliglota , faça ela se possível as outras duas também , e poste aqui .
  5. @DONG YOL você pode editar sua postagem , se quiser , e deletar essas duas partes repetida do seu código , deixando apenas aquela que está no meio que está certa , seu código está bom , precisa uma melhor organização , como o struct precisa ficar fora da main , precisa de um contador e o struct precisa ter várias posições pois senão nele só poderá guardar os dados de uma só pessoa , e o contador contará quantas pessoas foram cadastradas , e no final para mostrar o que foi guardado você pode colocar um laço de repetição , imprimindo todos os dados guardados , então essa parte do código ficaria assim : #include <stdio.h> #include <ctype.h> #include <stdlib.h> struct funcionario{ char nome[50]; int grau_de_estudo; int linguas_faladas; int cargo; float indice_produt; float salario; }; int cont,i; int main(){ struct funcionario novo[100]; char ch; do{ fflush(stdin); printf("Digite O Nome Do Funcionario:"); gets(novo[cont].nome); printf("Grau De Estudo:"); fflush(stdin); scanf("%d", &novo[cont].grau_de_estudo); fflush(stdin); printf("Quantas Linguas Faladas:"); scanf("%d", &novo[cont].linguas_faladas); fflush(stdin); printf("Informe O Cargo Que Ocupa:"); scanf("%d", &novo[cont].cargo); fflush(stdin); printf("I(nforme O Indice De Produtividade:"); scanf("%f", &novo[cont].indice_produt); fflush(stdin); printf("\n Informe O Salario Do Funcionario:"); scanf("%f", &novo[cont].salario); cont++; do{ fflush(stdin); printf("\n deseja cadastrar outro funcionario S/N "); scanf("%c", &ch); if((toupper(ch)!='S')&&(toupper(ch)!='N')){ printf("\n erro"); } }while(toupper(ch)!='N' && toupper(ch)!='S'); }while(toupper(ch)!='N'); system("pause"); for(i=0;i<cont;i++){ printf("====================================\n"); printf("Nome --------: %s \n",novo[i].nome ); printf("Grau --------: %d \n",novo[i].grau_de_estudo ); printf("Linguas -----: %d \n",novo[i].linguas_faladas); printf("Cargo -------: %d \n",novo[i].cargo ); printf("Indice ------: %.2f \n",novo[i].indice_produt ); printf("Salario -----: %.2f\n\n",novo[i].salario ); } return 0; }
  6. @DONG YOL esse programa seria para alguém que já tenha muito experiência , pois struct é bem complicado de entender , então creio que seja melhor fazer aos poucos , comece por pegar os dados das pessoas , e para isso primeiro crie a struct e dentro da função main coloque um do / while e dentro pegue os dados usando scanf ou gets e pergunte se quer pegar os dados de outra pessoa , se digitar n então sair do loop . faça essa parte e poste aqui para podermos ver como está e em que podemos ajudar .
  7. @abrunoab muito boa sua configuração , e uma boa fonte é a corsair cx 450 w , gabinete com espaço para fonte em baixo , não precisa de water cooler a menos que for fazer overclok , gabinete e hd ao seu gosto .
  8. @Igor Vargas depois de pegar a string que contém o e_mail , verifique se o email tem o arroba e se tem oito ou mais caracteres no inicio até o arroba e se tem o pontocom e se depois do arroba tem quatro ou mais caracteres até o pontocom .. nesse caso é válido .
  9. @apollosky1 veja nesse link um campo minado : e poste seu código para podermos ver como está e em que podemos ajudar .
  10. @Mahaus para gerar números aleatórios precisa usar a biblioteca time.h , pois senão os números sorteados serão sempre os mesmos , e use também a função srand(time(NULL)) e para imprimir a soma de cada linha coloque o somatório dentro do loop col e logo abaixo desse loop imprima o resultado , então essa parte ficaria assim : #include <time.h> dentro da main srand(time(NULL)); for (lin=0;lin<6;lin++){ somatorio_linha=0; for (col=0;col<6;col++){ mat[lin][col] = rand() % 100; somatorio_linha += mat[lin][col]; printf ("mat[%d][%d] = %d \n",lin,col,mat[lin][col]); } printf("\nsoma da linha %d = %d\n\n",lin,somatorio_linha); }
  11. @Igor Vargas então na hora de imprimir você precisa enviar esse vetor al por parâmetro .
  12. @Igor Vargas no primeiro você está usando scanf("%d",&al[a].grade[a][b]); e no segundo você usa o vetor (al_C[x].grade[x][y]==122)/* esse vetor é diferente do al[x] */
  13. @43 do pet olha nesse link :
  14. @43 do pet aqui no fórum tem alguns códigos desse jogo , faça uma pesquisa ali em cima na barra de pesquisa .
  15. @glaukito é o do / while mesmo , ele seria assim : #include <stdio.h> #include <stdlib.h> #include <math.h> #include <locale.h> #include <time.h> #include <conio.h> #include <cstdlib> #include <ctime> #include <ctype.h> float calc (float num1, float num2){ int op; char resp; float result, respUsu; srand(time(NULL)); do{ op= (rand() % 3)+1; switch (op){ case 1: printf ("qual é o resultado da soma dos valores? "); scanf ("%f", &respUsu); result= num1+num2; return result; break; case 2: printf ("qual é o resultado da subtração dos valores? "); scanf ("%f", &respUsu); result= num1-num2; return result; break; case 3: printf ("qual é o resultado da multiplicação dos valores?"); scanf ("%f", &respUsu); result= num1*num2; return result; break; case 4: printf ("qual é o resultado da divisão dos valores?"); scanf ("%f", &respUsu); result= num1/num2; return result; default: printf ("*****!!!!"); } printf("Quer Continuar S/N "); scanf("%c",&resp); }while(toupper(res) != 'N'); } int main (void){ setlocale (LC_CTYPE, "Portuguese"); char n=20, nome[n], final; float num1, num2, result; int i, j, op; printf ("digite seu nome: "); scanf ("%s", &nome); printf ("digite o primeiro valor: "); scanf ("%f", &num1); printf ("digite o segundo valor: "); scanf ("%f", &num2); for (i=0; i<=100; i++){ result= calc(num1, num2); printf ("%f\n", result); } }

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×